summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-03 10:26:14 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-03 10:26:14 +0000
commitf7eae6d95ad00a751d671ddcf272171bef115392 (patch)
tree1344fa2dd6ceafc085c7cf0927ea81b2ab9fee1f /net-libs
parentversion bump (diff)
downloadgentoo-2-f7eae6d95ad00a751d671ddcf272171bef115392.tar.gz
gentoo-2-f7eae6d95ad00a751d671ddcf272171bef115392.tar.bz2
gentoo-2-f7eae6d95ad00a751d671ddcf272171bef115392.zip
version bump
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/openh323/ChangeLog5
-rw-r--r--net-libs/openh323/Manifest4
-rw-r--r--net-libs/openh323/files/digest-openh323-1.12.21
-rw-r--r--net-libs/openh323/openh323-1.12.2.ebuild96
4 files changed, 104 insertions, 2 deletions
diff --git a/net-libs/openh323/ChangeLog b/net-libs/openh323/ChangeLog
index 5ae4a42616d5..52e1e2bf42b8 100644
--- a/net-libs/openh323/ChangeLog
+++ b/net-libs/openh323/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# $Header:
+*openh323-1.12.2 (03 Sep 2003)
+
+ 03 Sep 2003; Alastair Tse <liquidx@gentoo.org> openh323-1.12.2.ebuild:
+ version bump
+
09 Jul 2003; Martin Holzer <mholzer@gentoo.org> openh323-1.12.0-r1.ebuild:
Changed ffmpeg cat. Closes #24149
diff --git a/net-libs/openh323/Manifest b/net-libs/openh323/Manifest
index 836f64348254..040794c0cf05 100644
--- a/net-libs/openh323/Manifest
+++ b/net-libs/openh323/Manifest
@@ -1,9 +1,9 @@
-MD5 da9cbd1c5c3fdecaeac2aa4a883fee83 ChangeLog 3483
+MD5 71c6c1220fcfa7c3c0eb7d0f215a7a1c ChangeLog 3604
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 da0bf4fee9d0011905bcb66384df7b53 openh323-1.11.7.ebuild 1844
MD5 aa08dbdda7012bb3ee6c0e9ffef46f5b openh323-1.12.0-r1.ebuild 2714
MD5 c65a41c26c255742f72421fe4a6a8cb5 openh323-1.12.0.ebuild 2221
-MD5 aa08dbdda7012bb3ee6c0e9ffef46f5b openh323-1.12.2.ebuild 2714
+MD5 d8fb9ddd5b93f66ce4a3669ac37f9fd1 openh323-1.12.2.ebuild 2754
MD5 00792a32c848412e425a67c20a72b594 openh323-1.9.10-r1.ebuild 1120
MD5 e9ac1227eaf205c20f84a4fc712e8d66 files/digest-openh323-1.11.7 68
MD5 238a3a0b91aabce0a61e0dd5c4b9ee68 files/digest-openh323-1.12.0 68
diff --git a/net-libs/openh323/files/digest-openh323-1.12.2 b/net-libs/openh323/files/digest-openh323-1.12.2
new file mode 100644
index 000000000000..4f6acaf41c0f
--- /dev/null
+++ b/net-libs/openh323/files/digest-openh323-1.12.2
@@ -0,0 +1 @@
+MD5 15f0b12b60769d03eca9e498050776f3 openh323_1.12.2.tar.gz 2343354
diff --git a/net-libs/openh323/openh323-1.12.2.ebuild b/net-libs/openh323/openh323-1.12.2.ebuild
new file mode 100644
index 000000000000..3c3f023d942a
--- /dev/null
+++ b/net-libs/openh323/openh323-1.12.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.12.2.ebuild,v 1.1 2003/09/03 10:26:10 liquidx Exp $
+
+IUSE="ssl"
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Open Source implementation of the ITU H.323 teleconferencing protocol"
+HOMEPAGE="http://www.openh323.org"
+SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~ppc -sparc "
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-libs/pwlib-1.5.0
+ >=media-video/ffmpeg-0.4.7_pre20030624
+ ssl? ( dev-libs/openssl )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ # to prevent merge problems with broken makefiles from old
+ # pwlib versions, we double-check here.
+
+ if [ "` fgrep '\$(OPENSSLDIR)/include' /usr/share/pwlib/make/unix.mak`" ]
+ then
+ # patch unix.mak so it doesn't require annoying
+ # unmerge/merge cycle to upgrade
+ einfo "Fixing broken pwlib makefile."
+ cd /usr/share/pwlib/make
+ sed -i \
+ -e "s:-DP_SSL -I\$(OPENSSLDIR)/include -I\$(OPENSSLDIR)/crypto:-DP_SSL:" \
+ -e "s:^LDFLAGS.*\+= -L\$(OPENSSLDIR)/lib -L\$(OPENSSLDIR):LDFLAGS +=:" \
+ unix.mak
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ # enabling ffmpeg/h263 support
+ cd ${S}; sed -i -e "s:/usr/local/include/ffmpeg:/usr/include/ffmpeg:" configure
+}
+
+src_compile() {
+ local makeopts
+
+ export PWLIBDIR=/usr/share/pwlib
+ export PTLIB_CONFIG=/usr/bin/ptlib-config
+ export OPENH323DIR=${S}
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ makeopts="${makeopts} ASNPARSER=/usr/bin/asnparser NOTRACE=1"
+
+
+ if [ "`use ssl`" ]; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR=/usr
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+
+ econf || die
+ emake ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPENH323_ARCH ALT_ARCH
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+ OPENH323_ARCH="linux_${ARCH}_n"
+
+ dodir /usr/bin /usr/lib/ /usr/share
+ make PREFIX=${D}/usr install || die "install failed"
+ dobin ${S}/samples/simple/obj_${OPENH323_ARCH}/simph323
+
+ find ${D} -name 'CVS' -type d | xargs rm -rf
+
+ # mod to keep gnugk happy
+ insinto /usr/share/openh323/src
+ newins ${FILESDIR}/openh323-1.11.7-emptyMakefile Makefile
+
+ rm ${D}/usr/lib/libopenh323.so
+ dosym /usr/lib/libh323_${OPENH323_ARCH}.so.${PV} /usr/lib/libopenh323.so
+
+ # for backwards compatibility with _r versioned libraries
+ ALT_ARCH=${OPENH323_ARCH/_n/_r}
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ einfo "creating /usr/lib/libh323_${ALT_ARCH}.so.${pv} symlink"
+ dosym /usr/lib/libh323_${OPENH323_ARCH}.so.${PV} /usr/lib/libh323_${ALT_ARCH}.so.${pv}
+ done
+ dosym /usr/lib/libh323_${OPENH323_ARCH}.so.${PV} /usr/lib/libh323_${ALT_ARCH}.so
+
+}
+
+