summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-07-21 21:40:39 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-07-21 21:40:39 +0000
commitfe60f56beb7b35ca0538f7280faab07aaaed3706 (patch)
tree4a3aa4a7c681ada93c274a2cd44d9cd0e1b0d059 /net-libs
parentVersion bump. Better compatibility with python-2.6. (diff)
downloadgentoo-2-fe60f56beb7b35ca0538f7280faab07aaaed3706.tar.gz
gentoo-2-fe60f56beb7b35ca0538f7280faab07aaaed3706.tar.bz2
gentoo-2-fe60f56beb7b35ca0538f7280faab07aaaed3706.zip
Parallel make option and fix a nasty compile bug
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/ChangeLog6
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-0_p46126-wx-parallel-make.patch12
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild17
3 files changed, 27 insertions, 8 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 857217a5223c..746c44377c32 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.41 2009/07/21 21:02:24 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.42 2009/07/21 21:40:39 jokey Exp $
+
+ 21 Jul 2009; Markus Ullmann <jokey@gentoo.org> webkit-gtk-0_p46126.ebuild,
+ +files/webkit-gtk-0_p46126-wx-parallel-make.patch:
+ Parallel make option and fix a nasty compile bug
21 Jul 2009; Markus Ullmann <jokey@gentoo.org> webkit-gtk-0_p46126.ebuild:
Fix Quoting
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-wx-parallel-make.patch b/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-wx-parallel-make.patch
new file mode 100644
index 000000000000..6a1f3cd28086
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-wx-parallel-make.patch
@@ -0,0 +1,12 @@
+diff -urN ./WebKitTools.orig/wx/build-wxwebkit ./WebKitTools/wx/build-wxwebkit
+--- ./WebKitTools.orig/wx/build-wxwebkit 2009-06-30 21:27:58.000000000 +0200
++++ ./WebKitTools/wx/build-wxwebkit 2009-07-21 23:16:29.542350407 +0200
+@@ -179,7 +179,7 @@
+ cd $olddir
+ else
+ if [ -f $dir/GNUmakefile ]; then
+- make -C $dir -f GNUmakefile $MAKE_ARGS CXXFLAGS="$cxxflags -fvisibility=hidden -fvisibility-inlines-hidden" $@
++ make -C $dir -f GNUmakefile $MAKEOPTS $MAKE_ARGS CXXFLAGS="${CXXFLAGS} $cxxflags -fvisibility=hidden -fvisibility-inlines-hidden" $@
+ fi
+ fi
+ if [ $? != 0 ]; then
diff --git a/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild b/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild
index 644472c58cd7..e0b8f5e57c18 100644
--- a/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild,v 1.2 2009/07/21 21:02:24 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild,v 1.3 2009/07/21 21:40:39 jokey Exp $
EAPI=2
@@ -15,7 +15,7 @@ SRC_URI="http://nightly.webkit.org/files/trunk/src/${MY_P}.tar.bz2"
LICENSE="LGPL-2 LGPL-2.1 BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 -ia64 ~ppc -sparc ~x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 -ia64 ppc -sparc x86 ~x86-fbsd"
IUSE="coverage debug gstreamer pango soup sqlite svg wxwidgets xslt"
RDEPEND=">=x11-libs/gtk+-2.8
@@ -31,7 +31,7 @@ RDEPEND=">=x11-libs/gtk+-2.8
soup? ( >=net-libs/libsoup-2.27.4 )
xslt? ( dev-libs/libxslt )
pango? ( x11-libs/pango )
- wxwidgets? ( x11-libs/wxGTK dev-util/bakefile )"
+ wxwidgets? ( x11-libs/wxGTK )"
DEPEND="${RDEPEND}
dev-util/gperf
@@ -43,6 +43,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}/${P}-cxxmissing.patch"
epatch "${FILESDIR}/${P}-wxslot-gentoo.patch"
+ epatch "${FILESDIR}/${P}-wx-parallel-make.patch"
gtkdocize
eautoreconf
}
@@ -52,8 +53,8 @@ src_configure() {
use alpha && append-ldflags "-Wl,--no-relax"
local myconf
- use pango && myconf="${myconf} --with-font-backend=pango"
- use soup && myconf="${myconf} --with-http-backend=soup"
+ use pango && myconf="${myconf} --with-font-backend=pango"
+ use soup && myconf="${myconf} --with-http-backend=soup"
econf \
$(use_enable sqlite database) \
@@ -71,9 +72,11 @@ src_configure() {
src_compile() {
emake || die "emake failed"
-
+ read
if use wxwidgets ; then
- cd "${S}"/WebKitTools/wx
+ # Upstream without further comment
+ cp DerivedSources/JSDataGridC* bindings/js
+ cd ${S}/WebKitTools/wx
./build-wxwebkit || die "wxwebkit build failed"
fi
}