summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-15 11:28:56 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-15 11:28:56 +0000
commit12514a7333e538d5ffaebd06bc675903ff544724 (patch)
treeda5e1ce01b01c7f7ff57c15ae32f39264c497496 /net-mail/bincimap
parentMissing dep. Ogg::Vorbis::Header wrt #215581. (diff)
downloadgentoo-2-12514a7333e538d5ffaebd06bc675903ff544724.tar.gz
gentoo-2-12514a7333e538d5ffaebd06bc675903ff544724.tar.bz2
gentoo-2-12514a7333e538d5ffaebd06bc675903ff544724.zip
Cleanup, add patch to build w/ gcc-4.3 (#220727)
(Portage version: 2.1.5.5)
Diffstat (limited to 'net-mail/bincimap')
-rw-r--r--net-mail/bincimap/ChangeLog8
-rw-r--r--net-mail/bincimap/bincimap-1.2.11.ebuild91
-rw-r--r--net-mail/bincimap/bincimap-1.2.13.ebuild3
-rw-r--r--net-mail/bincimap/bincimap-1.3.3.ebuild92
-rw-r--r--net-mail/bincimap/files/bincimap-1.2-gcc43.patch64
-rw-r--r--net-mail/bincimap/files/bincimap-1.2.11-gentoo.diff32
-rw-r--r--net-mail/bincimap/files/bincimap-1.3.3-gentoo.diff135
7 files changed, 73 insertions, 352 deletions
diff --git a/net-mail/bincimap/ChangeLog b/net-mail/bincimap/ChangeLog
index 813b9c36fd00..6582a7581ac7 100644
--- a/net-mail/bincimap/ChangeLog
+++ b/net-mail/bincimap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/bincimap
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/bincimap/ChangeLog,v 1.47 2008/03/15 22:58:44 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/bincimap/ChangeLog,v 1.48 2008/06/15 11:28:55 dertobi123 Exp $
+
+ 15 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ -files/bincimap-1.2.11-gentoo.diff, +files/bincimap-1.2-gcc43.patch,
+ -files/bincimap-1.3.3-gentoo.diff, -bincimap-1.2.11.ebuild,
+ bincimap-1.2.13.ebuild, -bincimap-1.3.3.ebuild:
+ Cleanup, add patch to build w/ gcc-4.3 (#220727)
15 Mar 2008; Mark Loeser <halcy0n@gentoo.org> bincimap-1.2.11.ebuild,
bincimap-1.2.12.ebuild, bincimap-1.2.13.ebuild, bincimap-1.3.3.ebuild,
diff --git a/net-mail/bincimap/bincimap-1.2.11.ebuild b/net-mail/bincimap/bincimap-1.2.11.ebuild
deleted file mode 100644
index 6579200c26b9..000000000000
--- a/net-mail/bincimap/bincimap-1.2.11.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/bincimap/bincimap-1.2.11.ebuild,v 1.9 2008/03/15 22:58:44 halcy0n Exp $
-
-inherit eutils
-
-DESCRIPTION="IMAP server for Maildir"
-SRC_URI="http://www.bincimap.org/dl/tarballs/1.2/${P}final.tar.bz2"
-HOMEPAGE="http://www.bincimap.org/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 amd64 ~ppc"
-IUSE="ssl"
-
-DEPEND="virtual/libc
- ssl? ( dev-libs/openssl )"
-
-RDEPEND="${DEPEND}
- sys-process/daemontools
- sys-apps/ucspi-tcp
- net-mail/checkpassword
- !virtual/imapd"
-
-PROVIDE="virtual/imapd"
-
-S="${WORKDIR}/${P}final"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gentoo.diff
-}
-
-src_compile() {
- econf $(use_enable ssl) --sysconfdir=/etc/bincimap || die
- emake localstatedir=/etc/bincimap || die
-}
-
-src_install () {
- make DESTDIR="${D}" localstatedir=/etc/bincimap prefix=/usr install || die
- keepdir /var/log/bincimap || die
- if use ssl; then
- keepdir /var/log/bincimap-ssl || die
- fi
-
- dodoc AUTHORS ChangeLog INSTALL \
- NEWS README README.SSL TODO
-
- # backward compatibility
- dosym /etc/bincimap/service/bincimap /etc/bincimap/service/imap
- dosym /etc/bincimap/service/bincimaps /etc/bincimap/service/imaps
-}
-
-pkg_postinst() {
- elog "To start bicimap at boot you have to enable the /etc/init.d/svscan rc file"
- elog "and create the following link:"
- elog "ln -s /etc/bincimap/service/bincimap /service/bincimap"
- elog
-
- if use ssl; then
- elog "If you want to use ssl connections, create the following link:"
- elog "ln -s /etc/bincimap/service/bincimaps /service/bincimaps"
- elog
- elog "And this command will setup bincimap-ssl on your system."
- elog "emerge --config =${CATEGORY}/${PF}"
- elog
- fi
-
- elog "NOTE: Default Maildir path is '~/.maildir'. If you want to modify it,"
- elog "edit /etc/bincimap/bincimap.conf"
- elog
-}
-
-pkg_config() {
- if use ssl; then
- local pemfile=/etc/bincimap/bincimap.pem
- if [ ! -f $pemfile ]; then
- echo "Creating a self-signed ssl-cert:"
- /usr/bin/openssl req -new -x509 -nodes -out $pemfile -days 366 -keyout $pemfile
- chmod 640 $pemfile
-
- einfo "If You want to have a signed cert, do the following:"
- einfo "openssl req -new -nodes -out req.pem \\"
- einfo "-keyout $pemfile"
- einfo "chmod 640 $pemfile"
- einfo "Send req.pem to your CA to obtain signed_req.pem, and do:"
- einfo "cat signed_req.pem >> $pemfile"
- fi
- fi
-}
diff --git a/net-mail/bincimap/bincimap-1.2.13.ebuild b/net-mail/bincimap/bincimap-1.2.13.ebuild
index 14f43e530b2e..95f4b7388ac0 100644
--- a/net-mail/bincimap/bincimap-1.2.13.ebuild
+++ b/net-mail/bincimap/bincimap-1.2.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/bincimap/bincimap-1.2.13.ebuild,v 1.6 2008/03/15 22:58:44 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/bincimap/bincimap-1.2.13.ebuild,v 1.7 2008/06/15 11:28:55 dertobi123 Exp $
inherit eutils
@@ -30,6 +30,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-1.2-gcc43.patch
}
src_compile() {
diff --git a/net-mail/bincimap/bincimap-1.3.3.ebuild b/net-mail/bincimap/bincimap-1.3.3.ebuild
deleted file mode 100644
index 0bb9ae1869d5..000000000000
--- a/net-mail/bincimap/bincimap-1.3.3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/bincimap/bincimap-1.3.3.ebuild,v 1.7 2008/03/15 22:58:44 halcy0n Exp $
-
-inherit eutils
-
-DESCRIPTION="IMAP server for Maildir"
-SRC_URI="http://www.bincimap.org/dl/tarballs/1.3/${P}.tar.bz2"
-HOMEPAGE="http://www.bincimap.org/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86"
-IUSE="ssl"
-
-DEPEND="virtual/libc
- ssl? ( dev-libs/openssl )"
-
-RDEPEND="${DEPEND}
- sys-process/daemontools
- sys-apps/ucspi-tcp
- net-mail/checkpassword
- !virtual/imapd"
-
-PROVIDE="virtual/imapd"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gentoo.diff
-}
-
-src_compile() {
- econf $(use_enable ssl) --sysconfdir=/etc/bincimap \
- --datadir=/usr/share/doc/${PF} \
- --localstatedir=/etc/bincimap || die
- emake || die
-}
-
-src_install () {
- make DESTDIR="${D}" prefix=/usr install || die
- keepdir /var/log/bincimap || die
- if use ssl; then
- keepdir /var/log/bincimap-ssl || die
- fi
-
- # backward compatibility
- dosym /etc/bincimap/service/bincimap /etc/bincimap/service/imap
- dosym /etc/bincimap/service/bincimaps /etc/bincimap/service/imaps
-
- # rename
- mv "${D}"/etc/xinetd.d/{xinetd-bincimap,bincimap}
- mv "${D}"/etc/xinetd.d/{xinetd-bincimaps,bincimaps}
-}
-
-pkg_postinst() {
- elog "To start bicimap at boot you have to enable the /etc/init.d/svscan rc file"
- elog "and create the following link:"
- elog "ln -sf /etc/bincimap/service/bincimap /service/"
- elog
-
- if use ssl; then
- elog "If you want to use ssl connections, create the following link instead of above link."
- elog "ln -sf /etc/bincimap/service/bincimaps /service/"
- elog
- elog "And this command will setup bincimap-ssl on your system."
- elog "emerge --config =${CATEGORY}/${PF}"
- elog
- fi
-
- #elog "NOTE: Default Maildir path is '~/.maildir'. If you want to modify it, "
- #elog "edit /etc/bincimap/bincimap.conf"
- #elog
-}
-
-pkg_config() {
- if use ssl; then
- local pemfile=/etc/bincimap/bincimap.pem
- if [ ! -f $pemfile ]; then
- echo "Creating a self-signed ssl-cert:"
- /usr/bin/openssl req -new -x509 -nodes -out $pemfile -days 366 -keyout $pemfile
- chmod 640 $pemfile
-
- einfo "If You want to have a signed cert, do the following:"
- einfo "openssl req -new -nodes -out req.pem \\"
- einfo "-keyout $pemfile"
- einfo "chmod 640 $pemfile"
- einfo "Send req.pem to your CA to obtain signed_req.pem, and do:"
- einfo "cat signed_req.pem >> $pemfile"
- fi
- fi
-}
diff --git a/net-mail/bincimap/files/bincimap-1.2-gcc43.patch b/net-mail/bincimap/files/bincimap-1.2-gcc43.patch
new file mode 100644
index 000000000000..76cb3a96d6b5
--- /dev/null
+++ b/net-mail/bincimap/files/bincimap-1.2-gcc43.patch
@@ -0,0 +1,64 @@
+diff -NrU5 bincimap-1.2.13final.orig/src/convert.cc bincimap-1.2.13final/src/convert.cc
+--- bincimap-1.2.13final.orig/src/convert.cc 2005-01-08 11:20:48.000000000 +0100
++++ bincimap-1.2.13final/src/convert.cc 2008-05-07 12:32:33.000000000 +0200
+@@ -37,10 +37,12 @@
+
+ #include "convert.h"
+ #include "io.h"
+ #include <string>
+
++#include <cstring>
++
+ using namespace ::std;
+ using namespace Binc;
+
+ //------------------------------------------------------------------------
+ BincStream::BincStream(void)
+diff -NrU5 bincimap-1.2.13final.orig/src/convert.h bincimap-1.2.13final/src/convert.h
+--- bincimap-1.2.13final.orig/src/convert.h 2005-02-08 21:30:22.000000000 +0100
++++ bincimap-1.2.13final/src/convert.h 2008-05-07 12:32:33.000000000 +0200
+@@ -35,10 +35,11 @@
+ #include <config.h>
+ #endif
+
+ #ifndef convert_h_included
+ #define convert_h_included
++#include <cstdlib>
+ #include <string>
+ #include <vector>
+ #include <iomanip>
+ #include <iostream>
+
+@@ -46,10 +47,12 @@
+ #include <sys/stat.h>
+
+ #include "address.h"
+ #include "depot.h"
+
++#include <cstring>
++
+ namespace Binc {
+
+ //----------------------------------------------------------------------
+ inline std::string toString(int i_in)
+ {
+diff -NrU5 bincimap-1.2.13final.orig/src/tools.cc bincimap-1.2.13final/src/tools.cc
+--- bincimap-1.2.13final.orig/src/tools.cc 2005-01-08 11:20:48.000000000 +0100
++++ bincimap-1.2.13final/src/tools.cc 2008-05-07 12:32:33.000000000 +0200
+@@ -33,13 +33,16 @@
+ */
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
+ #include <errno.h>
++#include <cstdlib>
+
+ #include "tools.h"
+
++#include <cstring>
++
+ using namespace ::std;
+ using namespace Binc;
+
+ //------------------------------------------------------------------------
+ Tools::Tools(void)
diff --git a/net-mail/bincimap/files/bincimap-1.2.11-gentoo.diff b/net-mail/bincimap/files/bincimap-1.2.11-gentoo.diff
deleted file mode 100644
index 32841b1cfa88..000000000000
--- a/net-mail/bincimap/files/bincimap-1.2.11-gentoo.diff
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naru bincimap-1.2.11final.org/conf/bincimap.conf bincimap-1.2.11final/conf/bincimap.conf
---- bincimap-1.2.11final.org/conf/bincimap.conf 2004-04-18 20:23:28.000000000 +0100
-+++ bincimap-1.2.11final/conf/bincimap.conf 2004-04-24 13:53:10.011618795 +0100
-@@ -56,7 +56,7 @@
- type = "Maildir", /* only Maildir
- * support */
-
-- path = "Maildir", /* default path */
-+ path = ".maildir", /* default path */
-
- auto create inbox = "yes", /* create INBOX in
- * given format if
-diff -Naru bincimap-1.2.11final.org/service/log/run-ssl.in bincimap-1.2.11final/service/log/run-ssl.in
---- bincimap-1.2.11final.org/service/log/run-ssl.in 2004-03-02 20:16:02.000000000 +0000
-+++ bincimap-1.2.11final/service/log/run-ssl.in 2004-04-24 13:52:30.562843106 +0100
-@@ -14,5 +14,5 @@
-
- exec 2>&1
-
--exec multilog t n5 s1048576 @localstatedir@/log/bincimap-ssl
-+exec multilog t n5 s1048576 /var/log/bincimap-ssl
-
-diff -Naru bincimap-1.2.11final.org/service/log/run.in bincimap-1.2.11final/service/log/run.in
---- bincimap-1.2.11final.org/service/log/run.in 2004-03-02 20:16:02.000000000 +0000
-+++ bincimap-1.2.11final/service/log/run.in 2004-04-24 13:52:37.988613029 +0100
-@@ -14,5 +14,5 @@
-
- exec 2>&1
-
--exec multilog t n5 s1048576 @localstatedir@/log/bincimap
-+exec multilog t n5 s1048576 /var/log/bincimap
-
diff --git a/net-mail/bincimap/files/bincimap-1.3.3-gentoo.diff b/net-mail/bincimap/files/bincimap-1.3.3-gentoo.diff
deleted file mode 100644
index df829f30f47c..000000000000
--- a/net-mail/bincimap/files/bincimap-1.3.3-gentoo.diff
+++ /dev/null
@@ -1,135 +0,0 @@
-diff -Naru bincimap-1.3.3.org/Makefile.in bincimap-1.3.3/Makefile.in
---- bincimap-1.3.3.org/Makefile.in 2004-11-09 20:18:55.000000000 +0000
-+++ bincimap-1.3.3/Makefile.in 2004-11-19 09:54:41.000000000 +0000
-@@ -397,28 +397,28 @@
- @$(BINC_INSTALL_CONF) $(srcdir)/conf/bincimap-localconfig $(DESTDIR)$(sysconfdir) 755
- @echo
- @echo "* Run files"
-- @$(BINC_INSTALL_CONF) $(srcdir)/conf/xinetd-bincimap $(DESTDIR)$(sysconfdir)
-- @$(BINC_INSTALL_CONF) $(srcdir)/conf/xinetd-bincimaps $(DESTDIR)$(sysconfdir)
-+ @$(BINC_INSTALL_CONF) $(srcdir)/conf/xinetd-bincimap $(DESTDIR)/etc/xinetd.d
-+ @$(BINC_INSTALL_CONF) $(srcdir)/conf/xinetd-bincimaps $(DESTDIR)/etc/xinetd.d
- @echo
- @echo "* Service/run files"
-- @$(BINC_INSTALL_CONF) $(srcdir)/service/plain/run $(DESTDIR)$(datadir)/service/bincimap 755
-- @$(BINC_INSTALL_CONF) $(srcdir)/service/plain/log/run $(DESTDIR)$(datadir)/service/bincimap/log 755
-- @$(BINC_INSTALL_CONF) $(srcdir)/service/ssl/log/run $(DESTDIR)$(datadir)/service/bincimaps/log 755
-- @$(BINC_INSTALL_CONF) $(srcdir)/service/ssl/run $(DESTDIR)$(datadir)/service/bincimaps 755
-+ @$(BINC_INSTALL_CONF) $(srcdir)/service/plain/run $(DESTDIR)$(sysconfdir)/service/bincimap 755
-+ @$(BINC_INSTALL_CONF) $(srcdir)/service/plain/log/run $(DESTDIR)$(sysconfdir)/service/bincimap/log 755
-+ @$(BINC_INSTALL_CONF) $(srcdir)/service/ssl/log/run $(DESTDIR)$(sysconfdir)/service/bincimaps/log 755
-+ @$(BINC_INSTALL_CONF) $(srcdir)/service/ssl/run $(DESTDIR)$(sysconfdir)/service/bincimaps 755
- @echo
- @echo "* Documentation"
- @$(BINC_INSTALL_DOC) $(srcdir)/man/bincimap.1 $(DESTDIR)$(mandir)/man1
-- @$(BINC_INSTALL_DOC) $(srcdir)/ChangeLog $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/AUTHORS $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/COPYING $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/COPYING.OpenSSL $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/README $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/TODO $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-faq.html $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-goals.html $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-imapdir.html $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-tech.html $(DESTDIR)$(datadir)/doc/bincimap
-- @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-faq.html $(DESTDIR)$(datadir)/doc/bincimap
-+ @$(BINC_INSTALL_DOC) $(srcdir)/ChangeLog $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/AUTHORS $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/COPYING $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/COPYING.OpenSSL $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/README $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/TODO $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-faq.html $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-goals.html $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-imapdir.html $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-tech.html $(DESTDIR)$(datadir)
-+ @$(BINC_INSTALL_DOC) $(srcdir)/doc/bincimap-faq.html $(DESTDIR)$(datadir)
- @echo
- @echo "* Binaries"
- @$(BINC_INSTALL_BIN) src/bincimapd $(DESTDIR)$(bindir)
-diff -Naru bincimap-1.3.3.org/conf/xinetd-bincimap bincimap-1.3.3/conf/xinetd-bincimap
---- bincimap-1.3.3.org/conf/xinetd-bincimap 2004-11-09 20:08:05.000000000 +0000
-+++ bincimap-1.3.3/conf/xinetd-bincimap 2004-11-19 09:51:30.000000000 +0000
-@@ -13,14 +13,14 @@
- # description: Binc IMAP
- service imap
- {
-- disable = no
-+ disable = yes
- flags = REUSE
- socket_type = stream
- wait = no
- user = root
- group = root
- instances = UNLIMITED
-- server = /usr/local/etc/bincimap-config
-- server_args = /usr/local/bin/bincimap-up -- /bin/checkpassword /usr/local/etc/bincimap-localconfig /usr/local/bin/bincimapd Maildir
-+ server = /etc/bincimap/bincimap-config
-+ server_args = /usr/bin/bincimap-up -- /bin/checkpassword /etc/bincimap/bincimap-localconfig /usr/bin/bincimapd Maildir
- log_type = SYSLOG daemon info
- }
-diff -Naru bincimap-1.3.3.org/conf/xinetd-bincimap.in bincimap-1.3.3/conf/xinetd-bincimap.in
---- bincimap-1.3.3.org/conf/xinetd-bincimap.in 2004-05-24 10:17:16.000000000 +0100
-+++ bincimap-1.3.3/conf/xinetd-bincimap.in 2004-11-29 01:35:09.020518914 +0000
-@@ -13,7 +13,7 @@
- # description: Binc IMAP
- service imap
- {
-- disable = no
-+ disable = yes
- flags = REUSE
- socket_type = stream
- wait = no
-diff -Naru bincimap-1.3.3.org/conf/xinetd-bincimaps bincimap-1.3.3/conf/xinetd-bincimaps
---- bincimap-1.3.3.org/conf/xinetd-bincimaps 2004-11-09 20:08:05.000000000 +0000
-+++ bincimap-1.3.3/conf/xinetd-bincimaps 2004-11-19 09:50:53.000000000 +0000
-@@ -13,14 +13,14 @@
- # description: Binc IMAP, SSL
- service imaps
- {
-- disable = no
-+ disable = yes
- flags = REUSE
- socket_type = stream
- wait = no
- user = root
- group = root
- instances = UNLIMITED
-- server = /usr/local/etc/bincimap-config
-- server_args = /usr/local/bin/bincimap-up --enable-ssl -- /bin/checkpassword /usr/local/etc/bincimap-localconfig /usr/local/bin/bincimapd Maildir
-+ server = /etc/bincimap/bincimap-config
-+ server_args = /usr/bin/bincimap-up --enable-ssl -- /bin/checkpassword /etc/bincimap/bincimap-localconfig /usr/bin/bincimapd Maildir
- log_type = SYSLOG daemon info
- }
-diff -Naru bincimap-1.3.3.org/conf/xinetd-bincimaps.in bincimap-1.3.3/conf/xinetd-bincimaps.in
---- bincimap-1.3.3.org/conf/xinetd-bincimaps.in 2004-05-24 10:17:16.000000000 +0100
-+++ bincimap-1.3.3/conf/xinetd-bincimaps.in 2004-11-29 01:35:20.008893378 +0000
-@@ -13,7 +13,7 @@
- # description: Binc IMAP, SSL
- service imaps
- {
-- disable = no
-+ disable = yes
- flags = REUSE
- socket_type = stream
- wait = no
-diff -Naru bincimap-1.3.3.org/service/plain/log/run.in bincimap-1.3.3/service/plain/log/run.in
---- bincimap-1.3.3.org/service/plain/log/run.in 2004-06-17 21:37:33.000000000 +0100
-+++ bincimap-1.3.3/service/plain/log/run.in 2004-11-16 14:52:51.000000000 +0000
-@@ -14,5 +14,5 @@
-
- exec 2>&1
-
--exec multilog t n5 s1048576 @localstatedir@/log/bincimap
-+exec multilog t n5 s1048576 /var/log/bincimap
-
-diff -Naru bincimap-1.3.3.org/service/ssl/log/run.in bincimap-1.3.3/service/ssl/log/run.in
---- bincimap-1.3.3.org/service/ssl/log/run.in 2004-06-17 21:37:33.000000000 +0100
-+++ bincimap-1.3.3/service/ssl/log/run.in 2004-11-16 14:52:58.000000000 +0000
-@@ -14,5 +14,5 @@
-
- exec 2>&1
-
--exec multilog t n5 s1048576 @localstatedir@/log/bincimap-ssl
-+exec multilog t n5 s1048576 /var/log/bincimap-ssl
-