summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2008-08-06 20:05:33 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2008-08-06 20:05:33 +0000
commitcb0fd7c9b85f98c018244d3370bb976efd58521d (patch)
tree379db04ac5141d2c52bb197ee0e20172b5ca0bad /net-mail/dbmail
parentMake >=xmlrpc-c-1.14.07 multilib-strict safe. For real this time. Bug #233468... (diff)
downloadgentoo-2-cb0fd7c9b85f98c018244d3370bb976efd58521d.tar.gz
gentoo-2-cb0fd7c9b85f98c018244d3370bb976efd58521d.tar.bz2
gentoo-2-cb0fd7c9b85f98c018244d3370bb976efd58521d.zip
added 2.2.11_rc1 (bug # 233708) and 2.3.3
fixed init script for openrc (bug #225427) fixed download url for 2.3.x (Portage version: 2.2_rc6/cvs/Linux 2.6.24-gentoo-r3 x86_64)
Diffstat (limited to 'net-mail/dbmail')
-rw-r--r--net-mail/dbmail/ChangeLog13
-rw-r--r--net-mail/dbmail/dbmail-2.2.11_rc1.ebuild108
-rw-r--r--net-mail/dbmail/dbmail-2.3.2.ebuild8
-rw-r--r--net-mail/dbmail/dbmail-2.3.3.ebuild111
-rw-r--r--net-mail/dbmail/files/dbmail-timsieved.initd1
5 files changed, 236 insertions, 5 deletions
diff --git a/net-mail/dbmail/ChangeLog b/net-mail/dbmail/ChangeLog
index 19770bcc579f..3bab9abd7add 100644
--- a/net-mail/dbmail/ChangeLog
+++ b/net-mail/dbmail/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-mail/dbmail
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.28 2008/05/21 18:57:57 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.29 2008/08/06 20:05:32 lordvan Exp $
+
+*dbmail-2.3.3 (06 Aug 2008)
+*dbmail-2.2.11_rc1 (06 Aug 2008)
+
+ 06 Aug 2008; Thomas Raschbacher <lordvan@gentoo.org>
+ files/dbmail-timsieved.initd, +dbmail-2.2.11_rc1.ebuild,
+ dbmail-2.3.2.ebuild, +dbmail-2.3.3.ebuild:
+ Added 2.2.11 rc1 (Bug #233708 thanks to svrmarty <svrmarty@gmx.net>)
+ Added 2.3.3 devel release and fixed download url in 2.3.x
+ Fixed init script (Bug #225427 thanks to Chris Mayo
+ <mayo@clara.co.uk>)
21 May 2008; Tiziano Müller <dev-zero@gentoo.org> dbmail-2.2.7.ebuild,
dbmail-2.2.8.ebuild, dbmail-2.2.9.ebuild, dbmail-2.2.10.ebuild,
diff --git a/net-mail/dbmail/dbmail-2.2.11_rc1.ebuild b/net-mail/dbmail/dbmail-2.2.11_rc1.ebuild
new file mode 100644
index 000000000000..97210e49c851
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.11_rc1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.11_rc1.ebuild,v 1.1 2008/08/06 20:05:32 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}" # for rcX was without the - for versions < 2.2.6
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=virtual/postgresql-server-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ !mysql? ( !postgres? ( !sqlite3? ( >=dev-db/sqlite-3.0 ) ) )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "DBMail requires either SQLite3, PostgreSQL or MySQL."
+ elog "If none of the use-flags are specified SQLite3 is"
+ elog "used as default. To use another database please"
+ elog "specify the appropriate use-flag and re-emerge dbmail."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+}
diff --git a/net-mail/dbmail/dbmail-2.3.2.ebuild b/net-mail/dbmail/dbmail-2.3.2.ebuild
index b60eb1e67807..bfc7a4944284 100644
--- a/net-mail/dbmail/dbmail-2.3.2.ebuild
+++ b/net-mail/dbmail/dbmail-2.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.3.2.ebuild,v 1.6 2008/05/21 18:57:57 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.3.2.ebuild,v 1.7 2008/08/06 20:05:32 lordvan Exp $
inherit eutils
@@ -8,11 +8,11 @@ MY_P="${P/_/}" # for rcX
#MY_P="${P}" # releases
DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
HOMEPAGE="http://www.dbmail.org/"
-SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+SRC_URI="http://www.dbmail.org/download/2.3/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-amd64 -x86"
+KEYWORDS="-x86 -amd64"
IUSE="ldap mysql postgres sieve sqlite3 ssl static"
DEPEND="ssl? ( dev-libs/openssl )
@@ -106,4 +106,6 @@ pkg_postinst() {
elog "dbmail.conf and set it to the correct path"
elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
elog "A sample can be found in dbmail.conf.dist after etc-update."
+
+ ewarn "This is a Development release. use at own risk."
}
diff --git a/net-mail/dbmail/dbmail-2.3.3.ebuild b/net-mail/dbmail/dbmail-2.3.3.ebuild
new file mode 100644
index 000000000000..5287f8d63499
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.3.3.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.3.3.ebuild,v 1.1 2008/08/06 20:05:32 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/}" # for rcX
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.3/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-x86 -amd64"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=virtual/postgresql-server-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ !mysql? ( !postgres? ( !sqlite3? ( >=dev-db/sqlite-3.0 ) ) )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8
+ >=app-crypt/mhash-0.9.9-r1"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "DBMail requires either SQLite3, PostgreSQL or MySQL."
+ elog "If none of the use-flags are specified SQLite3 is"
+ elog "used as default. To use another database please"
+ elog "specify the appropriate use-flag and re-emerge dbmail."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+
+ ewarn "This is a Development release. use at own risk."
+}
diff --git a/net-mail/dbmail/files/dbmail-timsieved.initd b/net-mail/dbmail/files/dbmail-timsieved.initd
index 3fc4e047cfd7..325badb29fd4 100644
--- a/net-mail/dbmail/files/dbmail-timsieved.initd
+++ b/net-mail/dbmail/files/dbmail-timsieved.initd
@@ -26,7 +26,6 @@ start() {
ebegin "Starting DBMail SIEVE daemon"
start-stop-daemon --start --quiet \
--exec /usr/sbin/dbmail-timsieved \
- --name dbmail-timsieved \
-- -p ${PIDFILE} -f /etc/dbmail/dbmail.conf 2>&1
eend $?
}