summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-12-01 00:40:21 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-12-01 00:40:21 +0000
commit23044b44c9f288e6b1538f3c9025a1a5ff98d75f (patch)
tree198bca381133eea51af392f0ba546bd8c4150434 /net-mail/ezmlm-idx
parentpatch for newest tarball (diff)
downloadgentoo-2-23044b44c9f288e6b1538f3c9025a1a5ff98d75f.tar.gz
gentoo-2-23044b44c9f288e6b1538f3c9025a1a5ff98d75f.tar.bz2
gentoo-2-23044b44c9f288e6b1538f3c9025a1a5ff98d75f.zip
Added Ed Korthof's From: patch
Diffstat (limited to 'net-mail/ezmlm-idx')
-rw-r--r--net-mail/ezmlm-idx/ChangeLog8
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-0.40-r2.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/net-mail/ezmlm-idx/ChangeLog b/net-mail/ezmlm-idx/ChangeLog
index a9d161c8f884..c508469e5cea 100644
--- a/net-mail/ezmlm-idx/ChangeLog
+++ b/net-mail/ezmlm-idx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/ezmlm-idx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.2 2002/11/03 03:01:33 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.3 2002/12/01 00:40:21 drobbins Exp $
+
+*ezmlm-idx-0.40-r2 (30 Nov 2002)
+
+ 30 Nov 2002; Daniel Robbins <drobbins@gentoo.org>: Added Ed Korthof's
+ From: header patch to fix some issues we're experiencing on gentoo.org;
+ should be helpful for others as well.
*ezmlm-idx-0.40-r1 (02 Nov 2002)
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-0.40-r2.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-0.40-r2.ebuild
new file mode 100644
index 000000000000..66f49029a993
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-0.40-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ezmlm-idx-0.40-r2.ebuild,v 1.1 2002/12/01 00:40:21 drobbins Exp $
+
+# NOTE: ezmlm-idx, ezmlm-idx-mysql and ezmlm-idx-pgsql all supported by this single ebuild
+# (Please keep them in sync)
+
+PB=ezmlm-idx
+S2=${WORKDIR}/${PB}-${PV}
+S=${WORKDIR}/ezmlm-0.53
+GFILESDIR=${PORTDIR}/net-mail/${PB}/files/
+DESCRIPTION="Simple yet powerful mailing list manager for qmail."
+SRC_URI="http://gd.tuwien.ac.at/infosys/mail/qmail/ezmlm-patches/${PB}-${PV}.tar.gz http://cr.yp.to/software/ezmlm-0.53.tar.gz"
+HOMEPAGE="http://www.ezmlm.org"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+DEPEND="sys-apps/grep sys-apps/groff"
+RDEPEND="net-mail/qmail"
+PROVIDE="net-mail/ezmlm"
+
+if [ "$PN" = "${PB}-pgsql" ]
+then
+ DEPEND="$DEPEND dev-db/postgresql"
+ RDEPEND="$RDEPEND dev-db/postgresql"
+elif [ "$PN" = "${PB}-mysql" ]
+then
+ DEPEND="$DEPEND dev-db/mysql"
+ RDEPEND="$RDEPEND dev-db/mysql"
+fi
+
+src_unpack() {
+ unpack ${A}
+ cd ${S2}
+ mv ${S2}/* ${S} || die
+ cd ${S}
+ patch < idx.patch || die
+ #remove cat-man pages
+ cp MAN MAN.orig
+ cat MAN.orig | grep -v cat > MAN
+ echo "/usr/bin" > conf-bin
+ echo "/usr/share/man" > conf-man
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ #tweak the install to go to ${D}
+ cp Makefile Makefile.orig
+ sed -e "s:/install.*conf-bin\`\":/install ${D}usr/bin:" \
+ -e "s:/install.*conf-man\`\":/install ${D}usr/share/man:" Makefile.orig > Makefile
+ #apply patch from Ed Korthof (edk@collab.net) that allows ezmlm-issub and ezmlm-gate
+ #to check against the From: header as well as qmail's SENDER variable, which is set
+ #from the envelope sender and often reflects the local MTA rather than the user's
+ #"official" email address... enable this option by using "-f" with ezmlm-issub and/or
+ #ezmlm-gate.
+ cp ${GFILESDIR}/get_header.[ch] . || die
+ patch < ${GFILESDIR}/from-header.patch || die
+ echo ">>> Successfully applied Ed Korthof's From: header patch."
+}
+
+src_compile() {
+ cd ${S}
+ if [ "$PN" = "${PB}-pgsql" ]
+ then
+ make pgsql
+ elif [ "$PN" = "${PB}-mysql" ]
+ then
+ make mysql
+ fi
+ emake || die
+}
+
+src_install () {
+ install -d ${D}/usr/bin ${D}/usr/share/man ${D}/etc/ezmlm
+ make setup || die
+ mv ${D}/usr/bin/ez*rc ${D}/etc/ezmlm
+}