summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Berman <tberman@gentoo.org>2003-05-11 23:28:56 +0000
committerTodd Berman <tberman@gentoo.org>2003-05-11 23:28:56 +0000
commit25bd3e204132fcf2b8f47020f84852df72cf5cb6 (patch)
treecce251793fb45af365ff36d0070b5664f5a54611 /net-mail/hotwayd
parentInitial Import. (diff)
downloadgentoo-2-25bd3e204132fcf2b8f47020f84852df72cf5cb6.tar.gz
gentoo-2-25bd3e204132fcf2b8f47020f84852df72cf5cb6.tar.bz2
gentoo-2-25bd3e204132fcf2b8f47020f84852df72cf5cb6.zip
Initial Import.
Diffstat (limited to 'net-mail/hotwayd')
-rw-r--r--net-mail/hotwayd/ChangeLog9
-rw-r--r--net-mail/hotwayd/Manifest5
-rw-r--r--net-mail/hotwayd/files/digest-hotwayd-0.5.31
-rw-r--r--net-mail/hotwayd/files/hotwayd.xinetd26
-rw-r--r--net-mail/hotwayd/hotwayd-0.5.3.ebuild51
5 files changed, 90 insertions, 2 deletions
diff --git a/net-mail/hotwayd/ChangeLog b/net-mail/hotwayd/ChangeLog
new file mode 100644
index 000000000000..39d6059fd6eb
--- /dev/null
+++ b/net-mail/hotwayd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/hotwayd
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/ChangeLog,v 1.1 2003/05/11 23:28:51 tberman Exp $
+
+*hotwayd-0.5.3 (11 May 2003)
+
+ 11 May 2003; Todd Berman <tberman@gentoo.org> hotwayd-0.5.3.ebuild:
+ Initial commit.
+
diff --git a/net-mail/hotwayd/Manifest b/net-mail/hotwayd/Manifest
index 6e81a15fa559..77eb87d1756b 100644
--- a/net-mail/hotwayd/Manifest
+++ b/net-mail/hotwayd/Manifest
@@ -1,3 +1,4 @@
-MD5 9e38035109bf515948c866a047aa7956 hotwayd-0.5.3.ebuild 1718
-MD5 bde9d43d3e3db4a6b60263b6069f4005 files/hotwayd.xinetd 891
+MD5 ff970b3b5287d50de0c8359fe2718f23 hotwayd-0.5.3.ebuild 1819
+MD5 dca0272e105b047e283209c573f7da37 ChangeLog 334
+MD5 38800a211e0f1f2c9226af9ba80bfef7 files/hotwayd.xinetd 878
MD5 90c7357229f07f0723820b3b6810420b files/digest-hotwayd-0.5.3 66
diff --git a/net-mail/hotwayd/files/digest-hotwayd-0.5.3 b/net-mail/hotwayd/files/digest-hotwayd-0.5.3
new file mode 100644
index 000000000000..27789c65a468
--- /dev/null
+++ b/net-mail/hotwayd/files/digest-hotwayd-0.5.3
@@ -0,0 +1 @@
+MD5 64a40da8c0a78707b7053b4aca08fc35 hotwayd-0.5.3.tar.bz2 119626
diff --git a/net-mail/hotwayd/files/hotwayd.xinetd b/net-mail/hotwayd/files/hotwayd.xinetd
new file mode 100644
index 000000000000..a9b7c6a8dc94
--- /dev/null
+++ b/net-mail/hotwayd/files/hotwayd.xinetd
@@ -0,0 +1,26 @@
+# default: off
+# description: hotway daemon
+# - By default it listens to port 110 (default for pop3)
+# If you already have a pop3 server running, or you want it to listen
+# to another port change the value of "port = 110" below.
+# Change the value in your email client accordingly.
+# - By default it only allows access from localhost.
+# - Also all xinetd entries do not start by default.
+# One should manually enable the entries that one wants by
+# changing the value of "disable = yes" to "disable = no".
+# - Restart xinetd after changing anything in this file:
+# # /etc/init.d/xinetd restart
+
+service hotwayd
+{
+ only_from = localhost
+ socket_type = stream
+ wait = no
+ user = nobody
+ port = 110
+ server = /usr/sbin/hotwayd
+ server_args = -s
+ log_on_success += USERID
+ log_on_failure += USERID
+ disable = yes
+}
diff --git a/net-mail/hotwayd/hotwayd-0.5.3.ebuild b/net-mail/hotwayd/hotwayd-0.5.3.ebuild
new file mode 100644
index 000000000000..74e3dcea8c6d
--- /dev/null
+++ b/net-mail/hotwayd/hotwayd-0.5.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/hotwayd-0.5.3.ebuild,v 1.1 2003/05/11 23:28:52 tberman Exp $
+
+DESCRIPTION="Hotail to pop3 deamon"
+HOMEPAGE="http://hotwayd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hotwayd/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-apps/xinetd"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ # The original make install is broken, since it also tries to install
+ # the libghttp files. This is not needed, since this library is statically
+ # linked into the executable.
+ # Lets just copy the (one) file manually...
+ dosbin hotwayd
+
+ dodoc AUTHORS NEWS README
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/hotwayd.xinetd hotwayd
+}
+
+pkg_postinst () {
+ einfo "----------------------------------------------------------------"
+ einfo " By default daemons that use xinetd are not started "
+ einfo " automatically in gentoo"
+ einfo " To activate do the following steps: "
+ einfo " - Edit the file /etc/xinetd.d/hotwayd and change disable "
+ einfo " from yes to no "
+ einfo " - Add the following line to /etc/services: "
+ einfo " hotwayd 110/tcp "
+ einfo " - Note: if you already have a daemon serving port 110 (the "
+ einfo " default pop3 port); then change the port number to something "
+ einfo " else; also change the port number in hotwayd "
+ einfo " - If you already had xinetd up and running, restart with "
+ einfo " # /etc/init.d/xinetd restart "
+ einfo " or "
+ einfo " If the emerge also pulled in the xinetd package for you, do "
+ einfo " # rc-update add xinetd default "
+ einfo " # /etc/init.d/xinetd start "
+ einfo "-----------------------------------------------------------------"
+}