summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2004-09-03 20:47:12 +0000
committerTom Martin <slarti@gentoo.org>2004-09-03 20:47:12 +0000
commit3e4026bf9320c26014012ad38033f7b240000c41 (patch)
tree8a7c72d7b3582e654309b98de4bbba1e7ed2a8e5 /net-mail/kuvert
parentMarked ~amd64 (Manifest recommit) (diff)
downloadgentoo-2-3e4026bf9320c26014012ad38033f7b240000c41.tar.gz
gentoo-2-3e4026bf9320c26014012ad38033f7b240000c41.tar.bz2
gentoo-2-3e4026bf9320c26014012ad38033f7b240000c41.zip
Initial import, resolves #14567.
Diffstat (limited to 'net-mail/kuvert')
-rw-r--r--net-mail/kuvert/ChangeLog10
-rw-r--r--net-mail/kuvert/Manifest2
-rw-r--r--net-mail/kuvert/files/digest-kuvert-1.1.81
-rw-r--r--net-mail/kuvert/files/kuvert-1.1.8-idea.patch20
-rw-r--r--net-mail/kuvert/kuvert-1.1.8.ebuild41
-rw-r--r--net-mail/kuvert/metadata.xml9
6 files changed, 83 insertions, 0 deletions
diff --git a/net-mail/kuvert/ChangeLog b/net-mail/kuvert/ChangeLog
new file mode 100644
index 000000000000..f20167c36070
--- /dev/null
+++ b/net-mail/kuvert/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-mail/kuvert
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/kuvert/ChangeLog,v 1.1 2004/09/03 20:47:12 slarti Exp $
+
+*kuvert-1.1.8 (03 Sep 2004)
+
+ 03 Sep 2004; Tom Martin <slarti@gentoo.org> +kuvert-1.1.8.ebuild:
+ Initial import. The ebuild and the patch to get rid of idea stuff were
+ both submitted by Clemens Örtel <gentoo+sender+d53c44@kriegste.net> in bug
+ 14567.
diff --git a/net-mail/kuvert/Manifest b/net-mail/kuvert/Manifest
new file mode 100644
index 000000000000..271766d3e3d9
--- /dev/null
+++ b/net-mail/kuvert/Manifest
@@ -0,0 +1,2 @@
+MD5 369a0429537af6ed019361b31b45ee67 kuvert-1.1.8.ebuild 758
+MD5 c741dd345cce20ed816bcb2062765027 files/digest-kuvert-1.1.8 63
diff --git a/net-mail/kuvert/files/digest-kuvert-1.1.8 b/net-mail/kuvert/files/digest-kuvert-1.1.8
new file mode 100644
index 000000000000..2ec10fcf035e
--- /dev/null
+++ b/net-mail/kuvert/files/digest-kuvert-1.1.8
@@ -0,0 +1 @@
+MD5 fcce065ebac74fbf80fcf5120171cf3c kuvert_1.1.8.tar.gz 81328
diff --git a/net-mail/kuvert/files/kuvert-1.1.8-idea.patch b/net-mail/kuvert/files/kuvert-1.1.8-idea.patch
new file mode 100644
index 000000000000..d714e4eb4773
--- /dev/null
+++ b/net-mail/kuvert/files/kuvert-1.1.8-idea.patch
@@ -0,0 +1,20 @@
+--- kuvert.orig 2004-09-03 21:29:11.871880016 +0100
++++ kuvert 2004-09-03 21:28:59.299791264 +0100
+@@ -1179,7 +1179,7 @@
+ $cmd.="|$config{gpgpath} -q -t --batch --armor --detach-sign --passphrase-fd 0 --status-fd 1 --default-key";
+ if ($type eq "std")
+ {
+- $cmd.=" $config{stdkey} --rfc1991 --cipher-algo idea --digest-algo md5 --compress-algo 1";
++ $cmd.=" $config{stdkey} --rfc1991 --digest-algo md5 --compress-algo 1";
+ }
+ else
+ {
+@@ -1296,7 +1296,7 @@
+
+ # and finally encrypt all this for the wanted recipients.
+ unlink($outfile);
+- $cmd="$config{gpgpath} --no-literal --batch --encrypt --rfc1991 --cipher-algo idea "
++ $cmd="$config{gpgpath} --no-literal --batch --encrypt --rfc1991"
+ .($config{alwaystrust}?"--always-trust ":"")
+ ."--armor -o $outfile -r "
+ .join(" -r ",@recips)
diff --git a/net-mail/kuvert/kuvert-1.1.8.ebuild b/net-mail/kuvert/kuvert-1.1.8.ebuild
new file mode 100644
index 000000000000..960e01c03150
--- /dev/null
+++ b/net-mail/kuvert/kuvert-1.1.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/kuvert/kuvert-1.1.8.ebuild,v 1.1 2004/09/03 20:47:12 slarti Exp $
+
+MY_P=${P/-/_}
+
+DESCRIPTION="An MTA wrapper that automatically signs and/or encrypts
+outgoing mail"
+HOMEPAGE="http://www.snafu.priv.at/mystuff/kuvert/"
+SRC_URI="http://www.snafu.priv.at/mystuff/kuvert/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+SLOT="0"
+
+DEPEND=">=app-crypt/gnupg-1.0.6
+ >=app-crypt/quintuple-agent
+ dev-perl/MailTools
+ dev-perl/MIME-tools
+ dev-perl/TermReadKey
+ dev-lang/perl
+ virtual/mta
+ virtual/libc"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-idea.patch || die "epatch failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc dot-kuvert README THANKS TODO
+}
diff --git a/net-mail/kuvert/metadata.xml b/net-mail/kuvert/metadata.xml
new file mode 100644
index 000000000000..accb871b864d
--- /dev/null
+++ b/net-mail/kuvert/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>slarti@gentoo.org</email>
+ <name>Tom Martin</name>
+ </maintainer>
+</pkgmetadata>