summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-21 13:55:04 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-21 13:55:04 +0000
commit34a3936dada19d2a57e804f7bcca96c98c098297 (patch)
tree79529763b2f5a00f626c70896e53b1bf90d960d7 /net-mail/libdbx
parentNew package. Imported from kde overlay. Initial ebuild by Giorgos Tsiapaliwka... (diff)
downloadgentoo-2-34a3936dada19d2a57e804f7bcca96c98c098297.tar.gz
gentoo-2-34a3936dada19d2a57e804f7bcca96c98c098297.tar.bz2
gentoo-2-34a3936dada19d2a57e804f7bcca96c98c098297.zip
Do not call gcc directly (bug #462836).
(Portage version: 2.2.0_alpha183/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-mail/libdbx')
-rw-r--r--net-mail/libdbx/ChangeLog5
-rw-r--r--net-mail/libdbx/libdbx-1.0.3.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/net-mail/libdbx/ChangeLog b/net-mail/libdbx/ChangeLog
index d01747b0695f..a23dacf43bcb 100644
--- a/net-mail/libdbx/ChangeLog
+++ b/net-mail/libdbx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/libdbx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/ChangeLog,v 1.5 2013/03/23 17:08:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/ChangeLog,v 1.6 2013/06/21 13:55:04 jer Exp $
+
+ 21 Jun 2013; Jeroen Roovers <jer@gentoo.org> libdbx-1.0.3.ebuild:
+ Do not call gcc directly (bug #462836).
23 Mar 2013; Agostino Sarubbo <ago@gentoo.org> libdbx-1.0.3.ebuild:
Add ~amd64, wrt bug #462816
diff --git a/net-mail/libdbx/libdbx-1.0.3.ebuild b/net-mail/libdbx/libdbx-1.0.3.ebuild
index 280a49befd27..79781417d9bf 100644
--- a/net-mail/libdbx/libdbx-1.0.3.ebuild
+++ b/net-mail/libdbx/libdbx-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/libdbx-1.0.3.ebuild,v 1.6 2013/03/23 17:08:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/libdbx-1.0.3.ebuild,v 1.7 2013/06/21 13:55:04 jer Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
HOMEPAGE="http://sourceforge.net/projects/ol2mbox"
@@ -26,10 +26,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/bad_c.patch"
- sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/' Makefile
+ sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/;s|gcc|$(CC)|g' Makefile
}
src_compile() {
+ tc-export CC
emake || die
}