summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-02-12 09:52:13 +0000
committerThilo Bangert <bangert@gentoo.org>2010-02-12 09:52:13 +0000
commit715f3834d7b8d442d2fa298842577790cb54ea01 (patch)
tree587a2787e63f8d7f5b5340705d0e102458726381 /net-mail/mailfront
parentversion bump - dont pre-strip (diff)
downloadgentoo-2-715f3834d7b8d442d2fa298842577790cb54ea01.tar.gz
gentoo-2-715f3834d7b8d442d2fa298842577790cb54ea01.tar.bz2
gentoo-2-715f3834d7b8d442d2fa298842577790cb54ea01.zip
version bump (#297289) - dont pre-strip (#297989)
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'net-mail/mailfront')
-rw-r--r--net-mail/mailfront/ChangeLog8
-rw-r--r--net-mail/mailfront/mailfront-0.88.ebuild4
-rw-r--r--net-mail/mailfront/mailfront-0.98.ebuild6
-rw-r--r--net-mail/mailfront/mailfront-1.12.ebuild64
4 files changed, 76 insertions, 6 deletions
diff --git a/net-mail/mailfront/ChangeLog b/net-mail/mailfront/ChangeLog
index 32cdecce763a..ae3932843400 100644
--- a/net-mail/mailfront/ChangeLog
+++ b/net-mail/mailfront/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mailfront
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/ChangeLog,v 1.25 2010/01/14 15:15:26 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/ChangeLog,v 1.26 2010/02/12 09:52:13 bangert Exp $
+
+*mailfront-1.12 (12 Feb 2010)
+
+ 12 Feb 2010; Thilo Bangert <bangert@gentoo.org> mailfront-0.88.ebuild,
+ mailfront-0.98.ebuild, +mailfront-1.12.ebuild:
+ version bump (#297289) - dont pre-strip (#297989)
14 Jan 2010; Thilo Bangert <bangert@gentoo.org> mailfront-0.88.ebuild:
fix SRC_URI
diff --git a/net-mail/mailfront/mailfront-0.88.ebuild b/net-mail/mailfront/mailfront-0.88.ebuild
index 9e7d75293faa..9fe014e9f0d1 100644
--- a/net-mail/mailfront/mailfront-0.88.ebuild
+++ b/net-mail/mailfront/mailfront-0.88.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.88.ebuild,v 1.14 2010/01/14 15:15:26 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.88.ebuild,v 1.15 2010/02/12 09:52:13 bangert Exp $
inherit fixheadtails toolchain-funcs
@@ -30,7 +30,7 @@ src_compile() {
echo "/usr/lib/bglibs/lib" > conf-bglibs
echo "/var/qmail/bin" > conf-bin
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
- echo "$(tc-getCC) -s" > conf-ld
+ echo "$(tc-getCC) " > conf-ld
emake || die
}
diff --git a/net-mail/mailfront/mailfront-0.98.ebuild b/net-mail/mailfront/mailfront-0.98.ebuild
index 4a2421e4fa9b..c846b5389c47 100644
--- a/net-mail/mailfront/mailfront-0.98.ebuild
+++ b/net-mail/mailfront/mailfront-0.98.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.98.ebuild,v 1.6 2009/09/23 19:07:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.98.ebuild,v 1.7 2010/02/12 09:52:13 bangert Exp $
inherit toolchain-funcs
@@ -29,7 +29,7 @@ src_compile() {
echo "/var/qmail" > conf-qmail
echo "${D}/var/qmail/bin" > conf-bin
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
- echo "$(tc-getCC) -s" > conf-ld
+ echo "$(tc-getCC)" > conf-ld
emake || die
}
diff --git a/net-mail/mailfront/mailfront-1.12.ebuild b/net-mail/mailfront/mailfront-1.12.ebuild
new file mode 100644
index 000000000000..5cae247293b0
--- /dev/null
+++ b/net-mail/mailfront/mailfront-1.12.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-1.12.ebuild,v 1.1 2010/02/12 09:52:13 bangert Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Mail server network protocol front-ends"
+HOMEPAGE="http://untroubled.org/mailfront/"
+SRC_URI="http://untroubled.org/mailfront/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/bglibs-1.106
+ >=net-libs/cvm-0.81"
+
+RDEPEND="${DEPEND}
+ virtual/qmail
+ net-libs/cvm"
+
+src_configure() {
+ echo "/usr/include/bglibs/" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs/" > conf-bglibs
+ echo "/var/qmail" > conf-qmail
+ echo "/var/qmail/bin" > conf-bin
+ echo "/usr/$(get_libdir)/mailfront" > conf-modules
+ echo "/usr/include/mailfront" > conf-include
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${CFLAGS} -fPIC -shared" > conf-ccso
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ #dodir /var/qmail/bin
+ emake install install_prefix="${D}" || die "install failed"
+ exeinto /var/qmail/supervise/qmail-smtpd
+ newexe "${FILESDIR}"/run-smtpfront run.mailfront
+ exeinto /var/qmail/supervise/qmail-pop3d
+ newexe "${FILESDIR}"/run-pop3front run.mailfront
+
+ dodoc ANNOUNCEMENT ChangeLog NEWS README VERSION
+ dohtml *.html
+}
+
+pkg_config() {
+ cd "${ROOT}"/var/qmail/supervise/qmail-smtpd/
+ cp run run.qmail-smtpd.`date +%Y%m%d%H%M%S` && cp run.mailfront run
+ cd "${ROOT}"/var/qmail/supervise/qmail-pop3d/
+ cp run run.qmail-pop3d.`date +%Y%m%d%H%M%S` && cp run.mailfront run
+}
+
+pkg_postinst() {
+ echo
+ elog "Run"
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog "to update your run files (backups are created) in"
+ elog " /var/qmail/supervise/qmail-pop3d and"
+ elog " /var/qmail/supervise/qmail-smtpd"
+ echo
+}