summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-04-12 23:18:10 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-04-12 23:18:10 +0000
commitfef787930b7b6c0c3d417509d0bca3c2a900472a (patch)
tree7678e1ba8ba933e0a3d499ccedbfc806c3e03596 /net-mail/mpack/mpack-1.5-r1.ebuild
parentnew upstream release, fixes #78435. added ~amd64 to KEYWORDS. (diff)
downloadgentoo-2-fef787930b7b6c0c3d417509d0bca3c2a900472a.tar.gz
gentoo-2-fef787930b7b6c0c3d417509d0bca3c2a900472a.tar.bz2
gentoo-2-fef787930b7b6c0c3d417509d0bca3c2a900472a.zip
Fix #84828, install some docs.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-mail/mpack/mpack-1.5-r1.ebuild')
-rw-r--r--net-mail/mpack/mpack-1.5-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-mail/mpack/mpack-1.5-r1.ebuild b/net-mail/mpack/mpack-1.5-r1.ebuild
index 513f51685149..59dfa7ad2153 100644
--- a/net-mail/mpack/mpack-1.5-r1.ebuild
+++ b/net-mail/mpack/mpack-1.5-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/mpack-1.5-r1.ebuild,v 1.9 2004/07/15 01:51:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/mpack-1.5-r1.ebuild,v 1.10 2005/04/12 23:18:10 ticho Exp $
+
+inherit eutils
S=${WORKDIR}/${PN}
DESCRIPTION="Command-line MIME encoding and decoding utilities"
@@ -17,7 +19,8 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${P}-src.tar.Z
cd ${S}
- patch -l -p1 <${FILESDIR}/${P}-r1.patch
+ patch -l -p1 <${FILESDIR}/${P}-r1.patch || die "patch failed"
+ epatch ${FILESDIR}/${P}-malloc-fix.patch || die "epatch failed"
}
src_compile() {
@@ -27,4 +30,5 @@ src_compile() {
src_install () {
dodir /usr
make DESTDIR=${D}/usr install || die
+ dodoc README.* SCOPTIONS
}