summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-28 04:52:10 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-28 04:52:10 +0000
commitea165a99e039b05beb7a235ab80c806a840d1d61 (patch)
tree8af64dfed25905af350a31c3917090dfbf5fd836 /net-mail/mutt
parentminor typo (diff)
downloadgentoo-2-ea165a99e039b05beb7a235ab80c806a840d1d61.tar.gz
gentoo-2-ea165a99e039b05beb7a235ab80c806a840d1d61.tar.bz2
gentoo-2-ea165a99e039b05beb7a235ab80c806a840d1d61.zip
compressed folders support added
Diffstat (limited to 'net-mail/mutt')
-rw-r--r--net-mail/mutt/ChangeLog9
-rw-r--r--net-mail/mutt/files/digest-mutt-1.4-r11
-rw-r--r--net-mail/mutt/mutt-1.4-r1.ebuild59
3 files changed, 68 insertions, 1 deletions
diff --git a/net-mail/mutt/ChangeLog b/net-mail/mutt/ChangeLog
index 5c7a95d9754c..c2c2085835ff 100644
--- a/net-mail/mutt/ChangeLog
+++ b/net-mail/mutt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/mutt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.4 2002/05/29 21:29:34 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.5 2002/07/28 04:52:10 seemant Exp $
+
+*mutt-1.4-r1 (27 Jul 2002)
+
+ 27 Jul 2002; Seemant Kulleen <seemant@gentoo.org> mutt-1.4-r1.ebuild :
+
+ Enabled support for compressed folders. Submitted by Lim Swee Tat
+ <st_lim@eXtropia.com> in an email to me.
*mutt-1.4 (29 May 2002)
diff --git a/net-mail/mutt/files/digest-mutt-1.4-r1 b/net-mail/mutt/files/digest-mutt-1.4-r1
new file mode 100644
index 000000000000..177f7deab9a7
--- /dev/null
+++ b/net-mail/mutt/files/digest-mutt-1.4-r1
@@ -0,0 +1 @@
+MD5 a67bcdf1a1cd53d61ccd3ebf3993ba59 mutt-1.4i.tar.gz 2554158
diff --git a/net-mail/mutt/mutt-1.4-r1.ebuild b/net-mail/mutt/mutt-1.4-r1.ebuild
new file mode 100644
index 000000000000..952b711b3082
--- /dev/null
+++ b/net-mail/mutt/mutt-1.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.4-r1.ebuild,v 1.1 2002/07/28 04:52:10 seemant Exp $
+
+S=$WORKDIR/${P}
+DESCRIPTION="a small but very powerful text-based mail client"
+SRC_URI="ftp://ftp.mutt.org/pub/mutt/mutt-${PV}i.tar.gz"
+HOMEPAGE="http://www.mutt.org"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ slang? ( >=sys-libs/slang-1.4.2 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ # --without-slang doesn't work;
+ # specify --with-curses if you don't want slang
+ # (26 Sep 2001 agriffis)
+
+ use slang \
+ && myconf="${myconf} --with-slang" \
+ || myconf="${myconf} --with-curses"
+
+ econf \
+ --sysconfdir=/etc/mutt \
+ --with-docdir=/usr/share/doc/mutt-$PVR \
+ --with-regex --enable-pop --enable-imap --enable-nfs-fix \
+ --disable-fcntl --enable-flock --enable-external-dotlock \
+ --with-homespool=Maildir \
+ --enable-compressed \
+ ${myconf} || die
+
+ cp doc/Makefile doc/Makefile.orig
+ sed 's/README.UPGRADE//' doc/Makefile.orig > doc/Makefile
+ make || die "make failed (myconf=${myconf})"
+}
+
+src_install () {
+ make DESTDIR=$D install || die
+ find $D/usr/share/doc -type f |grep -v html | xargs gzip
+ insinto /etc/mutt
+ doins $FILESDIR/Muttrc
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}