summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-09-14 17:26:31 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-09-14 17:26:31 +0000
commit9ce0bb75df63a4e3a1cc90e60b66d2dbed97a461 (patch)
tree4287e8a9db22384f2550bc506344173ee137fe3b /net-mail/notmuch
parentAdded ebuild for milton-mail-api - mailing library of the milton framework (diff)
downloadgentoo-2-9ce0bb75df63a4e3a1cc90e60b66d2dbed97a461.tar.gz
gentoo-2-9ce0bb75df63a4e3a1cc90e60b66d2dbed97a461.tar.bz2
gentoo-2-9ce0bb75df63a4e3a1cc90e60b66d2dbed97a461.zip
Ensure test phase fails if any test in suite fails. Rels bug #483988.
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/ChangeLog12
-rw-r--r--net-mail/notmuch/files/0.12-0001-test-exit-with-nonzero-value-when-not-.patch56
-rw-r--r--net-mail/notmuch/files/0.13.1-0001-test-exit-with-nonzero-value-when-not-.patch56
-rw-r--r--net-mail/notmuch/files/0.14-0001-test-exit-with-nonzero-value-when-not-.patch56
-rw-r--r--net-mail/notmuch/files/0.15.2-0001-test-exit-with-nonzero-value-when-not-.patch56
-rw-r--r--net-mail/notmuch/files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch56
-rw-r--r--net-mail/notmuch/notmuch-0.12.ebuild5
-rw-r--r--net-mail/notmuch/notmuch-0.13.1.ebuild5
-rw-r--r--net-mail/notmuch/notmuch-0.14-r1.ebuild5
-rw-r--r--net-mail/notmuch/notmuch-0.15.2.ebuild8
-rw-r--r--net-mail/notmuch/notmuch-0.16-r1.ebuild5
11 files changed, 305 insertions, 15 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index e157b789183a..aaf8152c1746 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.78 2013/09/06 13:10:15 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.79 2013/09/14 17:26:31 aidecoe Exp $
+
+ 14 Sep 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> notmuch-0.12.ebuild,
+ notmuch-0.13.1.ebuild, notmuch-0.14-r1.ebuild, notmuch-0.15.2.ebuild,
+ notmuch-0.16-r1.ebuild,
+ +files/0.12-0001-test-exit-with-nonzero-value-when-not-.patch,
+ +files/0.13.1-0001-test-exit-with-nonzero-value-when-not-.patch,
+ +files/0.14-0001-test-exit-with-nonzero-value-when-not-.patch,
+ +files/0.15.2-0001-test-exit-with-nonzero-value-when-not-.patch,
+ +files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch:
+ Ensure test phase fails if any test in suite fails. Rels bug #483988.
06 Sep 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> -notmuch-0.16.ebuild:
Removing old revision of 0.16 version.
diff --git a/net-mail/notmuch/files/0.12-0001-test-exit-with-nonzero-value-when-not-.patch b/net-mail/notmuch/files/0.12-0001-test-exit-with-nonzero-value-when-not-.patch
new file mode 100644
index 000000000000..f66a12497320
--- /dev/null
+++ b/net-mail/notmuch/files/0.12-0001-test-exit-with-nonzero-value-when-not-.patch
@@ -0,0 +1,56 @@
+From c1f05bfb791e82776f5759e38c758cedd7e6190f Mon Sep 17 00:00:00 2001
+From: Tomi Ollila <tomi.ollila@iki.fi>
+Date: Sun, 8 Sep 2013 18:53:30 +0300
+Subject: [PATCH] test: exit with nonzero value when not all tests completed
+ successfully
+
+If any of the tests in our test system is not passing the execution
+of the test suite completes with nonzero exit value.
+
+It is better to rely on the exit value of the test system instead
+of some arbitrary strings in test output (or use both).
+---
+ test/aggregate-results.sh | 9 +++++++++
+ test/notmuch-test | 3 +++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/test/aggregate-results.sh b/test/aggregate-results.sh
+index 732d6ca..b016edb 100755
+--- a/test/aggregate-results.sh
++++ b/test/aggregate-results.sh
+@@ -1,5 +1,7 @@
+ #!/usr/bin/env bash
+
++set -eu
++
+ fixed=0
+ success=0
+ failed=0
+@@ -79,3 +81,10 @@ if [ "$skipped" != "0" ]; then
+ tests=$(pluralize "test" $skipped)
+ echo "$skipped $tests skipped."
+ fi
++
++if [ $success -gt 0 -a $fixed -eq 0 -a $failed -eq 0 -a $skipped -eq 0 ]
++then
++ exit 0
++else
++ exit 1
++fi
+diff --git a/test/notmuch-test b/test/notmuch-test
+index 6db7979..aa28bb0 100755
+--- a/test/notmuch-test
++++ b/test/notmuch-test
+@@ -97,6 +97,9 @@ trap - HUP INT TERM
+
+ # Report results
+ ./aggregate-results.sh test-results/*
++ev=$?
+
+ # Clean up
+ rm -rf test-results corpus.mail
++
++exit $ev
+--
+1.8.3.2
+
diff --git a/net-mail/notmuch/files/0.13.1-0001-test-exit-with-nonzero-value-when-not-.patch b/net-mail/notmuch/files/0.13.1-0001-test-exit-with-nonzero-value-when-not-.patch
new file mode 100644
index 000000000000..f66a12497320
--- /dev/null
+++ b/net-mail/notmuch/files/0.13.1-0001-test-exit-with-nonzero-value-when-not-.patch
@@ -0,0 +1,56 @@
+From c1f05bfb791e82776f5759e38c758cedd7e6190f Mon Sep 17 00:00:00 2001
+From: Tomi Ollila <tomi.ollila@iki.fi>
+Date: Sun, 8 Sep 2013 18:53:30 +0300
+Subject: [PATCH] test: exit with nonzero value when not all tests completed
+ successfully
+
+If any of the tests in our test system is not passing the execution
+of the test suite completes with nonzero exit value.
+
+It is better to rely on the exit value of the test system instead
+of some arbitrary strings in test output (or use both).
+---
+ test/aggregate-results.sh | 9 +++++++++
+ test/notmuch-test | 3 +++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/test/aggregate-results.sh b/test/aggregate-results.sh
+index 732d6ca..b016edb 100755
+--- a/test/aggregate-results.sh
++++ b/test/aggregate-results.sh
+@@ -1,5 +1,7 @@
+ #!/usr/bin/env bash
+
++set -eu
++
+ fixed=0
+ success=0
+ failed=0
+@@ -79,3 +81,10 @@ if [ "$skipped" != "0" ]; then
+ tests=$(pluralize "test" $skipped)
+ echo "$skipped $tests skipped."
+ fi
++
++if [ $success -gt 0 -a $fixed -eq 0 -a $failed -eq 0 -a $skipped -eq 0 ]
++then
++ exit 0
++else
++ exit 1
++fi
+diff --git a/test/notmuch-test b/test/notmuch-test
+index 6db7979..aa28bb0 100755
+--- a/test/notmuch-test
++++ b/test/notmuch-test
+@@ -97,6 +97,9 @@ trap - HUP INT TERM
+
+ # Report results
+ ./aggregate-results.sh test-results/*
++ev=$?
+
+ # Clean up
+ rm -rf test-results corpus.mail
++
++exit $ev
+--
+1.8.3.2
+
diff --git a/net-mail/notmuch/files/0.14-0001-test-exit-with-nonzero-value-when-not-.patch b/net-mail/notmuch/files/0.14-0001-test-exit-with-nonzero-value-when-not-.patch
new file mode 100644
index 000000000000..f66a12497320
--- /dev/null
+++ b/net-mail/notmuch/files/0.14-0001-test-exit-with-nonzero-value-when-not-.patch
@@ -0,0 +1,56 @@
+From c1f05bfb791e82776f5759e38c758cedd7e6190f Mon Sep 17 00:00:00 2001
+From: Tomi Ollila <tomi.ollila@iki.fi>
+Date: Sun, 8 Sep 2013 18:53:30 +0300
+Subject: [PATCH] test: exit with nonzero value when not all tests completed
+ successfully
+
+If any of the tests in our test system is not passing the execution
+of the test suite completes with nonzero exit value.
+
+It is better to rely on the exit value of the test system instead
+of some arbitrary strings in test output (or use both).
+---
+ test/aggregate-results.sh | 9 +++++++++
+ test/notmuch-test | 3 +++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/test/aggregate-results.sh b/test/aggregate-results.sh
+index 732d6ca..b016edb 100755
+--- a/test/aggregate-results.sh
++++ b/test/aggregate-results.sh
+@@ -1,5 +1,7 @@
+ #!/usr/bin/env bash
+
++set -eu
++
+ fixed=0
+ success=0
+ failed=0
+@@ -79,3 +81,10 @@ if [ "$skipped" != "0" ]; then
+ tests=$(pluralize "test" $skipped)
+ echo "$skipped $tests skipped."
+ fi
++
++if [ $success -gt 0 -a $fixed -eq 0 -a $failed -eq 0 -a $skipped -eq 0 ]
++then
++ exit 0
++else
++ exit 1
++fi
+diff --git a/test/notmuch-test b/test/notmuch-test
+index 6db7979..aa28bb0 100755
+--- a/test/notmuch-test
++++ b/test/notmuch-test
+@@ -97,6 +97,9 @@ trap - HUP INT TERM
+
+ # Report results
+ ./aggregate-results.sh test-results/*
++ev=$?
+
+ # Clean up
+ rm -rf test-results corpus.mail
++
++exit $ev
+--
+1.8.3.2
+
diff --git a/net-mail/notmuch/files/0.15.2-0001-test-exit-with-nonzero-value-when-not-.patch b/net-mail/notmuch/files/0.15.2-0001-test-exit-with-nonzero-value-when-not-.patch
new file mode 100644
index 000000000000..f66a12497320
--- /dev/null
+++ b/net-mail/notmuch/files/0.15.2-0001-test-exit-with-nonzero-value-when-not-.patch
@@ -0,0 +1,56 @@
+From c1f05bfb791e82776f5759e38c758cedd7e6190f Mon Sep 17 00:00:00 2001
+From: Tomi Ollila <tomi.ollila@iki.fi>
+Date: Sun, 8 Sep 2013 18:53:30 +0300
+Subject: [PATCH] test: exit with nonzero value when not all tests completed
+ successfully
+
+If any of the tests in our test system is not passing the execution
+of the test suite completes with nonzero exit value.
+
+It is better to rely on the exit value of the test system instead
+of some arbitrary strings in test output (or use both).
+---
+ test/aggregate-results.sh | 9 +++++++++
+ test/notmuch-test | 3 +++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/test/aggregate-results.sh b/test/aggregate-results.sh
+index 732d6ca..b016edb 100755
+--- a/test/aggregate-results.sh
++++ b/test/aggregate-results.sh
+@@ -1,5 +1,7 @@
+ #!/usr/bin/env bash
+
++set -eu
++
+ fixed=0
+ success=0
+ failed=0
+@@ -79,3 +81,10 @@ if [ "$skipped" != "0" ]; then
+ tests=$(pluralize "test" $skipped)
+ echo "$skipped $tests skipped."
+ fi
++
++if [ $success -gt 0 -a $fixed -eq 0 -a $failed -eq 0 -a $skipped -eq 0 ]
++then
++ exit 0
++else
++ exit 1
++fi
+diff --git a/test/notmuch-test b/test/notmuch-test
+index 6db7979..aa28bb0 100755
+--- a/test/notmuch-test
++++ b/test/notmuch-test
+@@ -97,6 +97,9 @@ trap - HUP INT TERM
+
+ # Report results
+ ./aggregate-results.sh test-results/*
++ev=$?
+
+ # Clean up
+ rm -rf test-results corpus.mail
++
++exit $ev
+--
+1.8.3.2
+
diff --git a/net-mail/notmuch/files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch b/net-mail/notmuch/files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch
new file mode 100644
index 000000000000..f66a12497320
--- /dev/null
+++ b/net-mail/notmuch/files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch
@@ -0,0 +1,56 @@
+From c1f05bfb791e82776f5759e38c758cedd7e6190f Mon Sep 17 00:00:00 2001
+From: Tomi Ollila <tomi.ollila@iki.fi>
+Date: Sun, 8 Sep 2013 18:53:30 +0300
+Subject: [PATCH] test: exit with nonzero value when not all tests completed
+ successfully
+
+If any of the tests in our test system is not passing the execution
+of the test suite completes with nonzero exit value.
+
+It is better to rely on the exit value of the test system instead
+of some arbitrary strings in test output (or use both).
+---
+ test/aggregate-results.sh | 9 +++++++++
+ test/notmuch-test | 3 +++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/test/aggregate-results.sh b/test/aggregate-results.sh
+index 732d6ca..b016edb 100755
+--- a/test/aggregate-results.sh
++++ b/test/aggregate-results.sh
+@@ -1,5 +1,7 @@
+ #!/usr/bin/env bash
+
++set -eu
++
+ fixed=0
+ success=0
+ failed=0
+@@ -79,3 +81,10 @@ if [ "$skipped" != "0" ]; then
+ tests=$(pluralize "test" $skipped)
+ echo "$skipped $tests skipped."
+ fi
++
++if [ $success -gt 0 -a $fixed -eq 0 -a $failed -eq 0 -a $skipped -eq 0 ]
++then
++ exit 0
++else
++ exit 1
++fi
+diff --git a/test/notmuch-test b/test/notmuch-test
+index 6db7979..aa28bb0 100755
+--- a/test/notmuch-test
++++ b/test/notmuch-test
+@@ -97,6 +97,9 @@ trap - HUP INT TERM
+
+ # Report results
+ ./aggregate-results.sh test-results/*
++ev=$?
+
+ # Clean up
+ rm -rf test-results corpus.mail
++
++exit $ev
+--
+1.8.3.2
+
diff --git a/net-mail/notmuch/notmuch-0.12.ebuild b/net-mail/notmuch/notmuch-0.12.ebuild
index 4f625b0b085a..8003d47586e7 100644
--- a/net-mail/notmuch/notmuch-0.12.ebuild
+++ b/net-mail/notmuch/notmuch-0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.12.ebuild,v 1.11 2013/09/06 13:06:27 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.12.ebuild,v 1.12 2013/09/14 17:26:31 aidecoe Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="python? 2:2.6 3:3.2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[45] 3.1"
-inherit elisp-common pax-utils distutils
+inherit elisp-common eutils pax-utils distutils
DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
HOMEPAGE="http://notmuchmail.org/"
@@ -63,6 +63,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${PV}-0001-test-exit-with-nonzero-value-when-not-.patch"
default
bindings python distutils_src_prepare
}
diff --git a/net-mail/notmuch/notmuch-0.13.1.ebuild b/net-mail/notmuch/notmuch-0.13.1.ebuild
index 3280d02d0b29..350de5c8e9c4 100644
--- a/net-mail/notmuch/notmuch-0.13.1.ebuild
+++ b/net-mail/notmuch/notmuch-0.13.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.13.1.ebuild,v 1.4 2013/09/06 13:06:27 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.13.1.ebuild,v 1.5 2013/09/14 17:26:31 aidecoe Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="python? 2:2.6 3:3.2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[45] 3.1"
-inherit elisp-common pax-utils distutils
+inherit elisp-common eutils pax-utils distutils
DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
HOMEPAGE="http://notmuchmail.org/"
@@ -67,6 +67,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${PV}-0001-test-exit-with-nonzero-value-when-not-.patch"
default
bindings python distutils_src_prepare
}
diff --git a/net-mail/notmuch/notmuch-0.14-r1.ebuild b/net-mail/notmuch/notmuch-0.14-r1.ebuild
index 9dc7e6975291..bd556598a87e 100644
--- a/net-mail/notmuch/notmuch-0.14-r1.ebuild
+++ b/net-mail/notmuch/notmuch-0.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.14-r1.ebuild,v 1.4 2013/09/06 13:06:27 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.14-r1.ebuild,v 1.5 2013/09/14 17:26:31 aidecoe Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="python? 2:2.6 3:3.2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[45] 3.1"
-inherit elisp-common pax-utils distutils
+inherit elisp-common eutils pax-utils distutils
DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
HOMEPAGE="http://notmuchmail.org/"
@@ -68,6 +68,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${PV}-0001-test-exit-with-nonzero-value-when-not-.patch"
default
bindings python distutils_src_prepare
}
diff --git a/net-mail/notmuch/notmuch-0.15.2.ebuild b/net-mail/notmuch/notmuch-0.15.2.ebuild
index fe81ac5d6b3a..451458a15ace 100644
--- a/net-mail/notmuch/notmuch-0.15.2.ebuild
+++ b/net-mail/notmuch/notmuch-0.15.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.15.2.ebuild,v 1.4 2013/09/06 13:06:27 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.15.2.ebuild,v 1.5 2013/09/14 17:26:31 aidecoe Exp $
EAPI=4
@@ -51,7 +51,6 @@ RDEPEND="${CDEPEND}
zsh-completion? ( app-shells/zsh )
"
-PATCHES=( )
DOCS=( AUTHORS NEWS README )
SITEFILE="50${PN}-gentoo.el"
SITEFILE_PICK="60${PN}-pick-gentoo.el"
@@ -74,10 +73,7 @@ pkg_setup() {
}
src_prepare() {
- local p
- for p in "${PATCHES[@]}"; do
- epatch "${p}"
- done
+ epatch "${FILESDIR}/${PV}-0001-test-exit-with-nonzero-value-when-not-.patch"
default
bindings python distutils_src_prepare
diff --git a/net-mail/notmuch/notmuch-0.16-r1.ebuild b/net-mail/notmuch/notmuch-0.16-r1.ebuild
index bfee3092b608..4740308cc804 100644
--- a/net-mail/notmuch/notmuch-0.16-r1.ebuild
+++ b/net-mail/notmuch/notmuch-0.16-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.16-r1.ebuild,v 1.1 2013/09/06 13:08:44 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.16-r1.ebuild,v 1.2 2013/09/14 17:26:31 aidecoe Exp $
EAPI=5
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit elisp-common pax-utils distutils-r1
+inherit elisp-common eutils pax-utils distutils-r1
DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
HOMEPAGE="http://notmuchmail.org/"
@@ -77,6 +77,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${PV}-0001-test-exit-with-nonzero-value-when-not-.patch"
default
bindings python distutils-r1_src_prepare
bindings python mv README README-python || die