summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-04-26 12:12:34 +0000
committerThomas Kahle <tomka@gentoo.org>2012-04-26 12:12:34 +0000
commit34c6050ef2efa26fe1d5c9539ab644c19d1a473f (patch)
treeec95168f6c99572bba5b5dc514f232acd08d0de9 /net-mail/offlineimap
parentVersion bump to 3.5.3. (diff)
downloadgentoo-2-34c6050ef2efa26fe1d5c9539ab644c19d1a473f.tar.gz
gentoo-2-34c6050ef2efa26fe1d5c9539ab644c19d1a473f.tar.bz2
gentoo-2-34c6050ef2efa26fe1d5c9539ab644c19d1a473f.zip
bump to 6.5.3.1
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/offlineimap')
-rw-r--r--net-mail/offlineimap/ChangeLog8
-rw-r--r--net-mail/offlineimap/files/offlineimap-6.5.3.1-darwin10.patch10
-rw-r--r--net-mail/offlineimap/offlineimap-6.5.3.1.ebuild77
3 files changed, 94 insertions, 1 deletions
diff --git a/net-mail/offlineimap/ChangeLog b/net-mail/offlineimap/ChangeLog
index fa54cc2f68a5..115a5323df05 100644
--- a/net-mail/offlineimap/ChangeLog
+++ b/net-mail/offlineimap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/offlineimap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.84 2012/04/23 20:29:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.85 2012/04/26 12:12:34 tomka Exp $
+
+*offlineimap-6.5.3.1 (26 Apr 2012)
+
+ 26 Apr 2012; Thomas Kahle <tomka@gentoo.org>
+ +files/offlineimap-6.5.3.1-darwin10.patch, +offlineimap-6.5.3.1.ebuild:
+ bump to 6.5.3.1
23 Apr 2012; Michał Górny <mgorny@gentoo.org> offlineimap-6.5.1.2.ebuild,
offlineimap-6.5.2.ebuild, offlineimap-6.5.2.1_rc1.ebuild,
diff --git a/net-mail/offlineimap/files/offlineimap-6.5.3.1-darwin10.patch b/net-mail/offlineimap/files/offlineimap-6.5.3.1-darwin10.patch
new file mode 100644
index 000000000000..2ec9161c10a4
--- /dev/null
+++ b/net-mail/offlineimap/files/offlineimap-6.5.3.1-darwin10.patch
@@ -0,0 +1,10 @@
+--- offlineimap.py 2012-04-10 14:19:03.335823779 +0200
++++ offlineimap.py.new 2012-04-10 14:18:57.631852822 +0200
+@@ -17,6 +17,7 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
++from locale import *
+ from offlineimap import OfflineImap
+
+ oi = OfflineImap()
diff --git a/net-mail/offlineimap/offlineimap-6.5.3.1.ebuild b/net-mail/offlineimap/offlineimap-6.5.3.1.ebuild
new file mode 100644
index 000000000000..3916a4d22fac
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-6.5.3.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/offlineimap-6.5.3.1.ebuild,v 1.1 2012/04/26 12:12:34 tomka Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="threads ssl?"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.* 2.7-pypy-*" #see bug 394307
+
+inherit eutils distutils
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+#Why doesn't this work?
+#SRC_URI="mirror://github/spaetz/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+SRC_URI="https://github.com/spaetz/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+DEPEND="doc? ( dev-python/docutils )"
+RDEPEND=""
+S="${WORKDIR}/${PN}"
+
+# github changed tarball internals again...
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}/"
+}
+
+src_prepare() {
+ distutils_src_prepare
+ # see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+ epatch "${FILESDIR}"/"${P}"-darwin10.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ cd docs
+ rst2man.py MANUAL.rst offlineimap.1 || die "building manpage failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ if use doc ; then
+ cd docs
+ doman offlineimap.1 || die "installing manpage failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog ""
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+
+ elog "If you upgraded from 6.3.* then you may need to update your config:"
+ elog ""
+ elog "If you use nametrans= settings on a remote repository, you will have"
+ elog "to add a \"reverse\" nametrans setting to the local repository, so that"
+ elog "it knows which folders it should (not) create on the remote side."
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ elog ""
+}