summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-05-04 01:15:49 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-05-04 01:15:49 +0000
commitccc09fa08d867fa0663e84ca5b42b1fc793786de (patch)
tree94f2f3d565492d2d313871b1fe43aabc559dc7f4 /net-mail/procmail
parentFixes #2126. (diff)
downloadgentoo-2-ccc09fa08d867fa0663e84ca5b42b1fc793786de.tar.gz
gentoo-2-ccc09fa08d867fa0663e84ca5b42b1fc793786de.tar.bz2
gentoo-2-ccc09fa08d867fa0663e84ca5b42b1fc793786de.zip
Added a mbox use item to procmail so that users who want the original
procmail behavior of delivering to /var/spool/mail can build procmail to do that. I think that should be the default unless a maildir use item is added, then it should change the default procmail behavior to something different like using ~/.maildir For now to avoid confusion, I left gentoo's procmail default behavior as it was (modifying procmail to use maildir) until which time we can notify the users and change the use item usage of this ebuild to be the opposite. (default: mbox, maildir use item: maildir)
Diffstat (limited to 'net-mail/procmail')
-rw-r--r--net-mail/procmail/ChangeLog9
-rw-r--r--net-mail/procmail/files/digest-procmail-3.22-r11
-rw-r--r--net-mail/procmail/procmail-3.22-r1.ebuild52
3 files changed, 61 insertions, 1 deletions
diff --git a/net-mail/procmail/ChangeLog b/net-mail/procmail/ChangeLog
index 44e4eddf1eaa..c1fdb54344e0 100644
--- a/net-mail/procmail/ChangeLog
+++ b/net-mail/procmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/procmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/ChangeLog,v 1.1 2002/02/01 21:53:34 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/ChangeLog,v 1.2 2002/05/04 01:15:49 jhhudso Exp $
+
+*procmail-3.22-r1 (1 Feb 2002)
+ 3 May 2002; J.Hudson <jhhudso@gentoo.org> procmail-3.22-r1.ebuild :
+
+ Added mbox use item to ebuild. When used, procmail will not change
+ the location of mail spool to a maildir style location. Instead, it
+ will use the /var/spool/mail/* default.
*procmail-3.22 (1 Feb 2002)
diff --git a/net-mail/procmail/files/digest-procmail-3.22-r1 b/net-mail/procmail/files/digest-procmail-3.22-r1
new file mode 100644
index 000000000000..d14b9662a1d7
--- /dev/null
+++ b/net-mail/procmail/files/digest-procmail-3.22-r1
@@ -0,0 +1 @@
+MD5 1678ea99b973eb77eda4ecf6acae53f1 procmail-3.22.tar.gz 226817
diff --git a/net-mail/procmail/procmail-3.22-r1.ebuild b/net-mail/procmail/procmail-3.22-r1.ebuild
new file mode 100644
index 000000000000..843b14873042
--- /dev/null
+++ b/net-mail/procmail/procmail-3.22-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# Modified by $HOME/.maildir by Craig Joly <craig@taipan.mudshark.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/procmail-3.22-r1.ebuild,v 1.1 2002/05/04 01:15:49 jhhudso Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Mail delivery agent/filter"
+SRC_URI="http://www.procmail.org/${P}.tar.gz"
+HOMEPAGE="http://www.procmail.org/"
+
+DEPEND="virtual/glibc
+ virtual/mta"
+
+src_compile() {
+
+ cp Makefile Makefile.orig
+ sed -e "s:CFLAGS0 = -O:CFLAGS0 = ${CFLAGS}:" \
+ -e "s:LOCKINGTEST=__defaults__:#LOCKINGTEST=__defaults__:" \
+ -e "s:#LOCKINGTEST=/tmp:LOCKINGTEST=/tmp:" Makefile.orig > Makefile
+
+ if [ -z "`use mbox`" ];
+ then
+ cd ${S}/src
+ cp authenticate.c authenticate.c.orig
+ sed -e "s:/\*#define MAILSPOOLHOME \"/.mail\":#define MAILSPOOLHOME \"/.maildir/\":" authenticate.c.orig > authenticate.c
+ cd ${S}
+ fi
+
+ emake || die
+}
+
+src_install () {
+ cd ${S}/new
+ insinto /usr/bin
+ insopts -m 6755
+ doins procmail
+
+ insopts -m 2755
+ doins lockfile
+
+ dobin formail mailstat
+
+ doman *.1 *.5
+
+ cd ${S}
+ dodoc Artistic COPYING FAQ FEATURES HISTORY INSTALL KNOWN_BUGS README
+
+ docinto examples
+ dodoc examples/*
+}
+