summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-12 16:50:30 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-12 16:50:30 +0000
commitf4313175e8708062bce127c40fbd7904a3867959 (patch)
tree185ec9074265fe245c12f6eae214792efe13f0b3 /net-mail/qmrtg/qmrtg-2.1-r1.ebuild
parentWith USE=doc should depend on virtual/texi2dvi (diff)
downloadgentoo-2-f4313175e8708062bce127c40fbd7904a3867959.tar.gz
gentoo-2-f4313175e8708062bce127c40fbd7904a3867959.tar.bz2
gentoo-2-f4313175e8708062bce127c40fbd7904a3867959.zip
Fix paths in patches. Respect CFLAGS (bug #241058).
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'net-mail/qmrtg/qmrtg-2.1-r1.ebuild')
-rw-r--r--net-mail/qmrtg/qmrtg-2.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-mail/qmrtg/qmrtg-2.1-r1.ebuild b/net-mail/qmrtg/qmrtg-2.1-r1.ebuild
new file mode 100644
index 000000000000..68ae1fdf8f9b
--- /dev/null
+++ b/net-mail/qmrtg/qmrtg-2.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmrtg/qmrtg-2.1-r1.ebuild,v 1.1 2010/02/12 16:50:30 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A tool to analyze qmail's activity with the goal to graph everything through MRTG."
+HOMEPAGE="http://dev.publicshout.org/qmrtg"
+SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="net-analyzer/mrtg"
+
+src_prepare() {
+ sed -i analyzers/Makefile.in filters/Makefile.in \
+ -e 's|^CFLAGS =|CFLAGS ?=|g' || die "sed failed"
+
+ epatch "${FILESDIR}/mrtg.cfg.patch"
+ epatch "${FILESDIR}/qmrtg.conf.sample.patch"
+}
+
+src_install () {
+ emake install DESTDIR=${D} || die "emake install failed"
+ keepdir /var/lib/qmrtg
+ dodoc INSTALL.txt
+ if use doc ; then
+ docinto txt
+ dodoc doc/*.txt
+ docinto html
+ dohtml -r html/*
+ fi
+
+ insinto /usr/share/qmrtg2
+ doins examples/*
+
+}
+
+pkg_postinst () {
+ elog
+ elog "You need to configure manually qmrtg in order to run it."
+ elog "The configuration templates in /usr/share/qmrtg2/ and"
+ elog "the INSTALL file in /usr/share/doc/qmrtg-2.1/"
+ elog "will be useful."
+ elog
+}