summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-04-05 23:29:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-04-05 23:29:37 +0000
commitf4cb723d9203eace1d2ac3ad9419d636e4b5487b (patch)
tree0644546137e21a25c50901ddd04d1765b9ab12e2 /net-mail/qtools
parentMarked stable on hppa. Changed depend sys-kernel/linux-headers to virtual/os-... (diff)
downloadgentoo-2-f4cb723d9203eace1d2ac3ad9419d636e4b5487b.tar.gz
gentoo-2-f4cb723d9203eace1d2ac3ad9419d636e4b5487b.tar.bz2
gentoo-2-f4cb723d9203eace1d2ac3ad9419d636e4b5487b.zip
new package
Diffstat (limited to 'net-mail/qtools')
-rw-r--r--net-mail/qtools/ChangeLog9
-rw-r--r--net-mail/qtools/files/digest-qtools-0.561
-rw-r--r--net-mail/qtools/files/qtools-0.56-errno.patch12
-rw-r--r--net-mail/qtools/qtools-0.56.ebuild46
4 files changed, 68 insertions, 0 deletions
diff --git a/net-mail/qtools/ChangeLog b/net-mail/qtools/ChangeLog
new file mode 100644
index 000000000000..ee437adf4baa
--- /dev/null
+++ b/net-mail/qtools/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/qtools
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qtools/ChangeLog,v 1.1 2003/04/05 23:29:37 robbat2 Exp $
+
+*qtools-0.56 (23 Mar 2003)
+
+ 23 Mar 2003; Robin Johnson <robbat2@orbis-terrarum.net> ChangeLog:
+ Initial import. Ebuild submitted by Robin Johnson
+ <robbat2@orbis-terrarum.net>.
diff --git a/net-mail/qtools/files/digest-qtools-0.56 b/net-mail/qtools/files/digest-qtools-0.56
new file mode 100644
index 000000000000..d3ad921b05e3
--- /dev/null
+++ b/net-mail/qtools/files/digest-qtools-0.56
@@ -0,0 +1 @@
+MD5 ba5610526e08fb00ddc30b28f1a0864e qtools-0.56.tar.gz 37748
diff --git a/net-mail/qtools/files/qtools-0.56-errno.patch b/net-mail/qtools/files/qtools-0.56-errno.patch
new file mode 100644
index 000000000000..a5fdab64b733
--- /dev/null
+++ b/net-mail/qtools/files/qtools-0.56-errno.patch
@@ -0,0 +1,12 @@
+--- qtools-0.56.old/error.h 2000-03-18 14:01:20.000000000 -0800
++++ qtools-0.56/error.h 2003-03-23 21:50:05.000000000 -0800
+@@ -1,7 +1,8 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++/* extern int errno; */
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/net-mail/qtools/qtools-0.56.ebuild b/net-mail/qtools/qtools-0.56.ebuild
new file mode 100644
index 000000000000..9e223ddc4256
--- /dev/null
+++ b/net-mail/qtools/qtools-0.56.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qtools/qtools-0.56.ebuild,v 1.1 2003/04/05 23:29:37 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Several utilities for use with qmail, typically as part of .qmail command processing"
+
+HOMEPAGE="http://www.superscript.com/qtools/intro.html"
+
+SRC_URI="http://www.superscript.com/qtools/${P}.tar.gz"
+
+LICENSE="as-is"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-errno.patch
+}
+
+src_compile() {
+ LDFLAGS=
+ use static && LDFLAGS="-static"
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc ${LDFLAGS}" > conf-ld
+ echo "/usr" > conf-home
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ dobin 822addr 822body 822bodyfilter 822fields 822headerfilter \
+ 822headerok 822headers checkaddr checkdomain \
+ condtomaildir filterto ifaddr iftoccfrom replier \
+ replier-config tomaildir
+
+ dodoc BAPVERSION CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+}