summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-11-26 11:39:11 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-11-26 11:39:11 +0000
commit18f402d249b71fc4d36f1348d28f41058cb63160 (patch)
treea7d3eb3de2d47ed21d8548709f502028375edb28 /net-mail/sylpheed-claws/sylpheed-claws-0.8.6.ebuild
parentnew digest (for rc5 tarballs) (diff)
downloadgentoo-2-18f402d249b71fc4d36f1348d28f41058cb63160.tar.gz
gentoo-2-18f402d249b71fc4d36f1348d28f41058cb63160.tar.bz2
gentoo-2-18f402d249b71fc4d36f1348d28f41058cb63160.zip
version bump, aspell support seems to be broken with gcc3.2.1
Diffstat (limited to 'net-mail/sylpheed-claws/sylpheed-claws-0.8.6.ebuild')
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.8.6.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.8.6.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.8.6.ebuild
new file mode 100644
index 000000000000..595e995fe65b
--- /dev/null
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.8.6.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.8.6.ebuild,v 1.1 2002/11/26 11:39:11 bcowan Exp $
+
+IUSE="nls gnome xface gtkhtml crypt spell imlib ssl ldap ipv6 pda"
+
+MY_P="sylpheed-${PV}claws"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Bleeding edge version of Sylpheed"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${MY_P}.tar.bz2"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ pda? ( >=app-misc/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( app-text/aspell )
+ xface? ( >=media-libs/compface-1.4 )
+ gtkhtml? ( net-www/dillo )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/sylpheed"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # This patch allows for dillo web browser to be embeedded
+ if use gtkhtml
+ then
+ cd ${S}
+ patch -p1 < ${FILESDIR}/sylpheed-0.8.3claws32-dillo.patch || die
+ fi
+}
+
+src_compile() {
+
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --enable-gdk-pixbuf" \
+ || myconf="${myconf} --disable-gdk-pixbuf"
+
+ use imlib \
+ && myconf="${myconf} --enable-imlib" \
+ || myconf="${myconf} --disable-imlib"
+
+ #currently broken
+ #use spell \
+ # && myconf="${myconf} --enable-aspell" \
+ # || myconf="${myconf} --disable-aspell"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ echo ${myconf}
+
+ econf \
+ --program-suffix=-claws \
+ --disable-aspell \
+ ${myconf} || die "./configure failed"
+
+ for i in `find . -name Makefile` ; do
+ cp $i ${i}.orig
+ sed "s/PACKAGE = sylpheed/PACKAGE = sylpheed-claws/" \
+ < ${i}.orig \
+ > ${i}
+ done
+
+ cp sylpheed.desktop sylpheed.desktop.orig
+ sed "s/sylpheed.png/sylpheed-claws.png/" \
+ < sylpheed.desktop.orig
+ > sylpheed.desktop
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ use gnome || rm -rf ${D}/usr/share/gnome
+
+ mv ${D}/usr/share/pixmaps/sylpheed.png \
+ ${D}/usr/share/pixmaps/sylpheed-claws.png
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+}
+
+pkg_postinst() {
+
+ einfo "Warning: Spell checker is currently broken in this"
+ einfo "testing build, if u need that functionality please"
+ einfo "use Gentoo's current marked stable version." \ No newline at end of file