summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-21 21:34:53 +0000
committerTod Neidt <tod@gentoo.org>2002-02-21 21:34:53 +0000
commit6bb12b125367d02c0d9382ada0df6da927abe14c (patch)
tree605fd63818bb8a5e4388c8ed12c59a08af03092e /net-mail/sylpheed
parentupdated, fixing bug #252 (diff)
downloadgentoo-2-6bb12b125367d02c0d9382ada0df6da927abe14c.tar.gz
gentoo-2-6bb12b125367d02c0d9382ada0df6da927abe14c.tar.bz2
gentoo-2-6bb12b125367d02c0d9382ada0df6da927abe14c.zip
Version update. Just a copy of sylpheed-0.7.0.ebuild. Thanks to Jim Nutt for the notification.
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/ChangeLog9
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.7.21
-rw-r--r--net-mail/sylpheed/sylpheed-0.7.2.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index 5b2ba63bac2d..211089108acc 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.1 2002/02/01 21:53:34 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.2 2002/02/21 21:34:53 tod Exp $
+
+*sylpheed-0.7.2 (21 Feb 2002)
+
+ 21 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog, sylpheed-0.7.2.ebuild :
+
+ Version update.
+ Just a copy of sylpheed-0.7.0.ebuild to sylpheed-0.7.2.ebuild.
*sylpheed-0.7.0 (1 Feb 2002)
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.7.2 b/net-mail/sylpheed/files/digest-sylpheed-0.7.2
new file mode 100644
index 000000000000..3382b4518781
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.7.2
@@ -0,0 +1 @@
+MD5 da94286fb3f621dec719f1bee8e01238 sylpheed-0.7.2.tar.bz2 1533287
diff --git a/net-mail/sylpheed/sylpheed-0.7.2.ebuild b/net-mail/sylpheed/sylpheed-0.7.2.ebuild
new file mode 100644
index 000000000000..22659eb0613f
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.7.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.7.2.ebuild,v 1.1 2002/02/21 21:34:53 tod Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/sylpheed/sylpheed-${PV}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/compface-1.4
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ gpg? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )"
+
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( dev-libs/openssl )
+ gpg? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use gnome`" ] ; then
+ myconf="--disable-gdk-pixbuf --disable-imlib"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --enable-ssl"
+ fi
+ if [ "`use gpg`" ] ; then
+ myconf="$myconf --enable-gpgme"
+ fi
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 $myconf || die
+ make || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}
+