summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2008-08-11 21:26:12 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2008-08-11 21:26:12 +0000
commit00f30a91f9f74126e9bad2662a7fb30828a9f6c0 (patch)
tree66208f8c138ee3413a321e0e4acb2ff9afe73ebe /net-mail/tpop3d
parentrevision bump with patches from fedora, also reported in bug #202315 (diff)
downloadgentoo-2-00f30a91f9f74126e9bad2662a7fb30828a9f6c0.tar.gz
gentoo-2-00f30a91f9f74126e9bad2662a7fb30828a9f6c0.tar.bz2
gentoo-2-00f30a91f9f74126e9bad2662a7fb30828a9f6c0.zip
Fixed init script for tpop3d-1.5.4
(Portage version: 2.2_rc3/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'net-mail/tpop3d')
-rw-r--r--net-mail/tpop3d/ChangeLog10
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.4.init30
-rw-r--r--net-mail/tpop3d/tpop3d-1.5.4-r1.ebuild99
3 files changed, 138 insertions, 1 deletions
diff --git a/net-mail/tpop3d/ChangeLog b/net-mail/tpop3d/ChangeLog
index 259cf37dc74d..1f9b1682cd5a 100644
--- a/net-mail/tpop3d/ChangeLog
+++ b/net-mail/tpop3d/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/tpop3d
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.25 2008/05/21 18:59:22 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.26 2008/08/11 21:26:11 griffon26 Exp $
+
+*tpop3d-1.5.4-r1 (11 Aug 2008)
+
+ 11 Aug 2008; Maurice van der Pot <griffon26@gentoo.org>
+ +files/tpop3d-1.5.4.init, +tpop3d-1.5.4-r1.ebuild:
+ The --background option to start-stop-daemon is no longer needed for
+ tpop3d-1.5.4 (see bug #76027) and it was causing the init script to report an
+ error while tpop3d actually started successfully.
21 May 2008; Tiziano Müller <dev-zero@gentoo.org> tpop3d-1.5.3.ebuild,
tpop3d-1.5.3-r1.ebuild, tpop3d-1.5.4.ebuild:
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.4.init b/net-mail/tpop3d/files/tpop3d-1.5.4.init
new file mode 100644
index 000000000000..8be7925c9eff
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.4.init
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/files/tpop3d-1.5.4.init,v 1.1 2008/08/11 21:26:12 griffon26 Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/tpop3d/tpop3d.conf ] ; then
+ eerror "You need an /etc/tpop3d/tpop3d.conf file to run tpop3d"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting tpop3d"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/sbin/tpop3d -- -f /etc/tpop3d/tpop3d.conf \
+ -p /var/run/tpop3d.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tpop3d"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/tpop3d
+ eend $?
+}
diff --git a/net-mail/tpop3d/tpop3d-1.5.4-r1.ebuild b/net-mail/tpop3d/tpop3d-1.5.4-r1.ebuild
new file mode 100644
index 000000000000..866bbecb0c97
--- /dev/null
+++ b/net-mail/tpop3d/tpop3d-1.5.4-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.5.4-r1.ebuild,v 1.1 2008/08/11 21:26:11 griffon26 Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="An extensible POP3 server with vmail-sql/MySQL support."
+HOMEPAGE="http://savannah.nongnu.org/projects/tpop3d/"
+SRC_URI="http://download.savannah.nongnu.org/releases/tpop3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="authexternal debug drac flatfile gdbm ldap maildir mbox mysql offensive
+ pam passwd perl postgres +sha1 shadow ssl tcpd"
+
+RDEPEND="
+ debug? ( >=dev-util/efence-2.4.13 )
+ sha1? ( >=dev-libs/openssl-0.9.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ mysql? ( virtual/mysql )
+ postgres? ( >=virtual/postgresql-server-7.3 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ pam? ( virtual/pam
+ >=net-mail/mailbase-0.00-r8 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ drac? ( mail-client/drac )"
+
+src_compile() {
+ local myconf=""
+ local noauth=0
+
+ elog "This version of the tpop3d ebuild has a lot of new USE flags."
+ elog "Make sure that everything you need is enabled."
+
+ # Various authentication methods
+ use authexternal && myconf="${myconf} --enable-auth-other"
+ use flatfile && myconf="${myconf} --enable-auth-flatfile"
+ use gdbm && myconf="${myconf} --enable-auth-gdbm"
+ use ldap && myconf="${myconf} --enable-auth-ldap"
+ use mysql && myconf="${myconf} --enable-auth-mysql"
+ use pam || myconf="${myconf} --disable-auth-pam"
+ use passwd && myconf="${myconf} --enable-auth-passwd"
+ use perl && myconf="${myconf} --enable-auth-perl"
+ use postgres && myconf="${myconf} --enable-auth-pgsql"
+ use shadow && myconf="${myconf} --enable-auth-passwd --enable-shadow-passwords"
+
+ use authexternal || use flatfile || use gdbm || use ldap || use mysql ||
+ use pam || use passwd || use perl || use postgres || use shadow ||
+ noauth=1
+
+ if [[ ${noauth} -eq 1 ]]; then
+ ewarn "None of tpop3d's authentication mechanism USE flags are set."
+ ewarn "As a result tpop3d will be built with /etc/passwd authentication only."
+ myconf="${myconf} --enable-auth-passwd"
+ fi
+
+ # Other optional features
+ use debug && myconf="${myconf} --enable-electric-fence --enable-backtrace"
+ use maildir && myconf="${myconf} --enable-mbox-maildir"
+ use mbox || myconf="${myconf} --disable-mbox-bsd"
+ use offensive || myconf="${myconf} --disable-snide-comments"
+ use sha1 || myconf="${myconf} --disable-sha1-passwords"
+ use ssl && myconf="${myconf} --enable-tls"
+ use tcpd && myconf="${myconf} --enable-tcp-wrappers"
+
+ # Install mail-client/drac for integration with tpop3d
+ use drac && myconf="${myconf} --enable-drac"
+
+ econf ${myconf} || die "./configure failed"
+
+ # Causes crash with "stack smashing attack" on connect, because of bug in
+ # SSP (bug #115285)
+ filter-flags -fstack-protector
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodir /etc/tpop3d
+
+ if use pam ; then
+ dodir /etc/pam.d
+ dosym /etc/pam.d/pop3 /etc/pam.d/tpop3d
+ fi
+
+ newinitd "${FILESDIR}/${PN}-1.5.4.init" tpop3d
+}
+
+pkg_postinst() {
+ elog "Read the tpop3d.conf manpage"
+ elog "Please create /etc/tpop3d/tpop3d.conf to fit your configuration"
+}