summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-09-30 12:15:10 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-09-30 12:15:10 +0000
commita4744f1db36cc73d71c9b1833858e51bd1085319 (patch)
treeced6038b1da27de6abad2578573fa3de9ceb4a28 /net-mail/vmailmgr
parentStable for sparc. (Manifest recommit) (diff)
downloadgentoo-2-a4744f1db36cc73d71c9b1833858e51bd1085319.tar.gz
gentoo-2-a4744f1db36cc73d71c9b1833858e51bd1085319.tar.bz2
gentoo-2-a4744f1db36cc73d71c9b1833858e51bd1085319.zip
Apply patch for clean compile on >=gcc3.4. Closes #65400.
Diffstat (limited to 'net-mail/vmailmgr')
-rw-r--r--net-mail/vmailmgr/ChangeLog7
-rw-r--r--net-mail/vmailmgr/files/vmailmgr-0.96.9-gcc3.3.patch65
-rw-r--r--net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild5
3 files changed, 75 insertions, 2 deletions
diff --git a/net-mail/vmailmgr/ChangeLog b/net-mail/vmailmgr/ChangeLog
index 2ccd82f95a08..8f8cdc9b0b04 100644
--- a/net-mail/vmailmgr/ChangeLog
+++ b/net-mail/vmailmgr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/vmailmgr
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/ChangeLog,v 1.12 2004/07/01 22:37:22 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/ChangeLog,v 1.13 2004/09/30 12:15:10 ticho Exp $
+
+ 30 Sep 2004; Andrej Kacian <ticho@gentoo.org>
+ +files/vmailmgr-0.96.9-gcc3.3.patch, vmailmgr-0.96.9-r1.ebuild:
+ Apply patch to fix multiline strings so we compile cleanly on >=gcc3.3.
+ Closes #65400, patch provided by Christophe Saout <christophe@saout.de>.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
vmailmgr-0.96.9-r1.ebuild:
diff --git a/net-mail/vmailmgr/files/vmailmgr-0.96.9-gcc3.3.patch b/net-mail/vmailmgr/files/vmailmgr-0.96.9-gcc3.3.patch
new file mode 100644
index 000000000000..8ac557628df3
--- /dev/null
+++ b/net-mail/vmailmgr/files/vmailmgr-0.96.9-gcc3.3.patch
@@ -0,0 +1,65 @@
+diff -ur vmailmgr-0.96.9.orig/commands/vcheckquota.cc vmailmgr-0.96.9/commands/vcheckquota.cc
+--- vmailmgr-0.96.9.orig/commands/vcheckquota.cc 2000-08-19 19:05:57.000000000 +0200
++++ vmailmgr-0.96.9/commands/vcheckquota.cc 2003-12-06 13:06:22.293442000 +0100
+@@ -31,10 +31,10 @@
+
+ const char* cli_program = "vcheckquota";
+ const char* cli_help_prefix = "vmailmgr quota enforcement program\n";
+-const char* cli_help_suffix = "
+-Warning: the soft-message is linked into the users maildir once for each
+-message that is received while the account is over its soft quota. This may
+-result in multiple warning messages.\n";
++const char* cli_help_suffix = "\n"
++"Warning: the soft-message is linked into the users maildir once for each\n"
++"message that is received while the account is over its soft quota. This may\n"
++"result in multiple warning messages.\n";
+ const char* cli_args_usage = "";
+ const int cli_args_min = 0;
+ const int cli_args_max = 0;
+diff -ur vmailmgr-0.96.9.orig/commands/vchforwards.cc vmailmgr-0.96.9/commands/vchforwards.cc
+--- vmailmgr-0.96.9.orig/commands/vchforwards.cc 2000-08-16 04:08:35.000000000 +0200
++++ vmailmgr-0.96.9/commands/vchforwards.cc 2003-12-06 13:06:06.349761000 +0100
+@@ -25,8 +25,7 @@
+ const char* cli_help_prefix =
+ "Change virtual user forwarding addresses.\n";
+ const char* cli_help_suffix =
+-"If no forwarding addresses are given, forwarding is disabled.
+-";
++"If no forwarding addresses are given, forwarding is disabled.\n";
+ const char* cli_args_usage = "USERNAME [DESTINATION1 ...]";
+ const int cli_args_min = 1;
+ const int cli_args_max = -1;
+diff -ur vmailmgr-0.96.9.orig/commands/vpasswd2cdb.cc vmailmgr-0.96.9/commands/vpasswd2cdb.cc
+--- vmailmgr-0.96.9.orig/commands/vpasswd2cdb.cc 2000-08-16 04:02:01.000000000 +0200
++++ vmailmgr-0.96.9/commands/vpasswd2cdb.cc 2003-12-06 13:05:47.972435000 +0100
+@@ -26,10 +26,10 @@
+
+ const char* cli_program = "vpasswd2cdb";
+ const char* cli_help_prefix = "Converts text password tables to CDB format\n";
+-const char* cli_help_suffix =
+-"Reads in a standard virtual password table in the current directory,
+-and writes it out to a CDB table. The file names for the text and CDB
+-tables are determined from the configuration file.";
++const char* cli_help_suffix = "\n"
++"Reads in a standard virtual password table in the current directory,\n"
++"and writes it out to a CDB table. The file names for the text and CDB\n"
++"tables are determined from the configuration file.";
+ const char* cli_args_usage = "";
+ const int cli_args_min = 0;
+ const int cli_args_max = 0;
+diff -ur vmailmgr-0.96.9.orig/commands/vpasswd2db.cc vmailmgr-0.96.9/commands/vpasswd2db.cc
+--- vmailmgr-0.96.9.orig/commands/vpasswd2db.cc 2000-08-16 04:02:04.000000000 +0200
++++ vmailmgr-0.96.9/commands/vpasswd2db.cc 2003-12-06 13:06:36.300404000 +0100
+@@ -26,9 +26,9 @@
+ const char* cli_program = "vpasswd2db";
+ const char* cli_help_prefix = "Converts text password tables to current vpwtable DB format\n";
+ const char* cli_help_suffix =
+-"Reads in a standard virtual password table in the current directory,
+-and writes it out to a table. The file names for the input and output
+-tables are determined from the configuration file.";
++"Reads in a standard virtual password table in the current directory,\n"
++"and writes it out to a table. The file names for the input and output\n"
++"tables are determined from the configuration file.";
+ const char* cli_args_usage = "";
+ const int cli_args_min = 0;
+ const int cli_args_max = 0;
diff --git a/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild b/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
index 8812322e6707..1ab6fdf80b53 100644
--- a/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
+++ b/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild,v 1.20 2004/07/15 02:31:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild,v 1.21 2004/09/30 12:15:10 ticho Exp $
inherit gcc
@@ -29,6 +29,9 @@ src_compile() {
if [ "`gcc-major-version`" = "3" ]; then
export LIBS="-lcrypt -lsupc++"
+ if [ `gcc-minor-version` -ge 3 ]; then
+ epatch ${FILESDIR}/${P}-gcc3.3.patch
+ fi
fi
if [ "`gcc-major-version`" = "2" ]; then