summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2004-08-26 13:50:28 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2004-08-26 13:50:28 +0000
commit08907fb068c365eb58d700ff2b542b4755937a92 (patch)
treed3b9466b032ebe73bdce037fe1b554fbf8761e85 /net-mail
parentBump (Manifest recommit) (diff)
downloadgentoo-2-08907fb068c365eb58d700ff2b542b4755937a92.tar.gz
gentoo-2-08907fb068c365eb58d700ff2b542b4755937a92.tar.bz2
gentoo-2-08907fb068c365eb58d700ff2b542b4755937a92.zip
Fixed error message and marked stable on x86
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/tpop3d/ChangeLog8
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.3-invalid-user-message.patch21
-rw-r--r--net-mail/tpop3d/tpop3d-1.5.3.ebuild7
3 files changed, 33 insertions, 3 deletions
diff --git a/net-mail/tpop3d/ChangeLog b/net-mail/tpop3d/ChangeLog
index c785000a3ec3..fa8add1fe1df 100644
--- a/net-mail/tpop3d/ChangeLog
+++ b/net-mail/tpop3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/tpop3d
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.13 2004/08/26 01:29:51 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.14 2004/08/26 13:50:28 griffon26 Exp $
+
+ 26 Aug 2004; Maurice van der Pot <griffon26@gentoo.org>
+ +files/tpop3d-1.5.3-invalid-user-message.patch, tpop3d-1.5.3.ebuild:
+ Fixed invalid user error message as reported by Jaroslaw Swierad
+ <messer@7thguard.net> in bug #51911
+ Marked stable on x86
26 Aug 2004; Maurice van der Pot <griffon26@gentoo.org> metadata.xml,
tpop3d-1.4.2.ebuild, tpop3d-1.5.3.ebuild:
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.3-invalid-user-message.patch b/net-mail/tpop3d/files/tpop3d-1.5.3-invalid-user-message.patch
new file mode 100644
index 000000000000..f462ad082408
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.3-invalid-user-message.patch
@@ -0,0 +1,21 @@
+diff -ruN tpop3d-1.5.3/auth_mysql.c tpop3d-1.5.3-invalid-user-message-patch/auth_mysql.c
+--- tpop3d-1.5.3/auth_mysql.c 2003-07-15 01:31:20.000000000 +0200
++++ tpop3d-1.5.3-invalid-user-message-patch/auth_mysql.c 2004-08-26 15:02:03.033018776 +0200
+@@ -267,7 +267,7 @@
+
+ /* User was not lying (about her password) */
+ if (!parse_uid((const char*)row[2], &uid)) {
+- log_print(LOG_ERR, _("auth_mysql_new_apop: unix user `%s' for %s does not make sense"), row[3], who);
++ log_print(LOG_ERR, _("auth_mysql_new_apop: unix user `%s' for %s does not make sense"), row[2], who);
+ break;
+ }
+
+@@ -367,7 +367,7 @@
+ }
+
+ if (!parse_uid((const char*)row[2], &uid)) {
+- log_print(LOG_ERR, _("auth_mysql_new_user_pass: unix user `%s' for %s does not make sense"), row[3], who);
++ log_print(LOG_ERR, _("auth_mysql_new_user_pass: unix user `%s' for %s does not make sense"), row[2], who);
+ break;
+ }
+
diff --git a/net-mail/tpop3d/tpop3d-1.5.3.ebuild b/net-mail/tpop3d/tpop3d-1.5.3.ebuild
index 826b312a041a..3f1e04b7f9b6 100644
--- a/net-mail/tpop3d/tpop3d-1.5.3.ebuild
+++ b/net-mail/tpop3d/tpop3d-1.5.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.5.3.ebuild,v 1.7 2004/08/26 01:29:51 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.5.3.ebuild,v 1.8 2004/08/26 13:50:28 griffon26 Exp $
+
+inherit eutils
DESCRIPTION="An extensible POP3 server with vmail-sql/MySQL support."
HOMEPAGE="http://www.ex-parrot.com/~chris/tpop3d/"
@@ -8,7 +10,7 @@ SRC_URI="http://www.ex-parrot.com/~chris/tpop3d/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="ssl ldap mysql perl pam tcpd maildir debug"
DEPEND="virtual/libc
@@ -22,6 +24,7 @@ DEPEND="virtual/libc
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
+ epatch ${FILESDIR}/${P}-invalid-user-message.patch
}
src_compile() {