summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-29 10:52:09 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-29 10:52:09 +0000
commit18aacce3c28d7f273d2587062c068768d342d1f3 (patch)
tree5fc43590a231f7007e755217d6ca4b37e5d961b7 /net-mail
parentAdded ppp to build dependencies, to get proper config files. (diff)
downloadgentoo-2-18aacce3c28d7f273d2587062c068768d342d1f3.tar.gz
gentoo-2-18aacce3c28d7f273d2587062c068768d342d1f3.tar.bz2
gentoo-2-18aacce3c28d7f273d2587062c068768d342d1f3.zip
New version with redesigned imap support
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.5.0_pre21
-rw-r--r--net-mail/sylpheed/sylpheed-0.5.0_pre2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.5.0_pre2 b/net-mail/sylpheed/files/digest-sylpheed-0.5.0_pre2
new file mode 100644
index 000000000000..5f58d93c8336
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.5.0_pre2
@@ -0,0 +1 @@
+MD5 09cd1711d377ffa973627a2ee6368f23 sylpheed-0.5.0pre2.tar.bz2
diff --git a/net-mail/sylpheed/sylpheed-0.5.0_pre2.ebuild b/net-mail/sylpheed/sylpheed-0.5.0_pre2.ebuild
new file mode 100644
index 000000000000..c7d1dfd249e9
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.5.0_pre2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.5.0_pre2.ebuild,v 1.1 2001/06/29 10:52:09 achim Exp $
+
+#P=
+A=${PN}-0.5.0pre2.tar.bz2
+S=${WORKDIR}/${PN}-0.5.0pre2
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/sylpheed/${A}"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+DEPEND=">=x11-libs/gtk+-1.2
+ >=media-libs/compface-1.4
+ gnome? ( >=gnome-base/gdk-pixbuf-0.10 )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND=">=x11-libs/gtk+-1.2
+ gnome? ( >=gnome-base/gdk-pixbuf-0.10 )"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use gnome`" ] ; then
+ myconf="--disable-gdk-pixbuf --disable-imlib"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST} --enable-ipv6 $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr manualdir=${D}/usr/share/doc/${PF}/html install
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+
+}
+