summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2008-04-06 17:55:17 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2008-04-06 17:55:17 +0000
commit30c7139af4276b8aa5aa794536bc70107fe98f19 (patch)
tree15b13e30aa1d0bcdb3f6ecb3be54652482ad6e80 /net-mail
parentAdded ~ppc; bug #195815 (diff)
downloadgentoo-2-30c7139af4276b8aa5aa794536bc70107fe98f19.tar.gz
gentoo-2-30c7139af4276b8aa5aa794536bc70107fe98f19.tar.bz2
gentoo-2-30c7139af4276b8aa5aa794536bc70107fe98f19.zip
Added tpop3d-1.5.4 and fixed bug #195488.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/tpop3d/ChangeLog12
-rw-r--r--net-mail/tpop3d/tpop3d-1.5.4.ebuild99
2 files changed, 109 insertions, 2 deletions
diff --git a/net-mail/tpop3d/ChangeLog b/net-mail/tpop3d/ChangeLog
index f3c823bbd0ea..ebac43080559 100644
--- a/net-mail/tpop3d/ChangeLog
+++ b/net-mail/tpop3d/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/tpop3d
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.22 2007/06/12 13:08:38 genone Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.23 2008/04/06 17:55:17 griffon26 Exp $
+
+*tpop3d-1.5.4 (06 Apr 2008)
+
+ 06 Apr 2008; Maurice van der Pot <griffon26@gentoo.org>
+ +tpop3d-1.5.4.ebuild:
+ Added tpop3d 1.5.4 and also fixed bug #195488 reported by Nico R.
+ <n-roeser@gmx.net>. This ebuild has a bunch of new USE flags one may want to
+ set before upgrading.
12 Jun 2007; Marius Mauch <genone@gentoo.org> tpop3d-1.5.3.ebuild,
tpop3d-1.5.3-r1.ebuild:
diff --git a/net-mail/tpop3d/tpop3d-1.5.4.ebuild b/net-mail/tpop3d/tpop3d-1.5.4.ebuild
new file mode 100644
index 000000000000..d7222b0281c9
--- /dev/null
+++ b/net-mail/tpop3d/tpop3d-1.5.4.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.5.4.ebuild,v 1.1 2008/04/06 17:55:17 griffon26 Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="An extensible POP3 server with vmail-sql/MySQL support."
+HOMEPAGE="http://savannah.nongnu.org/projects/tpop3d/"
+SRC_URI="http://download.savannah.nongnu.org/releases/tpop3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="authexternal debug drac flatfile gdbm ldap maildir mbox mysql offensive
+ pam passwd perl postgres +sha1 shadow ssl tcpd"
+
+RDEPEND="
+ debug? ( >=dev-util/efence-2.4.13 )
+ sha1? ( >=dev-libs/openssl-0.9.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ mysql? ( virtual/mysql )
+ postgres? ( >=dev-db/postgresql-7.3 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ pam? ( >=sys-libs/pam-0.75
+ >=net-mail/mailbase-0.00-r8 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ drac? ( mail-client/drac )"
+
+src_compile() {
+ local myconf=""
+ local noauth=0
+
+ elog "This version of the tpop3d ebuild has a lot of new USE flags."
+ elog "Make sure that everything you need is enabled."
+
+ # Various authentication methods
+ use authexternal && myconf="${myconf} --enable-auth-other"
+ use flatfile && myconf="${myconf} --enable-auth-flatfile"
+ use gdbm && myconf="${myconf} --enable-auth-gdbm"
+ use ldap && myconf="${myconf} --enable-auth-ldap"
+ use mysql && myconf="${myconf} --enable-auth-mysql"
+ use pam || myconf="${myconf} --disable-auth-pam"
+ use passwd && myconf="${myconf} --enable-auth-passwd"
+ use perl && myconf="${myconf} --enable-auth-perl"
+ use postgres && myconf="${myconf} --enable-auth-pgsql"
+ use shadow && myconf="${myconf} --enable-auth-passwd --enable-shadow-passwords"
+
+ use authexternal || use flatfile || use gdbm || use ldap || use mysql ||
+ use pam || use passwd || use perl || use postgres || use shadow ||
+ noauth=1
+
+ if [[ ${noauth} -eq 1 ]]; then
+ ewarn "None of tpop3d's authentication mechanism USE flags are set."
+ ewarn "As a result tpop3d will be built with /etc/passwd authentication only."
+ myconf="${myconf} --enable-auth-passwd"
+ fi
+
+ # Other optional features
+ use debug && myconf="${myconf} --enable-electric-fence --enable-backtrace"
+ use maildir && myconf="${myconf} --enable-mbox-maildir"
+ use mbox || myconf="${myconf} --disable-mbox-bsd"
+ use offensive || myconf="${myconf} --disable-snide-comments"
+ use sha1 || myconf="${myconf} --disable-sha1-passwords"
+ use ssl && myconf="${myconf} --enable-tls"
+ use tcpd && myconf="${myconf} --enable-tcp-wrappers"
+
+ # Install mail-client/drac for integration with tpop3d
+ use drac && myconf="${myconf} --enable-drac"
+
+ econf ${myconf} || die "./configure failed"
+
+ # Causes crash with "stack smashing attack" on connect, because of bug in
+ # SSP (bug #115285)
+ filter-flags -fstack-protector
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodir /etc/tpop3d
+
+ if use pam ; then
+ dodir /etc/pam.d
+ dosym /etc/pam.d/pop3 /etc/pam.d/tpop3d
+ fi
+
+ newinitd "${FILESDIR}/tpop3d-init" tpop3d
+}
+
+pkg_postinst() {
+ elog "Read the tpop3d.conf manpage"
+ elog "Please create /etc/tpop3d/tpop3d.conf to fit your configuration"
+}