summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-03-08 17:01:29 +0000
committerMarius Mauch <genone@gentoo.org>2004-03-08 17:01:29 +0000
commit3c7fbe8fe18995d98a112419d6957a5e2f040b82 (patch)
treecfd0725303d3e666633ea32455f9860052bb33e4 /net-mail
parentSELFHTML 8.0 with errata-pack 1 (therefore the initial ebuild is named -r1) (... (diff)
downloadgentoo-2-3c7fbe8fe18995d98a112419d6957a5e2f040b82.tar.gz
gentoo-2-3c7fbe8fe18995d98a112419d6957a5e2f040b82.tar.bz2
gentoo-2-3c7fbe8fe18995d98a112419d6957a5e2f040b82.zip
version bump
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed-claws/ChangeLog8
-rw-r--r--net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.9.102
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.9.10.ebuild143
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.9.5-r1.ebuild4
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild4
5 files changed, 156 insertions, 5 deletions
diff --git a/net-mail/sylpheed-claws/ChangeLog b/net-mail/sylpheed-claws/ChangeLog
index b25a8b51c3cc..c53aec31abc6 100644
--- a/net-mail/sylpheed-claws/ChangeLog
+++ b/net-mail/sylpheed-claws/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/sylpheed-claws
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.64 2004/02/08 23:57:01 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.65 2004/03/08 17:01:29 genone Exp $
+
+*sylpheed-claws-0.9.10 (08 Mar 2004)
+
+ 08 Mar 2004; Marius Mauch <genone@gentoo.org> sylpheed-claws-0.9.10.ebuild,
+ sylpheed-claws-0.9.5-r1.ebuild, sylpheed-claws-0.9.9.ebuild:
+ version bump, marking 0.9.9 stable on x86
*sylpheed-claws-0.9.9 (09 Feb 2004)
diff --git a/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.9.10 b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.9.10
new file mode 100644
index 000000000000..8d9547bb7111
--- /dev/null
+++ b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.9.10
@@ -0,0 +1,2 @@
+MD5 53c3f65afe8e1c96e07bf33c7f76ef5a sylpheed-0.9.10claws.tar.bz2 2969973
+MD5 76f1a9069271ecef0a4c2d463c58708d ghostscript-viewer-0.6.tar.bz2 244060
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.9.10.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.9.10.ebuild
new file mode 100644
index 000000000000..b350591b937d
--- /dev/null
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.9.10.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.9.10.ebuild,v 1.1 2004/03/08 17:01:29 genone Exp $
+
+IUSE="nls gnome xface dillo crypt spell imlib ssl ldap ipv6 pda clamav pdflib"
+
+inherit eutils
+
+GS_PN=ghostscript-viewer
+GS_PV=0.6
+MY_GS=${GS_PN}-${GS_PV}
+MY_P="sylpheed-${PV}claws"
+S=${WORKDIR}/${MY_P}
+S2=${S}/src/plugins/${MY_GS}
+DESCRIPTION="Bleeding edge version of Sylpheed"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2
+ pdflib? ( mirror://sourceforge/${PN}/${MY_GS}.tar.bz2 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=sys-apps/sed-4
+ =x11-libs/gtk+-1.2*
+ pda? ( >=app-pda/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( =app-crypt/gpgme-0.3.14 )
+ dillo? ( net-www/dillo )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( virtual/aspell-dict )
+ xface? ( >=media-libs/compface-1.4 )
+ pdflib? ( virtual/ghostscript )
+ nls? ( >=sys-devel/gettext-0.12 )"
+
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ net-mail/metamail
+ x11-misc/shared-mime-info"
+
+PROVIDE="virtual/sylpheed"
+
+src_unpack() {
+ unpack ${A}
+
+ mv ${WORKDIR}/${MY_GS} ${S}/src/plugins
+
+ # Change package name to sylpheed-claws ...
+ for i in `find ${S}/ -name 'configure*'`; do
+ sed -i "s/PACKAGE\=sylpheed/PACKAGE\=sylpheed-claws/" ${i}
+ done
+
+ # use shared-mime-info
+ cd ${S}/src
+ epatch ${FILESDIR}/procmime.patch
+
+ # procmime API was changed between 0.9.6 and 0.9.7,
+ # default Makefile uses installed (=old) headers
+ if use pdflib; then
+ cd ${S2}
+ epatch ${FILESDIR}/gv-procmime-Makefile.in.patch
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} `use_enable gnome gdk-pixbuf`"
+ myconf="${myconf} `use_enable imlib`"
+ myconf="${myconf} `use_enable spell aspell`"
+ myconf="${myconf} `use_enable ldap`"
+ myconf="${myconf} `use_enable ssl openssl`"
+ myconf="${myconf} `use_enable crypt gpgme`"
+ myconf="${myconf} `use_enable ipv6`"
+ myconf="${myconf} `use_enable pda jpilot`"
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+ myconf="${myconf} `use_enable clamav clamav-plugin`"
+ myconf="${myconf} `use_enable xface compface`"
+
+ echo ${myconf}
+
+ econf \
+ --program-suffix=-claws \
+ --enable-spamassassin-plugin \
+ ${myconf} || die "./configure failed"
+
+ make || die
+
+ # build the extra tools
+ cd ${S}/tools
+ emake || die
+
+ # build the ghostscript-viewer plugin
+ if use pdflib; then
+ cd ${S2}
+ einfo "Compiling ghostscript-viewer plugin"
+ PKG_CONFIG_PATH=${S} \
+ CFLAGS="-I${S} -I${S}/src -I${S}/src/common -I${S}/src/gtk ${CFLAGS}" \
+ CXXFLAGS="${CFLAGS}" \
+ econf --with-sylpheed-dir=../.. || die
+
+ emake || die
+ fi
+
+ cd ${S}
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ local menuentry="/usr/share/gnome/apps/Internet/sylpheed.desktop"
+ if use gnome; then
+ dosed "s/Sylpheed/Sylpheed Claws/" ${menuentry}
+ dosed "s/sylpheed/sylpheed-claws/" ${menuentry}
+ mv ${D}${menuentry} ${D}${menuentry/sylpheed/sylpheed-claws}
+ else
+ rm -rf ${D}/usr/share/gnome
+ fi
+
+ dodir /usr/share/pixmaps
+ mv sylpheed.png ${D}/usr/share/pixmaps/sylpheed-claws.png
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+ docinto tools
+ dodoc tools/README*
+
+ # install the extra tools
+ cd ${S}/tools
+ exeinto /usr/lib/${PN}/tools
+ doexe *.pl *.py *.rc *.conf gpg-sign-syl
+ doexe launch_firebird tb2sylpheed update-po uudec
+
+ # install the ghostscipt-viewer plugin
+ if use pdflib; then
+ cd ${S2}
+ make plugindir=${D}/usr/lib/${PN}/plugins install || die
+ docinto ${MY_GS}
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ fi
+}
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.9.5-r1.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.9.5-r1.ebuild
index f219a612798c..ffe676014a8c 100644
--- a/net-mail/sylpheed-claws/sylpheed-claws-0.9.5-r1.ebuild
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.9.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.9.5-r1.ebuild,v 1.7 2004/02/22 16:29:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.9.5-r1.ebuild,v 1.8 2004/03/08 17:01:29 genone Exp $
IUSE="nls gnome gtk2 xface gtkhtml crypt spell imlib ssl ldap ipv6 pda clamav pdflib"
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild
index f840925a838f..4dbe819252e0 100644
--- a/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild,v 1.1 2004/02/08 23:57:01 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild,v 1.2 2004/03/08 17:01:29 genone Exp $
IUSE="nls gnome xface dillo crypt spell imlib ssl ldap ipv6 pda clamav pdflib"
@@ -19,7 +19,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
DEPEND=">=sys-apps/sed-4
=x11-libs/gtk+-1.2*