summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-06-12 20:42:43 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-06-12 20:42:43 +0000
commit41e5279667b4e311f61c991695c15cabf6eb7ae2 (patch)
treef0b92f20300ad08f566ffb3e2a4acbfa802e5a43 /net-mail
parentRevbump, include kolab-patches (diff)
downloadgentoo-2-41e5279667b4e311f61c991695c15cabf6eb7ae2.tar.gz
gentoo-2-41e5279667b4e311f61c991695c15cabf6eb7ae2.tar.bz2
gentoo-2-41e5279667b4e311f61c991695c15cabf6eb7ae2.zip
Revbump, include kolab-patches
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog9
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild77
-rw-r--r--net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.3.14-kolab-annotations.patch82
3 files changed, 167 insertions, 1 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index e121e7c384d0..75f75cffdbaf 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/cyrus-imap-admin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.83 2009/06/08 03:33:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.84 2009/06/12 20:42:43 dertobi123 Exp $
+
+*cyrus-imap-admin-2.3.14-r1 (12 Jun 2009)
+
+ 12 Jun 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +files/cyrus-imap-admin-2.3.14-kolab-annotations.patch,
+ +cyrus-imap-admin-2.3.14-r1.ebuild:
+ Revbump, include kolab-patches
08 Jun 2009; Jeroen Roovers <jer@gentoo.org>
cyrus-imap-admin-2.3.14.ebuild:
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild
new file mode 100644
index 000000000000..f8391800598b
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14-r1.ebuild,v 1.1 2009/06/12 20:42:43 dertobi123 Exp $
+
+inherit autotools perl-app eutils
+
+MY_PV=${PV/_/}
+
+PIC_PATCH_VER="2.2"
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl kerberos kolab"
+
+RDEPEND=">=sys-libs/db-3.2
+ >=dev-lang/perl-5.6.1
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND
+ sys-devel/libtool
+ >=sys-devel/autoconf-2.58
+ sys-devel/automake
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ # Versioned symbols.
+ epatch "${FILESDIR}/${PN}-${PIC_PATCH_VER}-fPIC.patch"
+
+ # Recreate configure.
+ WANT_AUTOCONF="2.5"
+ eautoreconf
+
+ # When linking with rpm, you need to link with more libraries.
+ sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
+
+ # Add kolab support.
+ if use kolab ; then
+ epatch "${FILESDIR}/${P}-kolab-annotations.patch" || die "epatch failed"
+ fi
+}
+
+src_compile() {
+
+ local myconf
+ myconf="${myconf} `use_with ssl openssl`"
+ myconf="${myconf} `use_with kerberos krb`"
+
+ econf \
+ --disable-server \
+ --enable-murder \
+ --enable-listext \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-perl=/usr/bin/perl \
+ ${myconf} || die "econf failed"
+
+ emake -C "${S}/lib" all || die "compile problem"
+ emake -C "${S}/perl" all || die "compile problem"
+}
+
+src_install () {
+ make -C "${S}/perl" DESTDIR="${D}" install || die "install problem"
+ fixlocalpod # bug #98122
+}
diff --git a/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.3.14-kolab-annotations.patch b/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.3.14-kolab-annotations.patch
new file mode 100644
index 000000000000..3fd0a906ae12
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.3.14-kolab-annotations.patch
@@ -0,0 +1,82 @@
+Allows to use arbitrary annotations with the cyradm tool.
+
+diff -r 639190be2385 doc/man/cyradm.1.html
+--- a/doc/man/cyradm.1.html Mon Oct 27 18:48:18 2008 +0100
++++ b/doc/man/cyradm.1.html Mon Oct 27 18:48:25 2008 +0100
+@@ -245,6 +245,13 @@
+ <dd>
+ <p>Sets an email address to which messages injected into the server via NNTP
+ will be sent.</p>
++</dd>
++</li>
++<dt><strong><a NAME="item__2fexplicit_2fannotation"><code>/explicit/annotation</code></a></strong>
++
++<dd>
++<p>Sets the annotation <em>/explicit/annotation</em>
++on <em>mailbox</em> to <em>value</em>.</p>
+ </dd>
+ </li>
+ <dt><strong><a name="sharedseen" class="item"><code>sharedseen</code></a></strong>
+diff -r 639190be2385 perl/imap/IMAP/Admin.pm
+--- a/perl/imap/IMAP/Admin.pm Mon Oct 27 18:48:18 2008 +0100
++++ b/perl/imap/IMAP/Admin.pm Mon Oct 27 18:48:26 2008 +0100
+@@ -797,11 +797,11 @@
+ return undef;
+ }
+
+- if(!exists($values{$entry})) {
+- $self->{error} = "Unknown parameter $entry";
++ if(exists($values{$entry})) {
++ $entry = $values{$entry};
++ } else {
++ $self->{error} = "Unknown parameter $entry" unless substr($entry,0,1) eq "/";
+ }
+-
+- $entry = $values{$entry};
+
+ my ($rc, $msg);
+
+diff -r 639190be2385 perl/imap/IMAP/Shell.pm
+--- a/perl/imap/IMAP/Shell.pm Mon Oct 27 18:48:18 2008 +0100
++++ b/perl/imap/IMAP/Shell.pm Mon Oct 27 18:48:26 2008 +0100
+@@ -127,7 +127,7 @@
+ [\&_sc_info, '[mailbox]',
+ 'display mailbox/server metadata'],
+ mboxcfg =>
+- [\&_sc_mboxcfg, 'mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat] value',
++ [\&_sc_mboxcfg, 'mailbox [comment|condstore|news2mail|expire|sieve|squat|/<explicit annotation>] value',
+ 'configure mailbox'],
+ mboxconfig => 'mboxcfg',
+ reconstruct =>
+@@ -1437,7 +1437,7 @@
+ while (defined ($opt = shift(@argv))) {
+ last if $opt eq '--';
+ if ($opt =~ /^-/) {
+- die "usage: mboxconfig mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat] value\n";
++ die "usage: mboxconfig mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat|/<explicit annotation>] value\n";
+ }
+ else {
+ push(@nargv, $opt);
+@@ -1446,7 +1446,7 @@
+ }
+ push(@nargv, @argv);
+ if (@nargv < 2) {
+- die "usage: mboxconfig mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat] value\n";
++ die "usage: mboxconfig mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat|/<explicit annotation>] value\n";
+ }
+ if (!$cyrref || !$$cyrref) {
+ die "mboxconfig: no connection to server\n";
+diff -r 639190be2385 perl/imap/cyradm.sh
+--- a/perl/imap/cyradm.sh Mon Oct 27 18:48:18 2008 +0100
++++ b/perl/imap/cyradm.sh Mon Oct 27 18:48:26 2008 +0100
+@@ -241,6 +241,10 @@
+
+ Indicates that the mailbox should have a squat index created for it.
+
++=item C</explicit/annotation>
++
++Sets the annotation I</explicit/annotation> on I<mailbox> to I<value>.
++
+ =back
+
+ =item C<renamemailbox> [C<--partition> I<partition>] I<oldname> I<newname>