summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-01-17 10:15:50 +0000
committerThomas Kahle <tomka@gentoo.org>2012-01-17 10:15:50 +0000
commit44145f192d92f6309d49f1ca3fd5148c3b2f80ab (patch)
tree13dfc6931b490cc6faf9d06e110a995d47b6cd09 /net-mail
parentAdd prefix love (diff)
downloadgentoo-2-44145f192d92f6309d49f1ca3fd5148c3b2f80ab.tar.gz
gentoo-2-44145f192d92f6309d49f1ca3fd5148c3b2f80ab.tar.bz2
gentoo-2-44145f192d92f6309d49f1ca3fd5148c3b2f80ab.zip
bump to 6.5.2
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/offlineimap/ChangeLog7
-rw-r--r--net-mail/offlineimap/offlineimap-6.5.2.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/net-mail/offlineimap/ChangeLog b/net-mail/offlineimap/ChangeLog
index 53ce243cb22c..eb0ffb553200 100644
--- a/net-mail/offlineimap/ChangeLog
+++ b/net-mail/offlineimap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/offlineimap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.78 2012/01/08 14:02:13 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.79 2012/01/17 10:15:50 tomka Exp $
+
+*offlineimap-6.5.2 (17 Jan 2012)
+
+ 17 Jan 2012; Thomas Kahle <tomka@gentoo.org> +offlineimap-6.5.2.ebuild:
+ bump to 6.5.2
*offlineimap-6.5.1.2 (08 Jan 2012)
diff --git a/net-mail/offlineimap/offlineimap-6.5.2.ebuild b/net-mail/offlineimap/offlineimap-6.5.2.ebuild
new file mode 100644
index 000000000000..58b01ee255e7
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-6.5.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/offlineimap-6.5.2.ebuild,v 1.1 2012/01/17 10:15:50 tomka Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="threads ssl?"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.*" #see bug 394307
+
+inherit eutils distutils
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+# SRC_URI="http://offlineimap.org/downloads/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+# Lately only spaetz gitub:
+SRC_URI="https://github.com/downloads/spaetz/${PN}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+DEPEND="doc? ( dev-python/docutils )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/offlineimap-6.3.2-darwin10.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ cd docs
+ rst2man.py MANUAL.rst offlineimap.1 || die "building manpage failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ if use doc ; then
+ cd docs
+ doman offlineimap.1 || die "installing manpage failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog ""
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+
+ elog "If you upgraded from 6.3.* then you may need to update your config:"
+ elog ""
+ elog "If you use nametrans= settings on a remote repository, you will have"
+ elog "to add a \"reverse\" nametrans setting to the local repository, so that"
+ elog "it knows which folders it should (not) create on the remote side."
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ elog ""
+}