summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-25 20:25:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-25 20:25:58 +0000
commit7f1185033cfcd733d13a39149b7ab2ae38d7bc56 (patch)
tree79d1841c8eb80491bb16ce9dada70a9a3bbc4439 /net-mail
parentFix deprecation warnings. (diff)
downloadgentoo-2-7f1185033cfcd733d13a39149b7ab2ae38d7bc56.tar.gz
gentoo-2-7f1185033cfcd733d13a39149b7ab2ae38d7bc56.tar.bz2
gentoo-2-7f1185033cfcd733d13a39149b7ab2ae38d7bc56.zip
Fix deprecation warnings.
(Portage version: 2.2.0_alpha30_p2/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/ChangeLog9
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.17-r1.ebuild16
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.17.ebuild16
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.18.ebuild16
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.19.ebuild16
5 files changed, 43 insertions, 30 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index e18fc47103a6..8c636f852370 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.197 2010/12/13 08:23:01 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.198 2011/04/25 20:25:58 arfrever Exp $
+
+ 25 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ fetchmail-6.3.17.ebuild, fetchmail-6.3.17-r1.ebuild, fetchmail-6.3.18.ebuild,
+ fetchmail-6.3.19.ebuild:
+ Fix deprecation warnings.
*fetchmail-6.3.19 (13 Dec 2010)
diff --git a/net-mail/fetchmail/fetchmail-6.3.17-r1.ebuild b/net-mail/fetchmail/fetchmail-6.3.17-r1.ebuild
index fb55c0b4ca66..110e92f9f6e5 100644
--- a/net-mail/fetchmail/fetchmail-6.3.17-r1.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.3.17-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.17-r1.ebuild,v 1.1 2010/05/18 06:06:51 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.17-r1.ebuild,v 1.2 2011/04/25 20:25:58 arfrever Exp $
-EAPI=2
+EAPI=3
PYTHON_DEPEND="tk? 2"
PYTHON_USE_WITH_OPT="tk"
@@ -30,8 +30,10 @@ DEPEND="${RDEPEND}
pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
- use tk && python_set_active_version 2
- python_pkg_setup
+ if use tk; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -89,7 +91,7 @@ src_install() {
}
pkg_postinst() {
- use tk && python_mod_optimize "$(python_get_sitedir)/fetchmailconf.py"
+ use tk && python_mod_optimize fetchmailconf.py
ewarn "From the NEWS:"
ewarn "Fetchmail now supports a bad-header command line or rcfile option that takes"
@@ -106,5 +108,5 @@ pkg_postinst() {
}
pkg_postrm() {
- use tk && python_mod_cleanup "$(python_get_sitedir)/fetchmailconf.py"
+ use tk && python_mod_cleanup fetchmailconf.py
}
diff --git a/net-mail/fetchmail/fetchmail-6.3.17.ebuild b/net-mail/fetchmail/fetchmail-6.3.17.ebuild
index 35bf237d1627..8dd53c3dc4d3 100644
--- a/net-mail/fetchmail/fetchmail-6.3.17.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.3.17.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.17.ebuild,v 1.7 2010/05/12 22:32:15 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.17.ebuild,v 1.8 2011/04/25 20:25:58 arfrever Exp $
-EAPI=2
+EAPI=3
PYTHON_DEPEND="tk? 2"
PYTHON_USE_WITH_OPT="tk"
@@ -30,8 +30,10 @@ DEPEND="${RDEPEND}
pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
- use tk && python_set_active_version 2
- python_pkg_setup
+ if use tk; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -86,7 +88,7 @@ src_install() {
}
pkg_postinst() {
- use tk && python_mod_optimize "$(python_get_sitedir)/fetchmailconf.py"
+ use tk && python_mod_optimize fetchmailconf.py
ewarn "From the NEWS:"
ewarn "Fetchmail now supports a bad-header command line or rcfile option that takes"
@@ -103,5 +105,5 @@ pkg_postinst() {
}
pkg_postrm() {
- use tk && python_mod_cleanup "$(python_get_sitedir)/fetchmailconf.py"
+ use tk && python_mod_cleanup fetchmailconf.py
}
diff --git a/net-mail/fetchmail/fetchmail-6.3.18.ebuild b/net-mail/fetchmail/fetchmail-6.3.18.ebuild
index 97b288b0b427..101d68aab719 100644
--- a/net-mail/fetchmail/fetchmail-6.3.18.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.3.18.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.18.ebuild,v 1.2 2010/10/10 07:59:25 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.18.ebuild,v 1.3 2011/04/25 20:25:58 arfrever Exp $
-EAPI=2
+EAPI=3
PYTHON_DEPEND="tk? 2"
PYTHON_USE_WITH_OPT="tk"
@@ -30,8 +30,10 @@ DEPEND="${RDEPEND}
pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
- use tk && python_set_active_version 2
- python_pkg_setup
+ if use tk; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -85,12 +87,12 @@ src_install() {
}
pkg_postinst() {
- use tk && python_mod_optimize "$(python_get_sitedir)/fetchmailconf.py"
+ use tk && python_mod_optimize fetchmailconf.py
elog "Please see /etc/conf.d/fetchmail if you want to adjust"
elog "the polling delay used by the fetchmail init script."
}
pkg_postrm() {
- use tk && python_mod_cleanup "$(python_get_sitedir)/fetchmailconf.py"
+ use tk && python_mod_cleanup fetchmailconf.py
}
diff --git a/net-mail/fetchmail/fetchmail-6.3.19.ebuild b/net-mail/fetchmail/fetchmail-6.3.19.ebuild
index 3c1a7d98e140..22acdaf6ca84 100644
--- a/net-mail/fetchmail/fetchmail-6.3.19.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.3.19.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.19.ebuild,v 1.1 2010/12/13 08:23:01 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.19.ebuild,v 1.2 2011/04/25 20:25:58 arfrever Exp $
-EAPI=2
+EAPI=3
PYTHON_DEPEND="tk? 2"
PYTHON_USE_WITH_OPT="tk"
@@ -30,8 +30,10 @@ DEPEND="${RDEPEND}
pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
- use tk && python_set_active_version 2
- python_pkg_setup
+ if use tk; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -85,12 +87,12 @@ src_install() {
}
pkg_postinst() {
- use tk && python_mod_optimize "$(python_get_sitedir)/fetchmailconf.py"
+ use tk && python_mod_optimize fetchmailconf.py
elog "Please see /etc/conf.d/fetchmail if you want to adjust"
elog "the polling delay used by the fetchmail init script."
}
pkg_postrm() {
- use tk && python_mod_cleanup "$(python_get_sitedir)/fetchmailconf.py"
+ use tk && python_mod_cleanup fetchmailconf.py
}