summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-12-05 20:03:17 +0000
committerNick Hadaway <raker@gentoo.org>2002-12-05 20:03:17 +0000
commit9048b3fb4b89f8a25c3f9d13c3f4f5642ec5e042 (patch)
treeb2f403ada0d5fa89ba8220c2a5c61b9c11a1a4c2 /net-mail
parenttweaked qt dep (diff)
downloadgentoo-2-9048b3fb4b89f8a25c3f9d13c3f4f5642ec5e042.tar.gz
gentoo-2-9048b3fb4b89f8a25c3f9d13c3f4f5642ec5e042.tar.bz2
gentoo-2-9048b3fb4b89f8a25c3f9d13c3f4f5642ec5e042.zip
ssl certs sed statement fix as noted on bug #11638 and removes
-I/usr/include warnings.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pine/ChangeLog9
-rw-r--r--net-mail/pine/files/digest-pine-4.50-r41
-rw-r--r--net-mail/pine/pine-4.50-r4.ebuild135
3 files changed, 144 insertions, 1 deletions
diff --git a/net-mail/pine/ChangeLog b/net-mail/pine/ChangeLog
index 348a21f97324..a70264b7cf1b 100644
--- a/net-mail/pine/ChangeLog
+++ b/net-mail/pine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/pine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.12 2002/12/03 21:28:39 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.13 2002/12/05 20:03:17 raker Exp $
+
+*pine-4.50-r4 (06 Dec 2002)
+
+ 06 Dec 2002; Nick Hadaway <raker@gentoo.org> pine-4.50-r4.ebuild,
+ files/digest-pine-4.50-r4 :
+ Fixed ssl certs directory as noted on bug #11638 and fixed some
+ compile-time warnings.
*pine-4.50-r3 (03 Dec 2002)
diff --git a/net-mail/pine/files/digest-pine-4.50-r4 b/net-mail/pine/files/digest-pine-4.50-r4
new file mode 100644
index 000000000000..81a5a0524429
--- /dev/null
+++ b/net-mail/pine/files/digest-pine-4.50-r4
@@ -0,0 +1 @@
+MD5 5f517297242f625de9a9ccbaf48578f0 pine4.50.tar.gz 3772620
diff --git a/net-mail/pine/pine-4.50-r4.ebuild b/net-mail/pine/pine-4.50-r4.ebuild
new file mode 100644
index 000000000000..98917518fc49
--- /dev/null
+++ b/net-mail/pine/pine-4.50-r4.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.50-r4.ebuild,v 1.1 2002/12/05 20:03:17 raker Exp $
+
+IUSE="ssl ldap"
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+SRC_URI="ftp://ftp.cac.washington.edu/${PN}/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.washington.edu/pine/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )"
+
+SLOT="0"
+LICENSE="PICO"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+
+src_unpack() {
+ unpack ${A}
+
+ if [ "`use mbox`" ] ; then
+ patch -d ${S} -p0 < ${FILESDIR}/imap-4.7c2-flock.patch
+ else
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.50-maildir.patch
+ patch -d ${S} -p0 < ${FILESDIR}/imap-4.7c2-flock+maildir.patch
+ fi
+
+ # fix for Home and End keys
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-fixhome.patch
+
+ # flock() emulation
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+
+ # change /bin/passwd to /usr/bin/passwd
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-passwd.patch
+
+ if [ "`use ldap`" ] ; then
+ # link to shared ldap libs instead of static
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+
+ # small flock() related fix
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-boguswarning.patch
+
+ # segfix? not sure what this is for but it still applies
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.31-segfix.patch
+
+ # change lock files from 0666 to 0600
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-lockfile-perm.patch
+
+ # add missing needed time.h includes
+ patch -d ${S} -p1 < ${FILESDIR}/imap-2000-time.patch
+
+ # gets rid of a call to stripwhitespace()
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.33-whitespace.patch
+
+ if [ -n "$DEBUG" ]; then
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ < makefile.orig > makefile.lnx
+ else
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+ fi
+
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ cd ${S}/imap/src/osdep/unix
+ cp Makefile Makefile.orig
+ sed \
+ -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
+ -e "s:\$(SSLCERTS):/etc/ssl/certs:" \
+ -e "s:-I\$(SSLINCLUDE) ::" \
+ < Makefile.orig > Makefile
+ cd ${S}
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+ use mbox || dodoc README.maildir
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/FAQ imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}
+