summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-01-25 09:56:06 +0000
committerThomas Kahle <tomka@gentoo.org>2012-01-25 09:56:06 +0000
commit9a3df9a9c0e5d202de360fa134f2cf1a74c06f8f (patch)
tree7bf4f0a57038e2b2f295c263f98b64519ece501a /net-mail
parentRemove old. (diff)
downloadgentoo-2-9a3df9a9c0e5d202de360fa134f2cf1a74c06f8f.tar.gz
gentoo-2-9a3df9a9c0e5d202de360fa134f2cf1a74c06f8f.tar.bz2
gentoo-2-9a3df9a9c0e5d202de360fa134f2cf1a74c06f8f.zip
bump to 6.5.2.1_rc1 to fix bug 399597
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/offlineimap/ChangeLog7
-rw-r--r--net-mail/offlineimap/offlineimap-6.5.2.1_rc1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/net-mail/offlineimap/ChangeLog b/net-mail/offlineimap/ChangeLog
index eb0ffb553200..ad909f640821 100644
--- a/net-mail/offlineimap/ChangeLog
+++ b/net-mail/offlineimap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/offlineimap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.79 2012/01/17 10:15:50 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.80 2012/01/25 09:56:06 tomka Exp $
+
+*offlineimap-6.5.2.1_rc1 (25 Jan 2012)
+
+ 25 Jan 2012; Thomas Kahle <tomka@gentoo.org> +offlineimap-6.5.2.1_rc1.ebuild:
+ bump to 6.5.2.1_rc1 to fix bug 399597
*offlineimap-6.5.2 (17 Jan 2012)
diff --git a/net-mail/offlineimap/offlineimap-6.5.2.1_rc1.ebuild b/net-mail/offlineimap/offlineimap-6.5.2.1_rc1.ebuild
new file mode 100644
index 000000000000..4eee348d9e75
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-6.5.2.1_rc1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/offlineimap-6.5.2.1_rc1.ebuild,v 1.1 2012/01/25 09:56:06 tomka Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="threads ssl?"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.*" #see bug 394307
+
+inherit eutils distutils
+
+MYPV=${PV//_/-}
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+# SRC_URI="http://offlineimap.org/downloads/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+# Lately only spaetz gitub:
+SRC_URI="https://github.com/downloads/spaetz/${PN}/${PN}-v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+DEPEND="doc? ( dev-python/docutils )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/offlineimap-6.3.2-darwin10.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ cd docs
+ rst2man.py MANUAL.rst offlineimap.1 || die "building manpage failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ if use doc ; then
+ cd docs
+ doman offlineimap.1 || die "installing manpage failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog ""
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+
+ elog "If you upgraded from 6.3.* then you may need to update your config:"
+ elog ""
+ elog "If you use nametrans= settings on a remote repository, you will have"
+ elog "to add a \"reverse\" nametrans setting to the local repository, so that"
+ elog "it knows which folders it should (not) create on the remote side."
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ elog ""
+}