summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2015-07-21 15:35:26 +0000
committerEray Aslan <eras@gentoo.org>2015-07-21 15:35:26 +0000
commit9a8904c922ee24f9ae0aa5d5fc4e515c282b9f3d (patch)
tree153d827c9e570077d7e067fcbe8427929286f45c /net-mail
parentCreate logs directory in $CATALINA_BASE and set up perms to 0750. Fix securit... (diff)
downloadgentoo-2-9a8904c922ee24f9ae0aa5d5fc4e515c282b9f3d.tar.gz
gentoo-2-9a8904c922ee24f9ae0aa5d5fc4e515c282b9f3d.tar.bz2
gentoo-2-9a8904c922ee24f9ae0aa5d5fc4e515c282b9f3d.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog9
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index c2aa6336f8f1..8729b24ca759 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/cyrus-imap-admin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.136 2014/11/16 20:42:08 dilfridge Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.137 2015/07/21 15:35:26 eras Exp $
+
+*cyrus-imap-admin-2.4.18 (21 Jul 2015)
+
+ 21 Jul 2015; Eray Aslan <eras@gentoo.org> +cyrus-imap-admin-2.4.18.ebuild:
+ Version bump
16 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org>
cyrus-imap-admin-2.4.17-r1.ebuild:
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild
new file mode 100644
index 000000000000..700d72ff6982
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild,v 1.1 2015/07/21 15:35:26 eras Exp $
+
+EAPI=5
+inherit autotools db-use eutils perl-app toolchain-funcs
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server"
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb kerberos ssl"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey
+ berkdb? ( >=sys-libs/db-3.2:* )
+ ssl? ( >=dev-libs/openssl-0.9.6:* )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.4.10-ldflags.patch"
+ sed -i -e "s/ar cr/$(tc-getAR) cr/" \
+ perl/sieve/lib/Makefile.in \
+ imap/Makefile.in \
+ lib/Makefile.in \
+ installsieve/Makefile.in \
+ com_err/et/Makefile.in \
+ sieve/Makefile.in \
+ syslog/Makefile.in
+ AT_M4DIR="cmulocal" eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use berkdb ; then
+ myconf="--with-bdb-incdir=$(db_includedir)"
+ fi
+ econf \
+ --disable-server \
+ --enable-murder \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-perl=/usr/bin/perl \
+ --without-krb \
+ --without-krbdes \
+ $(use_with berkdb bdb) \
+ $(use_enable kerberos gssapi) \
+ $(use_with ssl openssl) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${S}/lib" all
+ emake -C "${S}/perl" all
+}
+
+src_install () {
+ emake -C "${S}/perl" DESTDIR="${D}" INSTALLDIRS=vendor install
+ perl_delete_localpod # bug #98122
+}