summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-07-07 15:08:14 +0000
committerEray Aslan <eras@gentoo.org>2011-07-07 15:08:14 +0000
commitb817607a90c97719ec6f56841eb45e4d13780f51 (patch)
tree985d2ad3e8643a557445226ac2a1619e338eed20 /net-mail
parentFix SRC_URI. Remove "useless" restricts and instead use QA_PRESTRIPPED. Get a... (diff)
downloadgentoo-2-b817607a90c97719ec6f56841eb45e4d13780f51.tar.gz
gentoo-2-b817607a90c97719ec6f56841eb45e4d13780f51.tar.bz2
gentoo-2-b817607a90c97719ec6f56841eb45e4d13780f51.zip
Fix depreciation warning and crashed status in init script - bugs #366581 #374311. EAPI bump.
(Portage version: 2.1.10.4/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailgraph/ChangeLog11
-rw-r--r--net-mail/mailgraph/files/mailgraph.initd-new12
-rw-r--r--net-mail/mailgraph/mailgraph-1.14-r1.ebuild142
3 files changed, 160 insertions, 5 deletions
diff --git a/net-mail/mailgraph/ChangeLog b/net-mail/mailgraph/ChangeLog
index b81e73b4b0cc..6c64c8bb1b60 100644
--- a/net-mail/mailgraph/ChangeLog
+++ b/net-mail/mailgraph/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/mailgraph
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/ChangeLog,v 1.35 2008/06/15 10:19:03 zmedico Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/ChangeLog,v 1.36 2011/07/07 15:08:14 eras Exp $
+
+*mailgraph-1.14-r1 (07 Jul 2011)
+
+ 07 Jul 2011; Eray Aslan <eras@gentoo.org> +mailgraph-1.14-r1.ebuild,
+ files/mailgraph.initd-new:
+ Fix depreciation warning and crashed status in init script - bugs #366581
+ #374311. EAPI bump.
15 Jun 2008; Zac Medico <zmedico@gentoo.org> mailgraph-1.14.ebuild:
Bug #226505 - For compatibility with phase execution order in
diff --git a/net-mail/mailgraph/files/mailgraph.initd-new b/net-mail/mailgraph/files/mailgraph.initd-new
index a80bea9dbe22..4ba72fe7dd53 100644
--- a/net-mail/mailgraph/files/mailgraph.initd-new
+++ b/net-mail/mailgraph/files/mailgraph.initd-new
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/files/mailgraph.initd-new,v 1.3 2008/05/14 21:38:13 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/files/mailgraph.initd-new,v 1.4 2011/07/07 15:08:14 eras Exp $
start() {
ebegin "Starting mailgraph"
@@ -9,12 +9,18 @@ start() {
# read mail log messages somewhere other than /var/log/syslog?
[[ -n "${MG_LOGFILE}" ]] && MG_DAEMON_OPTS="${MG_DAEMON_OPTS} -l ${MG_LOGFILE}"
+ # create /var/run/mailgraph if necessary
+ if [ ! -d /var/run/mailgraph ] ; then
+ checkpath -q -d -o mgraph:adm -m 0775 /var/run/mailgraph || return 1
+ fi
+
UMASK=$(umask)
umask ${MG_DAEMON_UMASK:-0077}
start-stop-daemon --start \
--name mailgraph \
- -c "${MG_DAEMON_UID}:${MG_DAEMON_GID}" \
+ --user "${MG_DAEMON_UID}:${MG_DAEMON_GID}" \
--name mailgraph \
+ --pidfile ${MG_DAEMON_PID} \
--exec /usr/bin/mailgraph -- -v --daemon \
--daemon-log="${MG_DAEMON_LOG}" \
--daemon-pid="${MG_DAEMON_PID}" \
diff --git a/net-mail/mailgraph/mailgraph-1.14-r1.ebuild b/net-mail/mailgraph/mailgraph-1.14-r1.ebuild
new file mode 100644
index 000000000000..c5da4e5af860
--- /dev/null
+++ b/net-mail/mailgraph/mailgraph-1.14-r1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/mailgraph-1.14-r1.ebuild,v 1.1 2011/07/07 15:08:14 eras Exp $
+
+EAPI=4
+inherit eutils webapp
+
+DESCRIPTION="A mail statistics RRDtool frontend for Postfix"
+HOMEPAGE="http://mailgraph.schweikert.ch/"
+SRC_URI="http://mailgraph.schweikert.ch//pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/File-Tail
+ >=net-analyzer/rrdtool-1.2.2[perl]"
+DEPEND=">=sys-apps/sed-4"
+
+user_group_setup() {
+ # add user and group for mailgraph daemon
+ # also add mgraph to the group adm so it's able to
+ # read syslog logfile /var/log/messages (should be owned by
+ # root:adm with permission 0640)
+ enewgroup mgraph
+ enewuser mgraph -1 -1 /var/empty mgraph,adm
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ user_group_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e "s|\(my \$rrd = '\).*'|\1/var/lib/mailgraph/mailgraph.rrd'|" \
+ -e "s|\(my \$rrd_virus = '\).*'|\1/var/lib/mailgraph/mailgraph_virus.rrd'|" \
+ mailgraph.cgi || die "sed mailgraph.cgi failed"
+}
+
+src_install() {
+ webapp_src_preinst
+ # be sure to run webapp_src_install *before* doing the directories below
+ # because it cripples all other permissions :-(
+ webapp_src_install
+
+ # for the RRDs
+ dodir /var/lib
+ diropts -omgraph -gmgraph -m0750
+ dodir /var/lib/mailgraph
+ keepdir /var/lib/mailgraph
+
+ # log and pid file
+ diropts ""
+ dodir /var/log
+ dodir /var/run
+ diropts -omgraph -gadm -m0750
+ dodir /var/log/mailgraph
+ keepdir /var/log/mailgraph
+
+ # logrotate config for mailgraph log
+ diropts ""
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/mailgraph.logrotate-new mailgraph
+
+ # mailgraph daemon
+ newbin mailgraph.pl mailgraph
+
+ # mailgraph CGI script
+ exeinto ${MY_CGIBINDIR}
+ doexe mailgraph.cgi
+
+ # init/conf files for mailgraph daemon
+ newinitd "${FILESDIR}"/mailgraph.initd-new mailgraph
+ newconfd "${FILESDIR}"/mailgraph.confd-new mailgraph
+
+ # docs
+ dodoc README CHANGES
+}
+
+pkg_preinst() {
+ has_version "<=${CATEGORY}/${PN}-1.12"
+ previous_less_or_equal_to_1_12=$?
+}
+
+pkg_postinst() {
+ # Fix ownerships - previous versions installed these with
+ # root as owner
+ if [[ $previous_less_or_equal_to_1_12 = 0 ]] ; then
+ if [[ -d /var/lib/mailgraph ]] ; then
+ chown mgraph:mgraph /var/lib/mailgraph
+ fi
+ if [[ -d /var/log/mailgraph ]] ; then
+ chown mgraph:adm /var/log/mailgraph
+ fi
+ if [[ -d /var/run/mailgraph ]] ; then
+ chown mgraph:adm /var/run/mailgraph
+ fi
+ fi
+ elog
+ elog "Mailgraph will run as user mgraph with group adm by default."
+ elog "This can be changed in /etc/conf.d/mailgraph if it doesn't fit."
+ elog "Remember to adjust MG_DAEMON_LOG, MG_DAEMON_PID and MG_DAEMON_RRD"
+ elog "as well!"
+ elog
+ elog
+ ewarn
+ ewarn "Please make sure the MG_LOGFILE (default: /var/log/messages) is readable"
+ ewarn "by group adm or change MG_DAEMON_GID in /etc/conf.d/mailgraph accordingly!"
+ ewarn
+ ewarn "Please make sure *all* mail related logs (MTA, spamfilter, virus scanner)"
+ ewarn "go to the file /var/log/messages or change MG_LOGFILE in"
+ ewarn "/etc/conf.d/mailgraph accordingly! Otherwise mailgraph won't get to know"
+ ewarn "the corresponding events (virus/spam mail found etc.)."
+ ewarn
+ ewarn
+ elog
+ elog "Checking for user apache"
+ if egetent passwd apache >&/dev/null; then
+ elog
+ elog "Adding user apache to group mgraph so the included"
+ elog "CGI script is able to read the mailgraph RRD files"
+ elog
+ if ! gpasswd -a apache mgraph >&/dev/null; then
+ eerror "Failed to add user apache to group mgraph!"
+ eerror "Please check manually."
+ fi
+ else
+ elog
+ elog "User apache not found, maybe we will be running a"
+ elog "webserver with a different UID?"
+ elog "If that's the case, please add that user to the"
+ elog "group mgraph manually to enable the included"
+ elog "CGI script to read the mailgraph RRD files:"
+ elog
+ elog "\tgpasswd -a <user> mgraph"
+ elog
+ fi
+}