summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-05-21 22:01:19 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-05-21 22:01:19 +0000
commitd0bd1a4694535f7ea02b55e52755eb5233e631c4 (patch)
tree00a8710fa96157ea7f4b3b9a9b07290c537d5734 /net-mail
parentform fixes (diff)
downloadgentoo-2-d0bd1a4694535f7ea02b55e52755eb5233e631c4.tar.gz
gentoo-2-d0bd1a4694535f7ea02b55e52755eb5233e631c4.tar.bz2
gentoo-2-d0bd1a4694535f7ea02b55e52755eb5233e631c4.zip
Added an important note about PHP configuration.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/squirrelmail/squirrelmail-1.2.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/squirrelmail/squirrelmail-1.2.6.ebuild b/net-mail/squirrelmail/squirrelmail-1.2.6.ebuild
new file mode 100644
index 000000000000..7a33b218d6c5
--- /dev/null
+++ b/net-mail/squirrelmail/squirrelmail-1.2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/squirrelmail/squirrelmail-1.2.6.ebuild,v 1.1 2002/05/21 22:01:19 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+
+DESCRIPTION="Webmail for nuts!"
+
+SRC_URI="http://prdownloads.sf.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.squirrelmail.org"
+
+DEPEND="dev-lang/php
+ net-www/apache"
+
+RDEPEND="virtual/imapd"
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+ dodir ${HTTPD_ROOT}/${P}
+ dosym ${HTTPD_ROOT}/${P} ${HTTPD_ROOT}/${PN}
+ cp -r . ${D}/${HTTPD_ROOT}/${P}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_USER} ${P}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Squirrelmail requires PHP to have 'register_globals = On'"
+ einfo "Please edit /etc/PHP4/php.ini."
+ einfo
+}