summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-10-01 21:39:34 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-10-01 21:39:34 +0000
commitf037d82d9b5dc5b541d6b9b190bbe4c9ab9cad19 (patch)
tree59581e384d9640d6064e2682022cb765973601ef /net-mail
parentFixes for vendor libs; more concise checking for ${D} in files; (diff)
downloadgentoo-2-f037d82d9b5dc5b541d6b9b190bbe4c9ab9cad19.tar.gz
gentoo-2-f037d82d9b5dc5b541d6b9b190bbe4c9ab9cad19.tar.bz2
gentoo-2-f037d82d9b5dc5b541d6b9b190bbe4c9ab9cad19.zip
Revision bump, apply patch from #28504. Small QA fix to both ebuilds.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pop3vscan/ChangeLog9
-rw-r--r--net-mail/pop3vscan/Manifest4
-rw-r--r--net-mail/pop3vscan/files/digest-pop3vscan-0.4-r12
-rw-r--r--net-mail/pop3vscan/pop3vscan-0.4-r1.ebuild59
-rw-r--r--net-mail/pop3vscan/pop3vscan-0.4.ebuild5
5 files changed, 75 insertions, 4 deletions
diff --git a/net-mail/pop3vscan/ChangeLog b/net-mail/pop3vscan/ChangeLog
index 1a4e2757a4ec..e259d852792c 100644
--- a/net-mail/pop3vscan/ChangeLog
+++ b/net-mail/pop3vscan/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for net-mail/pop3vscan
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
# AUTHOR: José Alberto Suárez López <bass@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pop3vscan/ChangeLog,v 1.8 2004/06/24 23:26:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pop3vscan/ChangeLog,v 1.9 2004/10/01 21:39:34 ticho Exp $
+
+*pop3vscan-0.4-r1 (01 Oct 2004)
+
+ 01 Oct 2004; Andrej Kacian <ticho@gentoo.org> +pop3vscan-0.4-r1.ebuild,
+ pop3vscan-0.4.ebuild:
+ Revision bump, apply patch with some improvements. See bug #28504 for
+ details. Patch submitted by Juan J. Prieto <jjptapia@eresmas.com>
04 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> pop3vscan-0.4.ebuild:
pkg_postinstall -> pkg_postinst
diff --git a/net-mail/pop3vscan/Manifest b/net-mail/pop3vscan/Manifest
index 1fe5b76b1a1e..767b192184b0 100644
--- a/net-mail/pop3vscan/Manifest
+++ b/net-mail/pop3vscan/Manifest
@@ -1,5 +1,7 @@
-MD5 c15efb2f4eea0c87e796bc56db74e811 pop3vscan-0.4.ebuild 1286
MD5 7282fdd2a863175e434180396bc281a1 ChangeLog 897
+MD5 89125bbac93ebe0b39b48c952e0d303d pop3vscan-0.4-r1.ebuild 1382
+MD5 c15efb2f4eea0c87e796bc56db74e811 pop3vscan-0.4.ebuild 1286
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 e8716b98e8a9ebd3cc7a3eee99b11568 files/pop3vscan 617
+MD5 31dc6dee0390bf98e963a763fcb09a96 files/digest-pop3vscan-0.4-r1 138
MD5 ce149161cbc3342eec80fe74757fa41d files/digest-pop3vscan-0.4 65
diff --git a/net-mail/pop3vscan/files/digest-pop3vscan-0.4-r1 b/net-mail/pop3vscan/files/digest-pop3vscan-0.4-r1
new file mode 100644
index 000000000000..b23d01ec424e
--- /dev/null
+++ b/net-mail/pop3vscan/files/digest-pop3vscan-0.4-r1
@@ -0,0 +1,2 @@
+MD5 48783c81cf70590637993aa0082fa467 pop3vscan-0.4.tar.gz 134583
+MD5 7517d6de62137714f2a8d4098ce21fdc pop3vscan-0.4-astaro.patch.gz 80530
diff --git a/net-mail/pop3vscan/pop3vscan-0.4-r1.ebuild b/net-mail/pop3vscan/pop3vscan-0.4-r1.ebuild
new file mode 100644
index 000000000000..2dcdf98ffcf2
--- /dev/null
+++ b/net-mail/pop3vscan/pop3vscan-0.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pop3vscan/pop3vscan-0.4-r1.ebuild,v 1.1 2004/10/01 21:39:34 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="A transparent POP3-Proxy with virus-scanning capabilities."
+SRC_URI="mirror://sourceforge/pop3vscan/${P}.tar.gz
+ http://dev.gentoo.org/~ticho/portage/${P}-astaro.patch.gz"
+HOMEPAGE="http://pop3vscan.sf.net/"
+
+DEPEND="net-mail/ripmime
+ dev-libs/libpcre"
+RDEPEND="net-firewall/iptables"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+
+ # Some improvements, see bug #28504 for details (ticho 2004-10-01)
+ epatch ${WORKDIR}/${P}-astaro.patch
+
+ rm -f ${S}/ripmime/ripmime.a
+}
+
+src_compile() {
+ make || die
+}
+
+src_install () {
+ dodir /usr/sbin
+ dosbin pop3vscan
+ dodir /etc
+ insinto /etc
+ doins pop3vscan.conf pop3vscan.mail
+
+ insinto /etc/init.d
+ doins ${FILESDIR}/pop3vscan
+ fperms 755 /etc/init.d/pop3vscan
+
+ dodoc README
+}
+
+pkg_postinst() {
+ useradd -d /tmp -s /bin/false -g nogroup mail
+ dodir /var/spool/pop3vscan
+ fowners mail /var/spool/pop3vscan
+ fperms 700 /var/spool/pop3vscan
+
+ einfo "You need configure /etc/pop3vscan and /etc/pop3vscan.mail"
+ einfo "For start pop3vscan you can use /etc/init.d/pop3vscan start"
+ einfo "You need port-redirecting, a rule like:"
+ einfo "iptables -t nat -A PREROUTING -p tcp -i eth0 --dport pop3 -j REDIRECT --to 8110"
+ einfo "is enough"
+}
diff --git a/net-mail/pop3vscan/pop3vscan-0.4.ebuild b/net-mail/pop3vscan/pop3vscan-0.4.ebuild
index 88ad4e47cacf..bfa960308a93 100644
--- a/net-mail/pop3vscan/pop3vscan-0.4.ebuild
+++ b/net-mail/pop3vscan/pop3vscan-0.4.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pop3vscan/pop3vscan-0.4.ebuild,v 1.14 2004/07/15 01:52:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pop3vscan/pop3vscan-0.4.ebuild,v 1.15 2004/10/01 21:39:34 ticho Exp $
DESCRIPTION="A transparent POP3-Proxy with virus-scanning capabilities."
SRC_URI="mirror://sourceforge/pop3vscan/${P}.tar.gz"
HOMEPAGE="http://pop3vscan.sf.net/"
-DEPEND="net-mail/ripmime dev-libs/libpcre"
+DEPEND="net-mail/ripmime
+ dev-libs/libpcre"
RDEPEND="net-firewall/iptables"
SLOT="0"