summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-02-17 00:35:54 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-02-17 00:35:54 +0000
commitf0cae9ff3a02d669fa99c293363aa208c0325161 (patch)
treeed75dfefbbe5e9afca1dac552c4f9d262e4674fe /net-mail
parentFixed freetype compile errors. Fixes #15494. (diff)
downloadgentoo-2-f0cae9ff3a02d669fa99c293363aa208c0325161.tar.gz
gentoo-2-f0cae9ff3a02d669fa99c293363aa208c0325161.tar.bz2
gentoo-2-f0cae9ff3a02d669fa99c293363aa208c0325161.zip
version bump
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed/ChangeLog8
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.8.101
-rw-r--r--net-mail/sylpheed/sylpheed-0.8.10.ebuild75
3 files changed, 83 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index 4f0cf6904863..f64c881c9de1 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.28 2003/02/12 08:17:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.29 2003/02/17 00:35:54 bcowan Exp $
+
+*sylpheed-0.8.10 (16 Feb 2003)
+
+ 16 Feb 2003; Brad Cowan <bcowan@gentoo.org> sylpheed-0.8.10.ebuild,
+ files/digest-sylpheed-0.8.10:
+ Version bump.
*sylpheed-0.8.9 (17 Jan 2003)
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.8.10 b/net-mail/sylpheed/files/digest-sylpheed-0.8.10
new file mode 100644
index 000000000000..6e27ff6e7ec1
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.8.10
@@ -0,0 +1 @@
+MD5 53f32890a0582e6697f3ed2b4294b536 sylpheed-0.8.10.tar.bz2 1971996
diff --git a/net-mail/sylpheed/sylpheed-0.8.10.ebuild b/net-mail/sylpheed/sylpheed-0.8.10.ebuild
new file mode 100644
index 000000000000..d7b193bf962c
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.8.10.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.8.10.ebuild,v 1.1 2003/02/17 00:35:54 bcowan Exp $
+
+IUSE="ssl xface ipv6 nls gnome ldap crypt pda"
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ xface? ( >=media-libs/compface-1.4 )
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 =app-crypt/gpgme-0.3.14 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ x11-misc/shared-mime-info"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/shared-mime.patch
+}
+
+src_compile() {
+ local myconf
+
+ use gnome || myconf="${myconf} --disable-gdk-pixbuf --disable-imlib"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use xface || myconf="${myconf} --disable-compface"
+
+ econf ${myconf}
+
+ emake || die
+}
+
+src_install () {
+ einstall
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ if use gnome
+ then
+ dodir /usr/share/gnome/apps/Internet
+ insinto /usr/share/gnome/apps/Internet
+ doins sylpheed.desktop
+ fi
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}