summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-22 20:58:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-22 20:58:29 +0000
commitf4f4bbec46b73aee86371ac5fd24714b10024111 (patch)
tree521869ab344a06835375f73521b56abde362efa8 /net-mail
parentversion bump (diff)
downloadgentoo-2-f4f4bbec46b73aee86371ac5fd24714b10024111.tar.gz
gentoo-2-f4f4bbec46b73aee86371ac5fd24714b10024111.tar.bz2
gentoo-2-f4f4bbec46b73aee86371ac5fd24714b10024111.zip
fix sanity-checker more, and minor typo in -r15 ebuild
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/qmail/ChangeLog8
-rw-r--r--net-mail/qmail/files/config-sanity-check4
-rw-r--r--net-mail/qmail/qmail-1.03-r15.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/net-mail/qmail/ChangeLog b/net-mail/qmail/ChangeLog
index a0fd4ab7c190..33483b22bd53 100644
--- a/net-mail/qmail/ChangeLog
+++ b/net-mail/qmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/qmail
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail/ChangeLog,v 1.56 2004/01/20 21:02:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail/ChangeLog,v 1.57 2004/01/22 20:58:28 robbat2 Exp $
+
+*qmail-1.03-r15 (22 Jan 2004)
+
+ 22 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> qmail-1.03-r15.ebuild,
+ files/config-sanity-check:
+ fix sanity-checker more, and minor typo in -r15 ebuild
20 Jan 2004; Robin H. Johnson <robbat2@gentoo.org>
files/1.03-r15/qmail-pop3d-top-outputfix.patch:
diff --git a/net-mail/qmail/files/config-sanity-check b/net-mail/qmail/files/config-sanity-check
index a4441163732e..074df4b87734 100644
--- a/net-mail/qmail/files/config-sanity-check
+++ b/net-mail/qmail/files/config-sanity-check
@@ -1,6 +1,6 @@
#!/bin/sh
# Configuration Sanity Checking for qmail
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail/files/config-sanity-check,v 1.2 2004/01/20 09:35:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail/files/config-sanity-check,v 1.3 2004/01/22 20:58:29 robbat2 Exp $
# This is intended solely to stop qmail eating up all your hard disk space with logs
CONFIG_SANITY_GOOD=1
@@ -22,7 +22,7 @@ if [ ! -f ${QMAIL_CONTROLDIR}/rcpthosts -a -z "${QMAIL_DISABLE_SANITY_CHECK}" -a
CONFIG_SANITY_GOOD=0
fi
-if [ ! -f "${TCPSERVER_RULESCDB}" ]; then
+if [ "${SERVICE}" != "send" -a ! -f "${TCPSERVER_RULESCDB}" ]; then
echo "No CDB file found (${TCPSERVER_RULESCDB})"
CONFIG_SANITY_GOOD=0
fi
diff --git a/net-mail/qmail/qmail-1.03-r15.ebuild b/net-mail/qmail/qmail-1.03-r15.ebuild
index 32a64a95e38e..2f182ee71726 100644
--- a/net-mail/qmail/qmail-1.03-r15.ebuild
+++ b/net-mail/qmail/qmail-1.03-r15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail/qmail-1.03-r15.ebuild,v 1.1 2004/01/20 09:35:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail/qmail-1.03-r15.ebuild,v 1.2 2004/01/22 20:58:28 robbat2 Exp $
inherit eutils fixheadtails
@@ -443,7 +443,7 @@ pkg_preinst() {
old="/etc/tcp.${proto}${ext}"
new="${TCPRULES_DIR}/tcp.qmail-${proto}${ext}"
fail=0
- if [ -f "$old" -a ! -f "$new"]; then
+ if [ -f "$old" -a ! -f "$new" ]; then
einfo "Moving $old to $new"
cp $old $new || fail=1
else