summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-01-18 00:51:39 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-01-18 00:51:39 +0000
commitf9205d332368518732c0f06020d9d9d0eae8bbad (patch)
tree22fe50e849c536e48bd4e31ef3e2f0c1363fc263 /net-mail
parentStable on amd64 (diff)
downloadgentoo-2-f9205d332368518732c0f06020d9d9d0eae8bbad.tar.gz
gentoo-2-f9205d332368518732c0f06020d9d9d0eae8bbad.tar.bz2
gentoo-2-f9205d332368518732c0f06020d9d9d0eae8bbad.zip
Readded 6.3.3 at request of Natanael Copa <natanael.copa at gmail.com> in bug #134187 - 6.3.3 is the last version that works with uclibc.
(Portage version: 2.1.2_rc4-r8)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/ChangeLog6
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.3.ebuild90
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.3.33
3 files changed, 98 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index db87057cc49e..294ac219e9cd 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.123 2007/01/08 22:30:52 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.124 2007/01/18 00:51:39 ticho Exp $
+
+ 18 Jan 2007; Andrej Kacian <ticho@gentoo.org> +fetchmail-6.3.3.ebuild:
+ Readded 6.3.3 at request of Natanael Copa <natanael.copa at gmail.com> in
+ bug #134187 - 6.3.3 is the last version that works with uclibc.
08 Jan 2007; Torsten Veller <tove@gentoo.org>
-files/patch-6.3.2.1-fix-netrc-SIGSEGV.diff,
diff --git a/net-mail/fetchmail/fetchmail-6.3.3.ebuild b/net-mail/fetchmail/fetchmail-6.3.3.ebuild
new file mode 100644
index 000000000000..a1f3dbddc772
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.3.ebuild,v 1.5 2007/01/18 00:51:39 ticho Exp $
+
+inherit eutils
+
+FCONF_P="fetchmailconf-1.43.2"
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ssl nls ipv6 kerberos krb4 hesiod"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( app-crypt/mit-krb5 )
+ nls? ( sys-devel/gettext )
+ elibc_FreeBSD? ( sys-libs/com_err )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd \${S} failed"
+
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch ${FILESDIR}/${PN}-6.2.5-broken-headers.patch || die
+
+ autoconf
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_enable ipv6 inet6) \
+ $(use_with kerberos gssapi) $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+ # wont compile reliably on smp (mkennedy@gentoo.org 2003-11-12)
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ newinitd ${FILESDIR}/fetchmail fetchmail
+ newconfd ${FILESDIR}/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Add 'tk' to the USE variable in /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+ einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+ einfo "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.3.3 b/net-mail/fetchmail/files/digest-fetchmail-6.3.3
new file mode 100644
index 000000000000..c794525de0b5
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.3.3
@@ -0,0 +1,3 @@
+MD5 d6f6ecd02fa5c92b84d44fe031067938 fetchmail-6.3.3.tar.bz2 1197241
+RMD160 45af0dd59976779875b683a98b94f68ffed02120 fetchmail-6.3.3.tar.bz2 1197241
+SHA256 bd53e23b0210a831c9ce6765f49904e1d996aaca5d1e95ebacead35a06f3304a fetchmail-6.3.3.tar.bz2 1197241