summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-08-01 13:32:15 +0000
committerMichael Weber <xmw@gentoo.org>2012-08-01 13:32:15 +0000
commit39d1b3daf3862709163bec99a653198977100525 (patch)
treeed168e744163d1513d3b764e4b19e42aaf47ea39 /net-misc/aiccu
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-39d1b3daf3862709163bec99a653198977100525.tar.gz
gentoo-2-39d1b3daf3862709163bec99a653198977100525.tar.bz2
gentoo-2-39d1b3daf3862709163bec99a653198977100525.zip
Add uclibc fix (bug 230091), add CONFIG_CHECK for TUN.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/aiccu')
-rw-r--r--net-misc/aiccu/ChangeLog6
-rw-r--r--net-misc/aiccu/aiccu-2007.01.15-r2.ebuild7
-rw-r--r--net-misc/aiccu/files/aiccu-2007.01.15-uclibc.patch29
3 files changed, 39 insertions, 3 deletions
diff --git a/net-misc/aiccu/ChangeLog b/net-misc/aiccu/ChangeLog
index 357f80094ec7..91ed9f44de3e 100644
--- a/net-misc/aiccu/ChangeLog
+++ b/net-misc/aiccu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/aiccu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/ChangeLog,v 1.33 2012/08/01 09:37:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/ChangeLog,v 1.34 2012/08/01 13:32:14 xmw Exp $
+
+ 01 Aug 2012; Michael Weber <xmw@gentoo.org>
+ +files/aiccu-2007.01.15-uclibc.patch, aiccu-2007.01.15-r2.ebuild:
+ Add uclibc fix (bug 230091), add CONFIG_CHECK for TUN.
01 Aug 2012; Michael Weber <xmw@gentoo.org> metadata.xml:
Add Maciej Grela as maintainer.
diff --git a/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild b/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild
index 3203ddd82e98..2fabdecd399f 100644
--- a/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild
+++ b/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild,v 1.1 2012/08/01 06:39:07 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild,v 1.2 2012/08/01 13:32:14 xmw Exp $
EAPI=4
-inherit toolchain-funcs eutils
+inherit eutils linux-info toolchain-funcs
DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS"
HOMEPAGE="http://www.sixxs.net/tools/aiccu"
@@ -21,10 +21,13 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/aiccu
+CONFIG_CHECK="~TUN"
+
src_prepare() {
epatch "${FILESDIR}"/${PF}-init.gentoo.patch
epatch "${FILESDIR}"/${P}-Makefile.patch
epatch "${FILESDIR}"/${P}-setupscript.patch
+ epatch "${FILESDIR}"/${P}-uclibc.patch
}
src_compile() {
diff --git a/net-misc/aiccu/files/aiccu-2007.01.15-uclibc.patch b/net-misc/aiccu/files/aiccu-2007.01.15-uclibc.patch
new file mode 100644
index 000000000000..56341dea72f4
--- /dev/null
+++ b/net-misc/aiccu/files/aiccu-2007.01.15-uclibc.patch
@@ -0,0 +1,29 @@
+--- aiccu/common/resolver.c
++++ aiccu/common/resolver.c
+@@ -26,7 +26,7 @@
+
+ int getrrs(const char *label, int rrtype, void gotrec(unsigned int num, int type, const char *record))
+ {
+-#ifdef _LINUX
++#if defined(_LINUX) && ! defined(__UCLIBC__)
+ struct __res_state res;
+ #endif
+ unsigned char answer[8192];
+@@ -38,7 +38,7 @@
+ uint16_t type = 0, class = 0;
+ uint32_t ttl = 0;
+
+-#ifdef _LINUX
++#if defined(_LINUX) && ! defined(__UCLIBC__)
+ memset(&res, 0, sizeof(res));
+ res.options = RES_DEBUG;
+ res_ninit(&res);
+@@ -47,7 +47,7 @@
+ #endif
+
+ memset(answer, 0, sizeof(answer));
+-#ifdef _LINUX
++#if defined(_LINUX) && ! defined(__UCLIBC__)
+ ret = res_nquery(&res, label, C_IN, rrtype, answer, sizeof(answer));
+ #else
+ ret = res_query(label, C_IN, rrtype, answer, sizeof(answer));