summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-07-19 09:21:48 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-07-19 09:21:48 +0000
commit6159e756ab764ff75accdfc1712fedef8f24a4c0 (patch)
tree00646fac604edd5d8f7cdf1e6d9b9c14c75884e2 /net-misc/aria2
parentFix openssl-1 patch to work for openssl<1.0.0. See Bug #328785 (diff)
downloadgentoo-2-6159e756ab764ff75accdfc1712fedef8f24a4c0.tar.gz
gentoo-2-6159e756ab764ff75accdfc1712fedef8f24a4c0.tar.bz2
gentoo-2-6159e756ab764ff75accdfc1712fedef8f24a4c0.zip
Version bump. Dropped old patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/aria2')
-rw-r--r--net-misc/aria2/ChangeLog8
-rw-r--r--net-misc/aria2/aria2-1.10.0.ebuild86
-rw-r--r--net-misc/aria2/files/1.6.3-unaligned_pointers.patch62
3 files changed, 93 insertions, 63 deletions
diff --git a/net-misc/aria2/ChangeLog b/net-misc/aria2/ChangeLog
index 6713bbbe621e..57eef971f8c8 100644
--- a/net-misc/aria2/ChangeLog
+++ b/net-misc/aria2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/aria2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.63 2010/06/05 05:40:52 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.64 2010/07/19 09:21:48 dev-zero Exp $
+
+*aria2-1.10.0 (19 Jul 2010)
+
+ 19 Jul 2010; Tiziano Müller <dev-zero@gentoo.org>
+ -files/1.6.3-unaligned_pointers.patch, +aria2-1.10.0.ebuild:
+ Version bump. Dropped old patch.
*aria2-1.9.4 (05 Jun 2010)
diff --git a/net-misc/aria2/aria2-1.10.0.ebuild b/net-misc/aria2/aria2-1.10.0.ebuild
new file mode 100644
index 000000000000..bcd6c36b9819
--- /dev/null
+++ b/net-misc/aria2/aria2-1.10.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.10.0.ebuild,v 1.1 2010/07/19 09:21:48 dev-zero Exp $
+
+EAPI="2"
+
+DESCRIPTION="A download utility with resuming and segmented downloading with HTTP/HTTPS/FTP/BitTorrent support."
+HOMEPAGE="http://aria2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="ares bittorrent expat gnutls metalink nls scripts sqlite ssl test xmlrpc"
+
+CDEPEND="sys-libs/zlib
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.9 )
+ !gnutls? ( dev-libs/openssl ) )
+ ares? ( >=net-dns/c-ares-1.5.0 )
+ bittorrent? (
+ gnutls? ( >=net-libs/gnutls-1.2.9 >=dev-libs/libgcrypt-1.2.2 )
+ !gnutls? ( dev-libs/openssl ) )
+ metalink? (
+ !expat? ( >=dev-libs/libxml2-2.6.26 )
+ expat? ( dev-libs/expat ) )
+ sqlite? ( dev-db/sqlite:3 )
+ xmlrpc? (
+ !expat? ( >=dev-libs/libxml2-2.6.26 )
+ expat? ( dev-libs/expat ) )"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( >=dev-util/cppunit-1.12.0 )"
+RDEPEND="${CDEPEND}
+ scripts? ( dev-lang/ruby )
+ nls? ( virtual/libiconv virtual/libintl )"
+
+pkg_setup() {
+ if use scripts && use !xmlrpc && use !metalink; then
+ ewarn "Please also enable the 'xmlrpc' USE flag to actually use the additional scripts"
+ fi
+}
+
+src_prepare() {
+ sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
+}
+
+src_configure() {
+ local myconf="--without-gnutls --without-openssl"
+ use ssl && \
+ myconf="$(use_with gnutls) $(use_with !gnutls openssl)"
+
+ local xmllib="--without-libexpat --without-libxml2"
+ if use metalink || use xmlrpc ; then
+ xmllib="$(use_with expat libexpat) $(use_with !expat libxml2)"
+ fi
+
+ # Note:
+ # - depends on libgcrypt only when using gnutls
+ # - if --without-libexpat or --without-libxml2 are not given, it links against
+ # one of them to provide xmlrpc-functionality
+ # - always enable gzip/http compression since zlib should always be available anyway
+ # - always enable epoll since we can assume kernel 2.6.x
+ # - other options for threads: solaris, pth, win32
+ econf \
+ --enable-epoll \
+ --enable-threads=posix \
+ --with-libz \
+ $(use_enable nls) \
+ $(use_enable metalink) \
+ $(use_with sqlite sqlite3) \
+ $(use_enable bittorrent) \
+ $(use_with ares libcares) \
+ ${xmllib} \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm -rf "${D}/usr/share/doc/aria2"
+ dodoc ChangeLog README AUTHORS NEWS
+ dohtml README.html doc/aria2c.1.html
+
+ use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
+}
diff --git a/net-misc/aria2/files/1.6.3-unaligned_pointers.patch b/net-misc/aria2/files/1.6.3-unaligned_pointers.patch
deleted file mode 100644
index a19a0dcfe3ea..000000000000
--- a/net-misc/aria2/files/1.6.3-unaligned_pointers.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff -Naur aria2-1.6.3.orig/src/bittorrent_helper.cc aria2-1.6.3/src/bittorrent_helper.cc
---- aria2-1.6.3.orig/src/bittorrent_helper.cc 2009-11-02 15:22:22.000000000 +0100
-+++ aria2-1.6.3/src/bittorrent_helper.cc 2009-11-14 18:56:29.461122621 +0100
-@@ -774,9 +774,9 @@
- }
- struct sockaddr_in* in = reinterpret_cast<struct sockaddr_in*>(res->ai_addr);
- uint32_t* addrp = (uint32_t*)compact;
-- *addrp = in->sin_addr.s_addr;
-- uint16_t* portp = (uint16_t*)(compact+4);
-- *portp = htons(port);
-+ memcpy(addrp, &(in->sin_addr.s_addr), sizeof(uint32_t));
-+ uint16_t port_nworder(htons(port));
-+ memcpy(compact+4, &port_nworder, sizeof(uint16_t));
- freeaddrinfo(res);
- return true;
- }
-@@ -790,7 +790,7 @@
- in.sin_len = sizeof(in);
- #endif // HAVE_SOCKADDR_IN_SIN_LEN
- in.sin_family = AF_INET;
-- in.sin_addr.s_addr = *reinterpret_cast<const uint32_t*>(compact);
-+ memcpy(&(in.sin_addr.s_addr), compact, sizeof(uint32_t));
- in.sin_port = 0;
- char host[NI_MAXHOST];
- int s;
-@@ -800,7 +800,9 @@
- if(s) {
- return std::pair<std::string, uint16_t>();
- }
-- uint16_t port = ntohs(*(uint16_t*)(compact+sizeof(uint32_t)));
-+ uint16_t port_nworder;
-+ memcpy(&port_nworder, compact+sizeof(uint32_t), sizeof(uint16_t));
-+ uint16_t port = ntohs(port_nworder);
- return std::pair<std::string, uint16_t>(host, port);
- }
-
-diff -Naur aria2-1.6.3.orig/src/PeerListProcessor.h aria2-1.6.3/src/PeerListProcessor.h
---- aria2-1.6.3.orig/src/PeerListProcessor.h 2009-11-02 15:22:22.000000000 +0100
-+++ aria2-1.6.3/src/PeerListProcessor.h 2009-11-14 17:12:40.000000000 +0100
-@@ -40,6 +40,8 @@
- #include "bencode.h"
- #include "Peer.h"
-
-+#include <cstring>
-+
- namespace aria2 {
-
- class PeerListProcessor {
-@@ -83,9 +85,11 @@
- if(length%6 == 0) {
- for(size_t i = 0; i < length; i += 6) {
- struct in_addr in;
-- in.s_addr = *(uint32_t*)(peerData.s().c_str()+i);
-+ memcpy(&in.s_addr, peerData.s().c_str()+i, sizeof(uint32_t));
- std::string ipaddr = inet_ntoa(in);
-- uint16_t port = ntohs(*(uint16_t*)(peerData.s().c_str()+i+4));
-+ uint16_t port_nworder;
-+ memcpy(&port_nworder, peerData.s().c_str()+i+4, sizeof(uint16_t));
-+ uint16_t port = ntohs(port_nworder);
- *dest = SharedHandle<Peer>(new Peer(ipaddr, port));
- ++dest;
- }