summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-05-31 13:39:16 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-05-31 13:39:16 +0000
commit0e6cc97aaa24154af1794b89dc960464add786a9 (patch)
treed834e180cff3c1211a3cb88214b1fab29afbedf0 /net-misc/asterisk-app_nv_faxdetect
parentAdded freebsd mirrors for Gentoo/FreeBSD packages. (diff)
downloadgentoo-2-0e6cc97aaa24154af1794b89dc960464add786a9.tar.gz
gentoo-2-0e6cc97aaa24154af1794b89dc960464add786a9.tar.bz2
gentoo-2-0e6cc97aaa24154af1794b89dc960464add786a9.zip
Initial import
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/asterisk-app_nv_faxdetect')
-rw-r--r--net-misc/asterisk-app_nv_faxdetect/ChangeLog13
-rw-r--r--net-misc/asterisk-app_nv_faxdetect/asterisk-app_nv_faxdetect-1.0.6.ebuild49
-rw-r--r--net-misc/asterisk-app_nv_faxdetect/files/app_nv_faxdetect-1.0.6-astcfg.diff34
-rw-r--r--net-misc/asterisk-app_nv_faxdetect/files/app_nv_faxdetect-1.0.6-aststable.diff26
-rw-r--r--net-misc/asterisk-app_nv_faxdetect/files/digest-asterisk-app_nv_faxdetect-1.0.61
-rw-r--r--net-misc/asterisk-app_nv_faxdetect/metadata.xml11
6 files changed, 134 insertions, 0 deletions
diff --git a/net-misc/asterisk-app_nv_faxdetect/ChangeLog b/net-misc/asterisk-app_nv_faxdetect/ChangeLog
new file mode 100644
index 000000000000..f649df1e9107
--- /dev/null
+++ b/net-misc/asterisk-app_nv_faxdetect/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-misc/asterisk-app_nv_faxdetect
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_nv_faxdetect/ChangeLog,v 1.1 2005/05/31 13:39:16 stkn Exp $
+
+*asterisk-app_nv_faxdetect-1.0.6 (31 May 2005)
+
+ 31 May 2005; Stefan Knoblich <stkn@gentoo.org> +metadata.xml,
+ +files/app_nv_faxdetect-1.0.6-astcfg.diff,
+ +files/app_nv_faxdetect-1.0.6-aststable.diff,
+ +asterisk-app_nv_faxdetect-1.0.6.ebuild:
+ Initial import. Thanks to Josef, Joe Stroller and of course
+ Justin Newman (Newmantelecom).
+
diff --git a/net-misc/asterisk-app_nv_faxdetect/asterisk-app_nv_faxdetect-1.0.6.ebuild b/net-misc/asterisk-app_nv_faxdetect/asterisk-app_nv_faxdetect-1.0.6.ebuild
new file mode 100644
index 000000000000..b01911247f76
--- /dev/null
+++ b/net-misc/asterisk-app_nv_faxdetect/asterisk-app_nv_faxdetect-1.0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_nv_faxdetect/asterisk-app_nv_faxdetect-1.0.6.ebuild,v 1.1 2005/05/31 13:39:16 stkn Exp $
+
+inherit eutils
+
+MY_PN="app_nv_faxdetect"
+
+DESCRIPTION="Asterisk application plugins to detect incoming faxes, dtfm and voice"
+HOMEPAGE="http://www.newmantelecom.com/asterisk/faxdetect/"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="sys-libs/glibc
+ >=net-misc/asterisk-1.0.5-r1"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/app_nv_faxdetect-${PV}-astcfg.diff
+ # change callerid to asterisk stable
+ epatch ${FILESDIR}/app_nv_faxdetect-${PV}-aststable.diff
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ einfo "See"
+ einfo ""
+ einfo " http://www.voip-info.org/wiki-NVFaxDetect"
+ einfo " http://www.voip-info.org/wiki-NVBackgroundDetect"
+ einfo ""
+ einfo "for more information"
+}
diff --git a/net-misc/asterisk-app_nv_faxdetect/files/app_nv_faxdetect-1.0.6-astcfg.diff b/net-misc/asterisk-app_nv_faxdetect/files/app_nv_faxdetect-1.0.6-astcfg.diff
new file mode 100644
index 000000000000..2cb01aea7252
--- /dev/null
+++ b/net-misc/asterisk-app_nv_faxdetect/files/app_nv_faxdetect-1.0.6-astcfg.diff
@@ -0,0 +1,34 @@
+--- Makefile.orig 1970-01-01 00:00:00.000000000 +0000
++++ Makefile 2005-01-26 20:30:27.009331696 +0000
+@@ -0,0 +1,31 @@
++
++CC=gcc
++CFLAGS=$(shell /usr/bin/asterisk-config --cflags) -fPIC -DPIC
++SOLINK=$(shell /usr/bin/asterisk-config --solink)
++LIBS=
++
++ASTMODDIR=$(shell /usr/bin/asterisk-config --modulesdir)
++ASTETCDIR=$(shell /usr/bin/asterisk-config --sysconfdir)
++
++all: .depend app_nv_faxdetect.so app_nv_backgrounddetect.so
++
++.depend:
++ @if [ ! -x /usr/bin/asterisk-config ]; then \
++ echo "/usr/bin/asterisk-config not found!"; \
++ exit 255; \
++ fi
++
++.c.o:
++ $(CC) -c $(CFLAGS) -o $@ $<
++
++app_nv_faxdetect.so: app_nv_faxdetect.o
++ $(CC) $(SOLINK) -o $@ $< $(LIBS)
++
++app_nv_backgrounddetect.so: app_nv_backgrounddetect.o
++ $(CC) $(SOLINK) -o $@ $< $(LIBS)
++
++install:
++ if [ ! -d $(DESTDIR)$(ASTMODDIR) ]; then mkdir -p $(DESTDIR)$(ASTMODDIR); fi
++ install -m755 app_nv_faxdetect.so $(DESTDIR)$(ASTMODDIR)
++ install -m755 app_nv_backgrounddetect.so $(DESTDIR)$(ASTMODDIR)
++
diff --git a/net-misc/asterisk-app_nv_faxdetect/files/app_nv_faxdetect-1.0.6-aststable.diff b/net-misc/asterisk-app_nv_faxdetect/files/app_nv_faxdetect-1.0.6-aststable.diff
new file mode 100644
index 000000000000..f276d31fd101
--- /dev/null
+++ b/net-misc/asterisk-app_nv_faxdetect/files/app_nv_faxdetect-1.0.6-aststable.diff
@@ -0,0 +1,26 @@
+--- app_nv_faxdetect-1.0.6/app_nv_faxdetect.c.orig 2005-05-31 15:10:11.000000000 +0200
++++ app_nv_faxdetect-1.0.6/app_nv_faxdetect.c 2005-05-31 15:14:41.000000000 +0200
+@@ -66,8 +66,8 @@
+ "For questions or comments, please e-mail support@newmantelecom.com.\n";
+
+ // Use the second one for recent Asterisk releases
+-#define CALLERID_FIELD cid.cid_num
+-//#define CALLERID_FIELD callerid
++//#define CALLERID_FIELD cid.cid_num
++#define CALLERID_FIELD callerid
+
+ STANDARD_LOCAL_USER;
+
+--- app_nv_faxdetect-1.0.6/app_nv_backgrounddetect.c.orig 2005-05-31 15:10:21.000000000 +0200
++++ app_nv_faxdetect-1.0.6/app_nv_backgrounddetect.c 2005-05-31 15:15:09.000000000 +0200
+@@ -64,8 +64,8 @@
+ "For questions or comments, please e-mail support@newmantelecom.com.\n";
+
+ // Use the second one for recent Asterisk releases
+-#define CALLERID_FIELD cid.cid_num
+-//#define CALLERID_FIELD callerid
++//#define CALLERID_FIELD cid.cid_num
++#define CALLERID_FIELD callerid
+
+ STANDARD_LOCAL_USER;
+
diff --git a/net-misc/asterisk-app_nv_faxdetect/files/digest-asterisk-app_nv_faxdetect-1.0.6 b/net-misc/asterisk-app_nv_faxdetect/files/digest-asterisk-app_nv_faxdetect-1.0.6
new file mode 100644
index 000000000000..32133cfc532c
--- /dev/null
+++ b/net-misc/asterisk-app_nv_faxdetect/files/digest-asterisk-app_nv_faxdetect-1.0.6
@@ -0,0 +1 @@
+MD5 09ce034884cb034777999053ef8d5bc9 app_nv_faxdetect-1.0.6.tar.bz2 4959
diff --git a/net-misc/asterisk-app_nv_faxdetect/metadata.xml b/net-misc/asterisk-app_nv_faxdetect/metadata.xml
new file mode 100644
index 000000000000..55931e71d879
--- /dev/null
+++ b/net-misc/asterisk-app_nv_faxdetect/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+</maintainer>
+<longdescription>Asterisk application plugins app_nv_faxdetect to detect faxes
+and app_nv_backgrounddetect to detect faxes, dtmf and voice. Useable with all
+channel types.</longdescription>
+</pkgmetadata>