summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-25 10:17:44 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-25 10:17:44 +0000
commit84a264820239d5fc74c2b8a2486511ab6fcb96eb (patch)
tree69a3c49441402b5becfff872799338b1db2150fa /net-misc/asterisk-spandsp_codec_g726
parentAdd patch from upstream for linux 2.6.28 support. (diff)
downloadgentoo-2-84a264820239d5fc74c2b8a2486511ab6fcb96eb.tar.gz
gentoo-2-84a264820239d5fc74c2b8a2486511ab6fcb96eb.tar.bz2
gentoo-2-84a264820239d5fc74c2b8a2486511ab6fcb96eb.zip
Fixed build issue with updated spandsp library, bug #252378, thank Bruno Redondi for this fix.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'net-misc/asterisk-spandsp_codec_g726')
-rw-r--r--net-misc/asterisk-spandsp_codec_g726/ChangeLog10
-rw-r--r--net-misc/asterisk-spandsp_codec_g726/asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild7
-rw-r--r--net-misc/asterisk-spandsp_codec_g726/files/asterisk-spandsp_codec_g726-0.0.2_pre26-spanddsp.patch15
3 files changed, 27 insertions, 5 deletions
diff --git a/net-misc/asterisk-spandsp_codec_g726/ChangeLog b/net-misc/asterisk-spandsp_codec_g726/ChangeLog
index 60e3c9f34603..c6380de92f88 100644
--- a/net-misc/asterisk-spandsp_codec_g726/ChangeLog
+++ b/net-misc/asterisk-spandsp_codec_g726/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/asterisk-spandsp_codec_g726
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-spandsp_codec_g726/ChangeLog,v 1.2 2007/01/06 16:40:13 drizzt Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-spandsp_codec_g726/ChangeLog,v 1.3 2008/12/25 10:17:44 pva Exp $
+
+ 25 Dec 2008; Peter Volkov <pva@gentoo.org>
+ +files/asterisk-spandsp_codec_g726-0.0.2_pre26-spanddsp.patch,
+ asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild:
+ Fixed build issue with updated spandsp library, bug #252378, thank Bruno
+ Redondi for this fix.
06 Jan 2007; Timothy Redaelli <drizzt@gentoo.org>
asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild:
diff --git a/net-misc/asterisk-spandsp_codec_g726/asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild b/net-misc/asterisk-spandsp_codec_g726/asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild
index 2e2ee807eea1..8aa3a64c99de 100644
--- a/net-misc/asterisk-spandsp_codec_g726/asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild
+++ b/net-misc/asterisk-spandsp_codec_g726/asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-spandsp_codec_g726/asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild,v 1.2 2007/01/06 16:40:13 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-spandsp_codec_g726/asterisk-spandsp_codec_g726-0.0.2_pre26.ebuild,v 1.3 2008/12/25 10:17:44 pva Exp $
inherit eutils toolchain-funcs
@@ -27,6 +27,7 @@ do_compile() {
src_unpack() {
unpack "${A}"
+ epatch "${FILESDIR}/${P}-spanddsp.patch"
# patch include declarations
sed -e 's:^\(#include.*\)"\(asterisk/.*\)":\1<\2>:g' \
-e 's:^\(#include.*\)"\(asterisk\.h\)":\1<asterisk/\2>:g' \
@@ -41,7 +42,7 @@ src_compile() {
src_install() {
exeinto /usr/$(get_libdir)/asterisk/modules
- doexe ${LIB_CODEC_G726}.so
+ doexe ${LIB_CODEC_G726}.so || die
}
pkg_postinst() {
diff --git a/net-misc/asterisk-spandsp_codec_g726/files/asterisk-spandsp_codec_g726-0.0.2_pre26-spanddsp.patch b/net-misc/asterisk-spandsp_codec_g726/files/asterisk-spandsp_codec_g726-0.0.2_pre26-spanddsp.patch
new file mode 100644
index 000000000000..b0c825427a1f
--- /dev/null
+++ b/net-misc/asterisk-spandsp_codec_g726/files/asterisk-spandsp_codec_g726-0.0.2_pre26-spanddsp.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/show_bug.cgi?id=252378
+
+--- spandsp-0.0.2pre26_codec_g726.c 2008-12-24 13:46:26.000000000 +0100
++++ spandsp-0.0.2pre26_codec_g726.c 2008-12-24 13:53:20.000000000 +0100
+@@ -25,8 +25,10 @@
+ #include <string.h>
+ #include <unistd.h>
+
++#define SPANDSP_EXPOSE_INTERNAL_STRUCTURES /* we need g726_state_s definition */
+ #include <spandsp.h>
+
++#define _PLC_H_ /* asterisk/plc.h conflicts with spandsp/plc.h */
+ #include "asterisk.h"
+
+ ASTERISK_FILE_VERSION(__FILE__, "$Revision: 1.1 $")