summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-06 03:35:48 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-06 03:35:48 +0000
commitc7e320f23b6affd28625690b500fbe15eaedf23c (patch)
treea7f87da8afc9e92b91aee13143f1d2296b0fd98a /net-misc/capi4hylafax
parentremoved net-wireless/mcs7780 from portage (diff)
downloadgentoo-2-c7e320f23b6affd28625690b500fbe15eaedf23c.tar.gz
gentoo-2-c7e320f23b6affd28625690b500fbe15eaedf23c.tar.bz2
gentoo-2-c7e320f23b6affd28625690b500fbe15eaedf23c.zip
rev-bump, solving bug #202712.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-misc/capi4hylafax')
-rw-r--r--net-misc/capi4hylafax/ChangeLog10
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild136
-rw-r--r--net-misc/capi4hylafax/files/digest-capi4hylafax-01.03.00.99.300.96
3 files changed, 150 insertions, 2 deletions
diff --git a/net-misc/capi4hylafax/ChangeLog b/net-misc/capi4hylafax/ChangeLog
index a8bd235886f7..a4f271d864f7 100644
--- a/net-misc/capi4hylafax/ChangeLog
+++ b/net-misc/capi4hylafax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/capi4hylafax
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/capi4hylafax/ChangeLog,v 1.28 2007/11/18 01:50:26 sbriesen Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/capi4hylafax/ChangeLog,v 1.29 2008/01/06 03:35:48 sbriesen Exp $
+
+*capi4hylafax-01.03.00.99.300.9 (06 Jan 2008)
+
+ 06 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +capi4hylafax-01.03.00.99.300.9.ebuild:
+ rev-bump, solving bug #202712.
*capi4hylafax-01.03.00.99.300.7 (18 Nov 2007)
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild
new file mode 100644
index 000000000000..71fa1339ed9d
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild,v 1.1 2008/01/06 03:35:48 sbriesen Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils versionator autotools
+
+FAX_SPOOL_DIR="/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment."
+SRC_URI="mirror://debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-dialup/capi4k-utils
+ app-shells/bash
+ media-libs/tiff
+ media-libs/jpeg
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # apply debian patches + update configs
+ epatch "${WORKDIR}/${MY_P}-${MY_PV3}.diff"
+
+ # update autotools
+ eautoreconf
+
+ # fix location of fax spool
+ for i in config.faxCAPI Readme_src src/defaults.h.in debian/*.1; do
+ [ -f "${i}" ] && sed -i -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" "${i}"
+ done
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile
+
+ # fix name and location of logfile
+ sed -i -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" config.faxCAPI
+ sed -i -e "s:/tmp/capifax.log:/var/log/${PN}.log:" src/defaults.h.in config.faxCAPI
+
+ # patch man pages
+ sed -i -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" debian/*.1
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8
+}
+
+src_compile() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ dodoc AUTHORS ChangeLog Readme_src
+ newdoc debian/changelog ChangeLog.debian
+ dohtml README.html LIESMICH.html
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ elog "To use capi4hylafax:"
+ elog "Make sure that your isdn/capi devices are owned by"
+ elog "the \"uucp\" user (see udev or devfsd config)."
+ elog "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ elog "to suit your system."
+
+ if [ -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI" ]; then
+ elog
+ elog "If you're upgrading from a previous version"
+ elog "please check for new or changed options."
+ elog "A sample default config is installed as:"
+ elog "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ # install default config
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ fi
+
+ elog
+ elog "You should also check special options in:"
+ elog "/etc/conf.d/${PN}"
+ elog
+ elog "If you want to use capi4hylafax together with"
+ elog "hylafax, then please emerge net-misc/hylafax"
+ elog
+ elog "Then append the following line to your hylafax"
+ elog "config file (${FAX_SPOOL_DIR}/etc/config):"
+ elog "SendFaxCmd: /usr/bin/c2faxsend"
+}
diff --git a/net-misc/capi4hylafax/files/digest-capi4hylafax-01.03.00.99.300.9 b/net-misc/capi4hylafax/files/digest-capi4hylafax-01.03.00.99.300.9
new file mode 100644
index 000000000000..896019902d51
--- /dev/null
+++ b/net-misc/capi4hylafax/files/digest-capi4hylafax-01.03.00.99.300.9
@@ -0,0 +1,6 @@
+MD5 fa185c612b07599b6314c86192fe62fe capi4hylafax_01.03.00.99.svn.300-9.diff.gz 160179
+RMD160 a3acf04af6871e8a6ca6576ee739cba56658a285 capi4hylafax_01.03.00.99.svn.300-9.diff.gz 160179
+SHA256 5c116fcefa6604a351c31507644c26fb43e0dc89e51f97ee748a52a5eebbc4af capi4hylafax_01.03.00.99.svn.300-9.diff.gz 160179
+MD5 af2610c5219e89ef9dc47eead30276b4 capi4hylafax_01.03.00.99.svn.300.orig.tar.gz 533410
+RMD160 163374cfcaa91909a5f70169203aa6c7df6a590d capi4hylafax_01.03.00.99.svn.300.orig.tar.gz 533410
+SHA256 8c5433fda85d5f178382c0a4fbc07cf22fc22c448146a4b7a090bc6a0b1789c2 capi4hylafax_01.03.00.99.svn.300.orig.tar.gz 533410