summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-07 16:44:33 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-07 16:44:33 +0000
commit86d8758bab375a6fbeb0ac9385af466fee20e35a (patch)
tree71ec7bff9a2486f5ce3032d4fab9cc12724ace09 /net-misc/chrony
parentFix Changelog. (diff)
downloadgentoo-2-86d8758bab375a6fbeb0ac9385af466fee20e35a.tar.gz
gentoo-2-86d8758bab375a6fbeb0ac9385af466fee20e35a.tar.bz2
gentoo-2-86d8758bab375a6fbeb0ac9385af466fee20e35a.zip
Remove _pre logic since it is not effective. Patch by GerbilSoft (bug #370391) to recognise Linux 3.0.
(Portage version: 2.2.0_alpha38/cvs/Linux i686)
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/ChangeLog9
-rw-r--r--net-misc/chrony/chrony-1.25-r1.ebuild66
-rw-r--r--net-misc/chrony/chrony-1.25.ebuild8
-rw-r--r--net-misc/chrony/files/chrony-1.25-linux3.patch16
4 files changed, 92 insertions, 7 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index 06f32593f578..157eb827b3cc 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/chrony
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.70 2011/05/08 17:38:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.71 2011/06/07 16:44:33 jer Exp $
+
+*chrony-1.25-r1 (07 Jun 2011)
+
+ 07 Jun 2011; Jeroen Roovers <jer@gentoo.org> chrony-1.25.ebuild,
+ +chrony-1.25-r1.ebuild, +files/chrony-1.25-linux3.patch:
+ Remove _pre logic since it is not effective. Patch by GerbilSoft (bug
+ #370391) to recognise Linux 3.0.
08 May 2011; Tobias Klausmann <klausman@gentoo.org> files/chrony.logrotate:
Fix logrotate script (end markers for here documents have to be at the
diff --git a/net-misc/chrony/chrony-1.25-r1.ebuild b/net-misc/chrony/chrony-1.25-r1.ebuild
new file mode 100644
index 000000000000..d2bdcf4461c7
--- /dev/null
+++ b/net-misc/chrony/chrony-1.25-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.25-r1.ebuild,v 1.1 2011/06/07 16:44:33 jer Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="caps readline"
+
+RDEPEND="
+ readline? ( >=sys-libs/readline-4.1-r4 )
+ caps? ( sys-libs/libcap )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i "s:/etc/chrony\.:/etc/chrony/chrony.:g" \
+ examples/* chrony*.{1,5,8} faq.txt chrony.texi || die "sed failed"
+ epatch "${FILESDIR}"/${P}-linux3.patch
+}
+
+src_configure() {
+ tc-export CC
+ local myconf
+ use readline || myconf+=" --disable-readline"
+ #use ipv6 || myconf+=" --disable-ipv6"
+ use caps || myconf+=" --disable-linuxcaps"
+ # selfwritten configure
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${PF} \
+ ${myconf} ${EXTRA_ECONF} || die "configure failed"
+}
+
+src_compile() {
+ emake all || die "make failed"
+ emake docs || die "make docs failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm "${D}"/usr/share/doc/${PF}/COPYING || die
+ dodoc examples/chrony.{conf,keys}.example || die
+ doinfo chrony.info* || die
+
+ newinitd "${FILESDIR}"/chronyd.rc chronyd || die
+ dosed "s:the documentation directory:/usr/share/doc/${PF}/:" \
+ /etc/init.d/chronyd || die "doc sed failed"
+ newconfd "${FILESDIR}"/chronyd.conf chronyd || die
+
+ keepdir /var/{lib,log}/chrony /etc/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony.logrotate chrony
+}
diff --git a/net-misc/chrony/chrony-1.25.ebuild b/net-misc/chrony/chrony-1.25.ebuild
index eaea11c9585f..286cc66c2e5a 100644
--- a/net-misc/chrony/chrony-1.25.ebuild
+++ b/net-misc/chrony/chrony-1.25.ebuild
@@ -1,16 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.25.ebuild,v 1.1 2011/05/04 14:36:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.25.ebuild,v 1.2 2011/06/07 16:44:33 jer Exp $
EAPI=2
inherit eutils toolchain-funcs
-MY_P="${P/_pre/-pre}"
-
DESCRIPTION="NTP client and server programs"
HOMEPAGE="http://chrony.tuxfamily.org/"
-SRC_URI="http://download.tuxfamily.org/${PN}/${MY_P}.tar.gz"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -23,8 +21,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
sed -i "s:/etc/chrony\.:/etc/chrony/chrony.:g" \
examples/* chrony*.{1,5,8} faq.txt chrony.texi || die "sed failed"
diff --git a/net-misc/chrony/files/chrony-1.25-linux3.patch b/net-misc/chrony/files/chrony-1.25-linux3.patch
new file mode 100644
index 000000000000..473759f24da8
--- /dev/null
+++ b/net-misc/chrony/files/chrony-1.25-linux3.patch
@@ -0,0 +1,16 @@
+diff -ur chrony-1.25.orig//sys_linux.c chrony-1.25//sys_linux.c
+--- chrony-1.25.orig//sys_linux.c 2011-05-04 06:29:40.000000000 -0400
++++ chrony-1.25//sys_linux.c 2011-06-07 01:29:18.254878791 -0400
+@@ -1050,6 +1050,12 @@
+ LOG_FATAL(LOGF_SysLinux, "Kernel version not supported yet, sorry.");
+ }
+ break;
++ case 3:
++ /* Linux 3.0 (formerly 2.6.40) */
++ /* These don't need scaling. (similar to 2.6.28 and later) */
++ freq_scale = 1.0;
++ have_readonly_adjtime = 2;
++ break;
+ default:
+ LOG_FATAL(LOGF_SysLinux, "Kernel's major version not supported yet, sorry");
+ break;