summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-20 00:23:24 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-20 00:23:24 +0000
commit664c2216cf4d0623bc536cb98f50fabd6174be63 (patch)
tree9ab650548af691aafb4d4eb3958ce474e892afb5 /net-misc/clockspeed
parent*** empty log message *** (diff)
downloadgentoo-2-664c2216cf4d0623bc536cb98f50fabd6174be63.tar.gz
gentoo-2-664c2216cf4d0623bc536cb98f50fabd6174be63.tar.bz2
gentoo-2-664c2216cf4d0623bc536cb98f50fabd6174be63.zip
new package clockspeed-0.62
Diffstat (limited to 'net-misc/clockspeed')
-rw-r--r--net-misc/clockspeed/clockspeed-0.62.ebuild37
-rw-r--r--net-misc/clockspeed/files/clockspeed-0.62-gentoo.diff25
-rw-r--r--net-misc/clockspeed/files/digest-clockspeed-0.621
3 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/clockspeed/clockspeed-0.62.ebuild b/net-misc/clockspeed/clockspeed-0.62.ebuild
new file mode 100644
index 000000000000..1dcd62973b5f
--- /dev/null
+++ b/net-misc/clockspeed/clockspeed-0.62.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clockspeed/clockspeed-0.62.ebuild,v 1.1 2001/04/20 00:23:24 pete Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="a simple ntp client"
+SRC_URI="http://cr.yp.to/clockspeed/clockspeed-0.62.tar.gz"
+HOMEPAGE="http://cr.yp.to/"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+ cp -a conf-cc conf-cc.orig
+ sed "s/@CFLAGS@/${CFLAGS}/" < conf-cc.orig > conf-cc
+}
+
+src_compile() {
+ try make
+}
+
+src_install () {
+ dodir /etc /usr/bin /usr/share/man/man1
+ insinto /etc
+ doins leapsecs.dat
+
+ into /usr
+ dobin clockspeed clockadd clockview sntpclock taiclock taiclockd
+ doman clockspeed.1 clockadd.1 clockview.1 sntpclock.1 taiclock.1 taiclockd.1
+
+ dodoc BLURB CHANGES README THANKS TODO
+}
diff --git a/net-misc/clockspeed/files/clockspeed-0.62-gentoo.diff b/net-misc/clockspeed/files/clockspeed-0.62-gentoo.diff
new file mode 100644
index 000000000000..83e314c1627d
--- /dev/null
+++ b/net-misc/clockspeed/files/clockspeed-0.62-gentoo.diff
@@ -0,0 +1,25 @@
+diff -ur clockspeed-0.62.orig/conf-cc clockspeed-0.62/conf-cc
+--- clockspeed-0.62.orig/conf-cc Tue Oct 13 13:37:49 1998
++++ clockspeed-0.62/conf-cc Thu Apr 19 19:55:16 2001
+@@ -1,3 +1,3 @@
+-gcc -O2
++gcc @CFLAGS@
+
+ This will be used to compile .c files.
+diff -ur clockspeed-0.62.orig/conf-home clockspeed-0.62/conf-home
+--- clockspeed-0.62.orig/conf-home Tue Oct 13 13:37:49 1998
++++ clockspeed-0.62/conf-home Thu Apr 19 19:55:00 2001
+@@ -1,4 +1,4 @@
+-/usr/local/clockspeed
++/usr
+
+ This is the clockspeed home directory. Programs will be installed in
+ .../bin.
+diff -ur clockspeed-0.62.orig/conf-ld clockspeed-0.62/conf-ld
+--- clockspeed-0.62.orig/conf-ld Tue Oct 13 13:37:49 1998
++++ clockspeed-0.62/conf-ld Thu Apr 19 19:54:54 2001
+@@ -1,3 +1,3 @@
+-gcc -s
++gcc
+
+ This will be used to link .o files into an executable.
diff --git a/net-misc/clockspeed/files/digest-clockspeed-0.62 b/net-misc/clockspeed/files/digest-clockspeed-0.62
new file mode 100644
index 000000000000..8e9ac051cd77
--- /dev/null
+++ b/net-misc/clockspeed/files/digest-clockspeed-0.62
@@ -0,0 +1 @@
+MD5 425614174fcfe2ad42d22d3d02e2d567 clockspeed-0.62.tar.gz