summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-06-04 10:15:22 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-06-04 10:15:22 +0000
commit63a347bc998b1a5885551517a37bef54916037bd (patch)
treef4001b316abd9b459484c4f982945e5c7a4f5949 /net-misc/connman
parentInitial commit, wrt bug #376155 (diff)
downloadgentoo-2-63a347bc998b1a5885551517a37bef54916037bd.tar.gz
gentoo-2-63a347bc998b1a5885551517a37bef54916037bd.tar.bz2
gentoo-2-63a347bc998b1a5885551517a37bef54916037bd.zip
Version bumps. Primarily bugfixes, particularly around hidden SSID (WiFi) scanning and the command line client.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/ChangeLog10
-rw-r--r--net-misc/connman/connman-1.14.ebuild62
-rw-r--r--net-misc/connman/connman-1.15.ebuild62
3 files changed, 133 insertions, 1 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index 5314669bc5c0..c47775454252 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.62 2013/04/30 15:38:44 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.63 2013/06/04 10:15:22 chainsaw Exp $
+
+*connman-1.15 (04 Jun 2013)
+*connman-1.14 (04 Jun 2013)
+
+ 04 Jun 2013; Tony Vroon <chainsaw@gentoo.org> +connman-1.14.ebuild,
+ +connman-1.15.ebuild:
+ Version bumps. Primarily bugfixes, particularly around hidden SSID (WiFi)
+ scanning and the command line client.
*connman-1.13 (30 Apr 2013)
diff --git a/net-misc/connman/connman-1.14.ebuild b/net-misc/connman/connman-1.14.ebuild
new file mode 100644
index 000000000000..73837b1d5080
--- /dev/null
+++ b/net-misc/connman/connman-1.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.14.ebuild,v 1.1 2013/06/04 10:15:22 chainsaw Exp $
+
+EAPI="5"
+inherit base
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn policykit threads tools vpnc +wifi"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-0.7[dbus] )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps \
+ --disable-openconnect
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/connmanctl || die "client installation failed"
+
+ keepdir /var/lib/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+}
diff --git a/net-misc/connman/connman-1.15.ebuild b/net-misc/connman/connman-1.15.ebuild
new file mode 100644
index 000000000000..24b39b121e46
--- /dev/null
+++ b/net-misc/connman/connman-1.15.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.15.ebuild,v 1.1 2013/06/04 10:15:22 chainsaw Exp $
+
+EAPI="5"
+inherit base
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn policykit threads tools vpnc +wifi"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-0.7[dbus] )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps \
+ --disable-openconnect
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/connmanctl || die "client installation failed"
+
+ keepdir /var/lib/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+}