summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2010-08-03 20:29:51 +0000
committerWilliam Hubbs <williamh@gentoo.org>2010-08-03 20:29:51 +0000
commit6da17837bf3cb54527c255620b96d04517f6eef5 (patch)
treec0389323b71bed571bc8483ee6bc96f068fc2878 /net-misc/dhcpcd
parentdigest fix (diff)
downloadgentoo-2-6da17837bf3cb54527c255620b96d04517f6eef5.tar.gz
gentoo-2-6da17837bf3cb54527c255620b96d04517f6eef5.tar.bz2
gentoo-2-6da17837bf3cb54527c255620b96d04517f6eef5.zip
removed all old 5.x versions
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog6
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.0.6.ebuild89
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.1.5.ebuild84
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.2.2.ebuild85
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.2.5.ebuild85
5 files changed, 5 insertions, 344 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 6a10ee3f6d03..8e908172c575 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.281 2010/07/07 23:38:48 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.282 2010/08/03 20:29:51 williamh Exp $
+
+ 03 Aug 2010; William Hubbs <williamh@gentoo.org> -dhcpcd-5.0.6.ebuild,
+ -dhcpcd-5.1.5.ebuild, -dhcpcd-5.2.2.ebuild, -dhcpcd-5.2.5.ebuild:
+ removed all old 5.x versions
*dhcpcd-5.2.6 (07 Jul 2010)
diff --git a/net-misc/dhcpcd/dhcpcd-5.0.6.ebuild b/net-misc/dhcpcd/dhcpcd-5.0.6.ebuild
deleted file mode 100644
index a9ef1496022c..000000000000
--- a/net-misc/dhcpcd/dhcpcd-5.0.6.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.0.6.ebuild,v 1.3 2010/03/31 18:03:50 solar Exp $
-
-EAPI=1
-
-inherit toolchain-funcs eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+zeroconf elibc_glibc"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- use compat && hooks="${hooks} 50-dhcpcd-compat"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-
- elog
- elog "Users transfering from 4.0 series should pay attention to removal"
- elog "of compat useflag. This changes behavior of dhcp in wide manner:"
- elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
- elog "This is so we can re-use the address the kernel DHCP client found."
- elog "To retain the old behaviour of sending a default ClientID based on the"
- elog "hardware address for interface, simply add the keyword clientid"
- elog "to dhcpcd.conf or use commandline parameter -I ''"
-}
diff --git a/net-misc/dhcpcd/dhcpcd-5.1.5.ebuild b/net-misc/dhcpcd/dhcpcd-5.1.5.ebuild
deleted file mode 100644
index 18304638dfcc..000000000000
--- a/net-misc/dhcpcd/dhcpcd-5.1.5.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.1.5.ebuild,v 1.2 2010/03/31 18:03:50 solar Exp $
-
-EAPI=1
-
-inherit eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+zeroconf elibc_glibc"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-}
-
-src_compile() {
- local hooks="--with-hook=ntp.conf"
- use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
- econf --prefix= --libexecdir=/lib/dhcpcd --dbdir=/var/lib/dhcpcd \
- --localstatedir=/var ${hooks}
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-
- elog
- elog "Users transfering from 4.0 series should pay attention to removal"
- elog "of compat useflag. This changes behavior of dhcp in wide manner:"
- elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
- elog "This is so we can re-use the address the kernel DHCP client found."
- elog "To retain the old behaviour of sending a default ClientID based on the"
- elog "hardware address for interface, simply add the keyword clientid"
- elog "to dhcpcd.conf or use commandline parameter -I ''"
-}
diff --git a/net-misc/dhcpcd/dhcpcd-5.2.2.ebuild b/net-misc/dhcpcd/dhcpcd-5.2.2.ebuild
deleted file mode 100644
index d95cd792f2c8..000000000000
--- a/net-misc/dhcpcd/dhcpcd-5.2.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.2.2.ebuild,v 1.1 2010/04/02 04:01:52 williamh Exp $
-
-EAPI=1
-
-inherit eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+zeroconf elibc_glibc"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-}
-
-src_compile() {
- local hooks="--with-hook=ntp.conf"
- use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
- econf --prefix= --libexecdir=/lib/dhcpcd --dbdir=/var/lib/dhcpcd \
- --localstatedir=/var ${hooks}
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-
- elog
- elog "Users transfering from 4.0 series should pay attention to removal"
- elog "of compat useflag. This changes behavior of dhcp in wide manner:"
- elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
- elog "This is so we can re-use the address the kernel DHCP client found."
- elog "To retain the old behaviour of sending a default ClientID based on the"
- elog "hardware address for interface, simply add the keyword clientid"
- elog "to dhcpcd.conf or use commandline parameter -I ''"
-}
diff --git a/net-misc/dhcpcd/dhcpcd-5.2.5.ebuild b/net-misc/dhcpcd/dhcpcd-5.2.5.ebuild
deleted file mode 100644
index d0c72fd0cb0f..000000000000
--- a/net-misc/dhcpcd/dhcpcd-5.2.5.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.2.5.ebuild,v 1.1 2010/06/11 16:55:31 darkside Exp $
-
-EAPI=1
-
-inherit eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-
-SLOT="0"
-IUSE="+zeroconf elibc_glibc"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-}
-
-src_compile() {
- local hooks="--with-hook=ntp.conf"
- use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
- econf --prefix= --libexecdir=/lib/dhcpcd --dbdir=/var/lib/dhcpcd \
- --localstatedir=/var ${hooks}
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-
- elog
- elog "Users transfering from 4.0 series should pay attention to removal"
- elog "of compat useflag. This changes behavior of dhcp in wide manner:"
- elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
- elog "This is so we can re-use the address the kernel DHCP client found."
- elog "To retain the old behaviour of sending a default ClientID based on the"
- elog "hardware address for interface, simply add the keyword clientid"
- elog "to dhcpcd.conf or use commandline parameter -I ''"
-}