summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-16 12:25:45 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-16 12:25:45 +0000
commit030140e44756bf19904b29ac0ce78c61aa2eae69 (patch)
treecc5d37ae0f02e05acd8023dcceca8f4cc3a4c5cd /net-misc/dnetstats
parentFix compilation and linking on Darwin (diff)
downloadgentoo-2-030140e44756bf19904b29ac0ce78c61aa2eae69.tar.gz
gentoo-2-030140e44756bf19904b29ac0ce78c61aa2eae69.tar.bz2
gentoo-2-030140e44756bf19904b29ac0ce78c61aa2eae69.zip
Initial commit of dnetstats application
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/dnetstats')
-rw-r--r--net-misc/dnetstats/ChangeLog9
-rw-r--r--net-misc/dnetstats/dnetstats-1.2.5.ebuild49
-rw-r--r--net-misc/dnetstats/metadata.xml15
3 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/dnetstats/ChangeLog b/net-misc/dnetstats/ChangeLog
new file mode 100644
index 000000000000..082d179e9f6e
--- /dev/null
+++ b/net-misc/dnetstats/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/dnetstats
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dnetstats/ChangeLog,v 1.1 2010/01/16 12:25:45 hwoarang Exp $
+
+*dnetstats-1.2.5 (16 Jan 2010)
+
+ 16 Jan 2010; <hwoarang@gentoo.org> +dnetstats-1.2.5.ebuild, +metadata.xml:
+ Initial commit of dnetstats application
+
diff --git a/net-misc/dnetstats/dnetstats-1.2.5.ebuild b/net-misc/dnetstats/dnetstats-1.2.5.ebuild
new file mode 100644
index 000000000000..de91ee2e0abc
--- /dev/null
+++ b/net-misc/dnetstats/dnetstats-1.2.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dnetstats/dnetstats-1.2.5.ebuild,v 1.1 2010/01/16 12:25:45 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+
+MY_PN="DNetStats"
+MY_P="${MY_PN}-v${PV}-release"
+
+DESCRIPTION="Qt4 network monitor utility"
+HOMEPAGE="http://qt-apps.org/content/show.php/DNetStats?content=107467"
+SRC_URI="http://qt-apps.org/CONTENT/content-files/107467-${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}
+ kde? ( kde-base/kdesu )"
+
+src_prepare() {
+ # remove old moc_* files
+ rm -rf moc_* || die "failed to remove old moc_* files"
+}
+
+src_install() {
+ newbin mythread ${PN} || die "newbin failed"
+ dodoc ReadMe || die "dodoc failed"
+ newicon resource/energy.png ${PN}.png || die "doicon failed"
+ make_desktop_entry ${PN} DNetStats ${PN}.png 'Qt;Network;Dialup'
+ # adjust the .desktop file
+ if use kde; then
+ sed -i "/^Exec/s:${PN}:kdesu -c ${PN}:" \
+ ${D}/usr/share/applications/"${PN}"-"${PN}".desktop \
+ || die "failed to add kdesu on desktop file"
+ fi
+}
+
+pkg_postinst() {
+ if ! use kde; then
+ elog
+ elog "Root priviledges are required in order to run ${PN}"
+ elog
+ fi
+}
diff --git a/net-misc/dnetstats/metadata.xml b/net-misc/dnetstats/metadata.xml
new file mode 100644
index 000000000000..7e70f1538383
--- /dev/null
+++ b/net-misc/dnetstats/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<use>
+<flag name="kde">Use kdesu to gain root access</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+