summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-02-03 12:15:20 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-02-03 12:15:20 +0000
commitc063182acaa0f1aefb88f5aae376277e0eb8c862 (patch)
tree24a0d60ccfbe8e67271be72354959f8d1c0de5a2 /net-misc/e1000/e1000-5.2.30.1.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-c063182acaa0f1aefb88f5aae376277e0eb8c862.tar.gz
gentoo-2-c063182acaa0f1aefb88f5aae376277e0eb8c862.tar.bz2
gentoo-2-c063182acaa0f1aefb88f5aae376277e0eb8c862.zip
Version bumped.
Diffstat (limited to 'net-misc/e1000/e1000-5.2.30.1.ebuild')
-rw-r--r--net-misc/e1000/e1000-5.2.30.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/e1000/e1000-5.2.30.1.ebuild b/net-misc/e1000/e1000-5.2.30.1.ebuild
new file mode 100644
index 000000000000..f043f2e90ce5
--- /dev/null
+++ b/net-misc/e1000/e1000-5.2.30.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/e1000-5.2.30.1.ebuild,v 1.1 2004/02/03 12:15:07 mholzer Exp $
+
+DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
+HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
+LICENSE="GPL-2"
+DEPEND="virtual/linux-sources"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+SLOT="${KV}"
+KEYWORDS="~x86"
+S="${WORKDIR}/${P}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ # rem out the DEPVER line, since it would cause a sandbox violation and
+ # since it is only needed by RPM ;-)
+ sed -i "/^DEPVER :=/ d" Makefile
+}
+
+
+src_compile() {
+ check_KV
+ cd "${S}/src"
+ make KSRC=/usr/src/linux clean e1000.o
+}
+
+
+src_install() {
+ insinto "/lib/modules/${KV}/kernel/drivers/net"
+ doins "${S}/src/e1000.o"
+ doman e1000.7
+ dodoc LICENSE README SUMS e1000.spec ldistrib.txt
+ einfo ""
+ einfo "In case you have problems, loading the module, try to run depmod -A"
+ einfo ""
+}