summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-01-09 17:32:48 +0000
committerJeroen Roovers <jer@gentoo.org>2011-01-09 17:32:48 +0000
commitd27222c62501c8160d1f18aa262f1c7dfa47f100 (patch)
tree3c982d02b535559d6f5b5f70f82c43aacdb1fdb7 /net-misc/gsasl/gsasl-1.6.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-d27222c62501c8160d1f18aa262f1c7dfa47f100.tar.gz
gentoo-2-d27222c62501c8160d1f18aa262f1c7dfa47f100.tar.bz2
gentoo-2-d27222c62501c8160d1f18aa262f1c7dfa47f100.zip
Version bump (bug #311319).
(Portage version: 2.2.0_alpha14/cvs/Linux i686)
Diffstat (limited to 'net-misc/gsasl/gsasl-1.6.0.ebuild')
-rw-r--r--net-misc/gsasl/gsasl-1.6.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/gsasl/gsasl-1.6.0.ebuild b/net-misc/gsasl/gsasl-1.6.0.ebuild
new file mode 100644
index 000000000000..1b4c038d10a2
--- /dev/null
+++ b/net-misc/gsasl/gsasl-1.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/gsasl-1.6.0.ebuild,v 1.1 2011/01/09 17:32:48 jer Exp $
+
+DESCRIPTION="The GNU SASL client, server, and library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="kerberos nls static doc"
+DEPEND="nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ --enable-client \
+ --enable-server \
+ --disable-valgrind-tests \
+ $(use_enable kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable static) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "einstall failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ doman doc/gsasl.1
+
+ if use doc; then
+ dodoc doc/*.{eps,ps,pdf}
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*.c
+ fi
+}