summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-02-26 23:14:51 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-02-26 23:14:51 +0000
commita1147e6da58d027a0f3b9dd92ce16d24c1a3235d (patch)
treeb99a01c8672644d973f719404672add9757cad75 /net-misc/gwhois
parentversion bump (diff)
downloadgentoo-2-a1147e6da58d027a0f3b9dd92ce16d24c1a3235d.tar.gz
gentoo-2-a1147e6da58d027a0f3b9dd92ce16d24c1a3235d.tar.bz2
gentoo-2-a1147e6da58d027a0f3b9dd92ce16d24c1a3235d.zip
version bump
(Portage version: 2.1.2)
Diffstat (limited to 'net-misc/gwhois')
-rw-r--r--net-misc/gwhois/files/digest-gwhois-200702183
-rw-r--r--net-misc/gwhois/gwhois-20070218.ebuild44
2 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/gwhois/files/digest-gwhois-20070218 b/net-misc/gwhois/files/digest-gwhois-20070218
new file mode 100644
index 000000000000..c50828dd1dcd
--- /dev/null
+++ b/net-misc/gwhois/files/digest-gwhois-20070218
@@ -0,0 +1,3 @@
+MD5 ca900daf9c6b0b3f826332e81a36bce4 gwhois_20070218.tar.gz 31354
+RMD160 e93f464d35f8f2a8a71d26ccf2ac3cc245902905 gwhois_20070218.tar.gz 31354
+SHA256 5998cb3b61c0aca269e736b02f9e0149f5d4e6e725e9469c1fbc27e3ff018ac9 gwhois_20070218.tar.gz 31354
diff --git a/net-misc/gwhois/gwhois-20070218.ebuild b/net-misc/gwhois/gwhois-20070218.ebuild
new file mode 100644
index 000000000000..43c0e1b8fbb7
--- /dev/null
+++ b/net-misc/gwhois/gwhois-20070218.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwhois/gwhois-20070218.ebuild,v 1.1 2007/02/26 23:14:51 wschlich Exp $
+
+inherit eutils
+
+DESCRIPTION="generic whois"
+HOMEPAGE="http://gwhois.de/"
+SRC_URI="http://gwhois.de/gwhois/${P/-/_}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="www-client/lynx
+ net-misc/curl
+ dev-lang/perl
+ dev-perl/libwww-perl"
+
+src_install() {
+ dodir /etc/gwhois
+ insinto /etc/gwhois
+ doins pattern
+ dobin gwhois
+ doman gwhois.1
+ dodoc TODO "${FILESDIR}/gwhois.xinetd" README.RIPE README.upgrade
+ einfo ""
+ einfo "See included gwhois.xinetd for an example on how to"
+ einfo "use gwhois as a whois proxy using xinetd."
+ einfo "Just copy gwhois.xinetd to /etc/xinetd.d/gwhois"
+ einfo "and reload xinetd."
+ einfo ""
+}
+
+pkg_postinst() {
+ if [ -f /etc/gwhois/pattern.ripe ]; then
+ ewarn ""
+ ewarn "Will move old /etc/gwhois/pattern.ripe to removethis-pattern.ripe"
+ ewarn "as it causes malfunction with this version."
+ ewarn "If you did not modify the file, just remove it."
+ ewarn ""
+ mv /etc/gwhois/pattern.ripe /etc/gwhois/removethis-pattern.ripe
+ fi
+}