summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-07-08 08:54:50 +0000
committerMichael Weber <xmw@gentoo.org>2012-07-08 08:54:50 +0000
commitbff02b02e2bb9c750ecfe1366997faf259a7f429 (patch)
treed0eb99d27d71868046f21c334480fb02780b8212 /net-misc/hotot
parentkeyword ~alpha wrt bug #316469 (diff)
downloadgentoo-2-bff02b02e2bb9c750ecfe1366997faf259a7f429.tar.gz
gentoo-2-bff02b02e2bb9c750ecfe1366997faf259a7f429.tar.bz2
gentoo-2-bff02b02e2bb9c750ecfe1366997faf259a7f429.zip
Add REQUIRED_USE (bug 424910, thanks Diego Elio Pettenò)
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/hotot')
-rw-r--r--net-misc/hotot/ChangeLog6
-rw-r--r--net-misc/hotot/hotot-0.9.8.4.ebuild7
-rw-r--r--net-misc/hotot/hotot-0.9.8.7.ebuild7
-rw-r--r--net-misc/hotot/hotot-0.9.8.ebuild7
-rw-r--r--net-misc/hotot/hotot-9999.ebuild10
5 files changed, 18 insertions, 19 deletions
diff --git a/net-misc/hotot/ChangeLog b/net-misc/hotot/ChangeLog
index 15d91edb9b85..742c22b4dff3 100644
--- a/net-misc/hotot/ChangeLog
+++ b/net-misc/hotot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/hotot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/ChangeLog,v 1.15 2012/06/13 12:30:04 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/ChangeLog,v 1.16 2012/07/08 08:54:50 xmw Exp $
+
+ 08 Jul 2012; Michael Weber <xmw@gentoo.org> hotot-0.9.8.ebuild,
+ hotot-0.9.8.4.ebuild, hotot-0.9.8.7.ebuild, hotot-9999.ebuild:
+ Add REQUIRED_USE (bug 424910, thanks Diego Elio Pettenò)
13 Jun 2012; Michael Weber <xmw@gentoo.org> hotot-0.9.8.ebuild:
vcs-snapshot eclass
diff --git a/net-misc/hotot/hotot-0.9.8.4.ebuild b/net-misc/hotot/hotot-0.9.8.4.ebuild
index cf71f1413101..3634617820f3 100644
--- a/net-misc/hotot/hotot-0.9.8.4.ebuild
+++ b/net-misc/hotot/hotot-0.9.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.4.ebuild,v 1.2 2012/06/13 11:02:00 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.4.ebuild,v 1.3 2012/07/08 08:54:50 xmw Exp $
EAPI=4
@@ -25,13 +25,12 @@ RDEPEND="
DEPEND="${RDEPEND}
sys-devel/gettext"
+REQUIRED_USE="|| ( chrome gtk qt4 )"
+
pkg_setup() {
if ! use gtk ; then
if ! use qt4 ; then
ewarn "neither gtk not qt4 binaries will be build"
- if ! use chrome ; then
- die "enable one use flag of chrome, gtk or qt4"
- fi
fi
fi
python_pkg_setup
diff --git a/net-misc/hotot/hotot-0.9.8.7.ebuild b/net-misc/hotot/hotot-0.9.8.7.ebuild
index ae37756dc4a6..17c88d99d4e4 100644
--- a/net-misc/hotot/hotot-0.9.8.7.ebuild
+++ b/net-misc/hotot/hotot-0.9.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.7.ebuild,v 1.2 2012/06/13 11:02:00 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.7.ebuild,v 1.3 2012/07/08 08:54:50 xmw Exp $
EAPI=4
@@ -25,13 +25,12 @@ RDEPEND="
DEPEND="${RDEPEND}
sys-devel/gettext"
+REQUIRED_USE="|| ( chrome gtk qt4 )"
+
pkg_setup() {
if ! use gtk ; then
if ! use qt4 ; then
ewarn "neither gtk not qt4 binaries will be build"
- if ! use chrome ; then
- die "enable one use flag of chrome, gtk or qt4"
- fi
fi
fi
python_pkg_setup
diff --git a/net-misc/hotot/hotot-0.9.8.ebuild b/net-misc/hotot/hotot-0.9.8.ebuild
index f6f0a6a89efa..263db0aae956 100644
--- a/net-misc/hotot/hotot-0.9.8.ebuild
+++ b/net-misc/hotot/hotot-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.ebuild,v 1.4 2012/06/13 12:30:04 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.ebuild,v 1.5 2012/07/08 08:54:50 xmw Exp $
EAPI=4
@@ -25,13 +25,12 @@ RDEPEND="
DEPEND="${RDEPEND}
sys-devel/gettext"
+REQUIRED_USE="|| ( chrome gtk qt4 )"
+
pkg_setup() {
if ! use gtk ; then
if ! use qt4 ; then
ewarn "neither gtk not qt4 binaries will be build"
- if ! use chrome ; then
- die "enable one use flag of chrome, gtk or qt4"
- fi
fi
fi
python_pkg_setup
diff --git a/net-misc/hotot/hotot-9999.ebuild b/net-misc/hotot/hotot-9999.ebuild
index 869b764fde01..e145535ef7b6 100644
--- a/net-misc/hotot/hotot-9999.ebuild
+++ b/net-misc/hotot/hotot-9999.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-9999.ebuild,v 1.3 2012/03/26 09:14:57 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-9999.ebuild,v 1.4 2012/07/08 08:54:50 xmw Exp $
EAPI=4
PYTHON_DEPEND="gtk? 2"
RESTRICT_PYTHON_ABIS="3.*"
-EGIT_REPO_URI="https://github.com/shellex/Hotot.git"
-
inherit cmake-utils git-2 python
DESCRIPTION="lightweight & open source microblogging client"
HOMEPAGE="http://hotot.org"
+EGIT_REPO_URI="https://github.com/shellex/Hotot.git"
LICENSE="LGPL-3"
SLOT="0"
@@ -26,13 +25,12 @@ RDEPEND="
DEPEND="${RDEPEND}
sys-devel/gettext"
+REQUIRED_USE="|| ( chrome gtk qt4 )"
+
pkg_setup() {
if ! use gtk ; then
if ! use qt4 ; then
ewarn "neither gtk not qt4 binaries will be build"
- if ! use chrome ; then
- die "enable one use flag of chrome, gtk or qt4"
- fi
fi
fi
python_pkg_setup